[BACK]Return to patch-ac CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / fast-user-switch-applet / patches

File: [cvs.NetBSD.org] / pkgsrc / x11 / fast-user-switch-applet / patches / Attic / patch-ac (download)

Revision 1.1, Thu Mar 26 16:49:46 2009 UTC (14 years, 8 months ago) by roy
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1

We need to link against libgnomeui as dependant libs no longer do.
Fix some pkglint warnings and add PKG_DESTDIR support.

$NetBSD: patch-ac,v 1.1 2009/03/26 16:49:46 roy Exp $

--- configure	2009-03-26 16:02:51.000000000 +0000
+++ configure	2009-03-26 16:06:55.000000000 +0000
@@ -21191,6 +21191,7 @@
 PANEL_REQUIRED_VERSION=2.0.0
 GLADE_REQUIRED_VERSION=2.0.0
 GLIB_REQUIRED_VERSION=2.15.3
+GNOMEUI_REQUIRED_VERSION=2.6.0
 
 
 
@@ -21325,10 +21326,12 @@
     { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 >= \$GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= \$PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= \$GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= \$GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= \$GLIB_REQUIRED_VERSION\"") >&5
   ($PKG_CONFIG --exists --print-errors "gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION") 2>&5
   ac_status=$?
   echo "$as_me:$LINENO: \$? = $ac_status" >&5
@@ -21336,6 +21339,7 @@
   pkg_cv_APPLET_CFLAGS=`$PKG_CONFIG --cflags "gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION" 2>/dev/null`
 else
   pkg_failed=yes
@@ -21352,10 +21356,12 @@
     { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 >= \$GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= \$PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= \$GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= \$GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= \$GLIB_REQUIRED_VERSION\"") >&5
   ($PKG_CONFIG --exists --print-errors "gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION") 2>&5
   ac_status=$?
   echo "$as_me:$LINENO: \$? = $ac_status" >&5
@@ -21363,6 +21369,7 @@
   pkg_cv_APPLET_LIBS=`$PKG_CONFIG --libs "gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION" 2>/dev/null`
 else
   pkg_failed=yes
@@ -21385,11 +21392,13 @@
 	        APPLET_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION"`
         else
 	        APPLET_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION"`
         fi
 	# Put the nasty error message in config.log where it belongs
@@ -21398,6 +21407,7 @@
 	{ { echo "$as_me:$LINENO: error: Package requirements (gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION) were not met:
 
 $APPLET_PKG_ERRORS
@@ -21412,6 +21422,7 @@
 echo "$as_me: error: Package requirements (gtk+-2.0 >= $GTK_REQUIRED_VERSION
 	     libpanelapplet-2.0 >= $PANEL_REQUIRED_VERSION
 	     libglade-2.0 >= $GLADE_REQUIRED_VERSION
+	     libgnomeui-2.0 >= $GNOMEUI_REQUIRED_VERSION
 	     gio-2.0 >= $GLIB_REQUIRED_VERSION) were not met:
 
 $APPLET_PKG_ERRORS