File:  [cvs.NetBSD.org] / pkgsrc / x11 / dunst / Makefile
Revision 1.36: download - view: text, annotated - select for diffs
Sun Apr 21 15:29:52 2024 UTC (12 months ago) by wiz
Branches: MAIN
CVS tags: HEAD
dunst: update to 1.11.0.

===================================================================================
Release Notes For v1.11.0
===================================================================================

This release hopefully marks the start of a new period of active development and
contributions and a shift away from the previous lower maintenance mode.

For users:

This is the perfect time to engage with the project and other dunst users.
Some of the features and changes to include in the v2 release are starting to
be proposed or implemented. Everyone's opinion is important, so feel free
to participate in the issues proposing new features (or redesigns of the old ones).

This version mainly contains bug fixes and QoL improvements, and can be considered
a preparatory release for the various things that will come in the future
(overhaul of the rule syntax, multiple windows support, aesthetic and customization
options, refactor of the drawing system, etc).

For maintainers:

X11 support is now optional and can be disabled in build by setting the `X11` make
flag to 0. This means that you can offer Wayland-only builds.

Shell completions are now considered official and can be installed/uninstalled from
the Makefile. By default they are installed and can be disabled by setting the
`COMPLETIONS` flag to 0.

Take a look at the changelog for all the bug fixes and improvements.

# $NetBSD: Makefile,v 1.36 2024/04/21 15:29:52 wiz Exp $

DISTNAME=	dunst-1.11.0
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_GITHUB:=dunst-project/}
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://dunst-project.org/
COMMENT=	Customizable and lightweight notification-daemon
LICENSE=	modified-bsd

USE_TOOLS+=	bash:test gmake pod2man pkg-config

# PASS test_notification_referencing:  (0 ticks, 0.000 sec)
# bash: line 2: 14069 Segmentation fault      (core dumped) ./test/test -v
#      11348 Done                    | ./test/greenest.awk
# gmake: *** [Makefile:76: test] Error 139
TEST_TARGET=	test

MAKE_FLAGS+=	SYSTEMD=0
MAKE_FLAGS+=	WAYLAND=0

REPLACE_SH+=	contrib/progress-notify.sh
REPLACE_BASH+=	contrib/dunst_xr_theme_changer.sh
REPLACE_BASH+=	test/test-install.sh

SUBST_CLASSES+=			fix-paths
SUBST_STAGE.fix-paths=		pre-configure
SUBST_MESSAGE.fix-paths=	Fixing absolute paths.
SUBST_FILES.fix-paths=		dunstrc docs/dunst.1.pod
SUBST_FILES.fix-paths+=		docs/dunst.5.pod
SUBST_FILES.fix-paths+=		src/icon-lookup.c
SUBST_FILES.fix-paths+=		src/settings_data.h
SUBST_SED.fix-paths+=		-e 's,/usr/local/share/:/usr/share/,${PREFIX}/share,g'
SUBST_SED.fix-paths+=		-e 's,/usr/bin,${PREFIX}/bin,g'
SUBST_SED.fix-paths+=		-e 's,/usr/share,${PREFIX}/share,g'

INSTALL_ENV+=	MANPREFIX=${PREFIX}/${PKGMANDIR}
INSTALL_ENV+=	SYSCONFDIR=${PREFIX}/share

INSTALLATION_DIRS+=	bin
INSTALLATION_DIRS+=	${PKGMANDIR}/man1
INSTALLATION_DIRS+=	${PKGMANDIR}/man5
INSTALLATION_DIRS+=	share/dbus-1/services
INSTALLATION_DIRS+=	share/dunst
INSTALLATION_DIRS+=	share/bash-completion/completions
INSTALLATION_DIRS+=	share/zsh/site-functions
INSTALLATION_DIRS+=	share/fish/vendor_completions.d

.include "../../devel/pango/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../sysutils/libnotify/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXScrnSaver/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXrandr/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>