[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / alacritty

File: [cvs.NetBSD.org] / pkgsrc / x11 / alacritty / Makefile (download)

Revision 1.17, Fri Oct 14 07:51:59 2022 UTC (17 months, 2 weeks ago) by pin
Branch: MAIN
Changes since 1.16: +10 -6 lines

x11/alacritty: update to 0.11.0


Alacritty Version 0.11.0
Packaging
 - Minimum Rust version has been bumped to 1.57.0
 - Renamed io.alacritty.Alacritty.appdata.xml to
   org.alacritty.Alacritty.appdata.xml
 - Renamed io.alacritty to org.alacritty for Alacritty.app

Added
 - Track and report surface damage information to Wayland compositors
 - Escape sequence for undercurl, dotted and dashed underlines
   (CSI 4 : [3-5] m)
 - ToggleMaximized key binding action to (un-)maximize the active window,
   not bound by default
 - Support for OpenGL ES 2.0
 - Escape sequence to set underline color
   (CSI 58 : 2 : Ps : Ps : Ps m/CSI 58 : 5 : Ps m)
 - Escape sequence to reset underline color (CSI 59 m)
 - Vi mode keybinding (z) to center view around vi mode cursor
 - Accept hexadecimal values starting with 0x for --embed
 - Config option cursor.blink_timeout to timeout cursor blinking after
   inactivity
 - Escape sequence to set hyperlinks (OSC 8 ; params ; URI ST)
 - Config hints.enabled.hyperlinks for hyperlink escape sequence hint highlight
 - window.decorations_theme_variant to control both Wayland CSD and GTK theme
   variant on X11
 - Support for inline input method

Changed
 - No longer renders to macos and x11 windows that are fully occluded / not
   directly visible
 - The --help output was reworked with a new colorful syntax
 - OSC 52 is now disabled on unfocused windows
 - SpawnNewInstance no longer inherits initial --command
 - Blinking cursor will timeout after 5 seconds by default
 - Deprecated colors.search.bar, use colors.footer_bar instead
 - On macOS, Alacritty now reads AppleFontSmoothing from user defaults to
   control font smoothing
 - Warn when either columns or lines is non-zero, but not both
 - Client side decorations should have proper text rendering now on Wayland
 - Config option window.gtk_theme_variant, you should use
   window.decorations_theme_variant instead
 - --class now sets both class part of WM_CLASS property and instance
 - --class's general and instance options were swapped
 - Search bar is now respecting cursor thickness
 - On X11 the IME popup window is stuck at the bottom of the window due to Xlib
   limitations
 - IME no longer works in Vi mode when moving around

Fixed
 - Creating the IPC socket failing if WAYLAND_DISPLAY contains an absolute path
 - Crash when resetting the terminal while in vi mode
 - font.glyph_offset not live reloading
 - Failure when running on 10-bit color system
 - The colors being slightly different when using srgb displays on macOS
 - Vi cursor blinking not reset when navigating in search
 - Scrolling and middle-clicking modifying the primary selection
 - Bottom gap for certain builtin box drawing characters
 - Incorrect built-in glyphs for U+2567 and U+2568
 - Character mappings in the DEC special graphics character set (line drawing)
 - Window flickering on resize on Wayland
 - Unnecessary config reload when using /dev/null as a config file
 - Windows Open Alacritty Here on root of drive displaying error
 - On macOS, font.use_thin_strokes did not work since Big Sur
 - On macOS, trying to load a disabled font would crash
 - On macOS, Alacritty sessions did not appear in the list of tty sessions
   for w and who
 - Cursor not hiding on GNOME Wayland
 - Font having different scale factor after monitor powering off/on on X11
 - Viewport not updating after opening a new tabbed window on macOS
 - Terminal not exiting sometimes after closing all windows on macOS
 - CPU usage spikes due to mouse movements for unfocused windows on X11/Windows
 - First window on macOS not tabbed with system prefer tabs setting
 - Window being treaten as focused by default on Wayland

Removed
 - font.use_thin_strokes config field; to use thin strokes on macOS, set
 - AppleFontSmoothing to 0 with $ defaults write -g AppleFontSmoothing -int 0

# $NetBSD: Makefile,v 1.17 2022/10/14 07:51:59 pin Exp $

DISTNAME=	alacritty-0.11.0
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_GITHUB:=alacritty/}
GITHUB_TAG=	refs/tags/v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/alacritty/alacritty
COMMENT=	Cross-platform, GPU-accelerated terminal emulator
LICENSE=	apache-2.0

BUILD_DEPENDS+=		cmake-[0-9]*:../../devel/cmake
BUILD_DEPENDS+=		${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat

.include "cargo-depends.mk"

WRKSRC=			${WRKDIR}/${DISTNAME}

USE_LANGUAGES+=		c c++
USE_TOOLS+=		gmake pkg-config	# for fontconfig-sys

MAKE_ENV+=	OPENSSL_DIR=${BUILDLINK_PREFIX.openssl:Q}

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} != "Darwin"
RUSTFLAGS+=	-C link-arg=${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.libxcb}/lib
RUSTFLAGS+=	-C link-arg=${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.fontconfig}/lib
RUSTFLAGS+=	-C link-arg=${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.freetype2}/lib
.endif

.if ${OPSYS} == "NetBSD" && exists(${X11BASE}/lib/X11/locale/lib/common/xlcUTF8Load.so)
# This works around XIM errors when RTLD local-binding libX11.
# https://mail-index.netbsd.org/tech-x11/2021/07/12/msg002222.html
# https://mail-index.netbsd.org/source-changes/2021/07/13/msg130884.html
SUBST_CLASSES+=		rtld
SUBST_MESSAGE.rtld=	amend RTLD_GLOBAL
SUBST_STAGE.rtld=	pre-configure
SUBST_FILES.rtld=	../vendor/x11-dl-2.19.1/src/link.rs
SUBST_SED.rtld=		-e 's,libc::RTLD_LAZY,& | libc::RTLD_GLOBAL,g'
.endif

# The xcb crate depends on any version of python 3.
PYTHON_VERSIONS_INCOMPATIBLE=	27
PYTHON_FOR_BUILD_ONLY=		tool

INSTALLATION_DIRS=	bin share/examples/alacritty ${PKGMANDIR}/man1

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/alacritty \
		${DESTDIR}${PREFIX}/bin
	${INSTALL_DATA} ${WRKSRC}/alacritty.yml \
		${DESTDIR}${PREFIX}/share/examples/alacritty
	${INSTALL_MAN} ${WRKSRC}/extra/alacritty.man \
		${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/alacritty.1
	${INSTALL_MAN} ${WRKSRC}/extra/alacritty-msg.man \
		${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/alacritty-msg.1

.include "../../lang/python/tool.mk"
.include "../../lang/rust/cargo.mk"
.include "../../security/openssl/buildlink3.mk"
.if ${OPSYS} != "Darwin"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../x11/libxcb/buildlink3.mk"
.include "../../x11/libxkbcommon/buildlink3.mk"
.endif
.include "../../mk/bsd.pkg.mk"