The NetBSD Project

CVS log for pkgsrc/x11/Xbae/PLIST

[BACK] Up to [] / pkgsrc / x11 / Xbae

Request diff between arbitrary revisions

Default branch: MAIN

Revision 1.8 / (download) - annotate - [select for diffs], Sun Jun 14 18:24:43 2009 UTC (14 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, HEAD
Changes since 1.7: +1 -4 lines
Diff to previous 1.7 (colored)

Remove @dirrm entries from PLISTs

Revision 1.7 / (download) - annotate - [select for diffs], Thu Feb 16 18:09:27 2006 UTC (17 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.6: +1 -2 lines
Diff to previous 1.6 (colored)

Do not remove share/aclocal, it's in the *dist files.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Feb 18 14:51:01 2005 UTC (18 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2, pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.5: +122 -3 lines
Diff to previous 1.5 (colored)

Update to 4.51.01:
Code cleanup, some bugfixes. Ran out of numbers so the new
version number is now somewhat strange.

Revision 1.5 / (download) - annotate - [select for diffs], Tue Nov 23 17:04:15 2004 UTC (19 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.4: +49 -29 lines
Diff to previous 1.4 (colored)

Update to 4.50.99:

Intermediate release 4.50.99
* Changed the configuration file for the build. The auto(conf|make) people
  changed their API so we changed our build.
* The string-to-pixel-table converter had gone missing; fixed.
* Several resources were not getting treated in SetValues and GetValues.
  Some must have been disabled for a while, several others died because
  moving them into the per-cell structure had the side-effect that they
  weren't any regular widget resources any more.
  I'm afraid this was oversight on my behalf during the per-cell conversion.
* Changed the functionality of drawCellCallback slightly: we're now initializing
  the callback structure with the cell contents. If the callback doesn't
  alter anything, something will still end up getting displayed.
* New work from Tobias Oed :
  - setlabel.patch corrects the buggy logic of XbaeSetRowLabel (and ColumnLabel).
  - SCROLLBAR_TOP.patch introduces two simple macros to make things a bit more readable
  - clips.patch redraws the left/right/bottom/top clips in the same way the clipchild is
    redrawn. IMHO it makes things cleaner and avoids redrawing the partially
    fixed cells twice in some cases. Also fixes bugs when deleting a row/col
    makes the matrix scroll.
  - ClearCell.patch fixes a small bug I introduced in GetCellClip.patch (one of the draw
    examples crashes).
  - deadspace-clipmask.patch redraws the dead space similarly to the labels (they are
    both drawn on the matrix). This makes things cleaner as now everything gets redrawn
    the way clipped cells are or the way labels are. It also eliminates the need to redraw
    the last non fixed row/columns to get the dead space to be drawn. It kills
    calcVertfill/calcHorzfill and removes a bunch of unnecessary
  - xbaeSetClipMask calls
    and simplifies that function. It gets the shadow to span the dead space (when there are
    trailing attached rows/columns) and  one of XmGRID_ROW_SHADOW etc are set.
    It simplifies the way a highlights are drawn and deprecates HighLightOther but these
    do not span the dead space yet.
* Protect against passing gadgets as cell widgets for now, because we don't have the
  right support for them yet.
* More work from Tobias :
  - refresh.patch adds stuff I missed in GetCellClip.patch that leads to this bug: start
    choice, add some (trailing)fixed columns, set cell margin heigtht to 10, scroll to the
    bottom of the matrix and then reduce the margin height. The fixed column don't get
    updated right.
  - left_column.patch. Do the same thing with the above patch applied.  Everything gets
    updated correctly now, but the scrolling is somewhat erratic. This patch fixes this by
    making left_column/top_row 'fake' resources (like cells now is). It relies on the assumption
    that SetValuesHook gets called after SetValues. If someone has a better X doc than me, let
    me know if this is safe.
  - filletc.patch gets the fill(s)/trailing attached to work under all combinations of these
    options and shadow types according to spec (these are wierd). The approach I started
    to take in deadspace-clipmask.patch was a hopless nightmare and this is much simpler. It makes
    the fill part of the cell that preced it. To accomodate this, the size of the clips is changed.
    It removes the more obscure macros (Sir Silly Macro's) and introduces new ones
    VISIBLE_FIXED_*_{HEIGHT|WIDTH}. The new version of exaples/add lets you try the stuff out.
  - renamemacro.patch does the renaming I suggested.
  - rowlabelwidth.patch fixes the calculation of the row label width as it included
    cell_shadow_thickness twice when the labels were buttons.
  - labelClip.patch - This patch puts the scrollable parts of labels in their own clips. It adds
    two clips and two scrollMgrs but on the other hand kills 3 gcs and the matrix scrollMgr.
    Now everything that scrolls is treated the same way and we have as many scrollMgrs as clips.
    Time to put them in the clip.
  - This patch fixes a few more problems due to the per_cell change of arcad: Set/GetValuesHook
    were missing some items and SetValuesHook wasn't updating the display.
    I also changes the semantics of per_cell[][].shadow_type a bit: a value of 0 now
    means to use the default matrix.cell_shadow_type. Unfortunately there is no
    XmUNSPECIFIED_SHODOW so this may not work on all motif flaviours. On
    the other hand, the values currently used come from two different motif enums
    so it's either already broken or safe.This gets that part of examples/choice to work again.
    I modified examples/choice to get the Arm option to work again (You can't just
    fiddle with what GetValues returned for cellBackgrounds and cellShadowTypes
    and do a redisplay, you need to SetValues what you changed). I also fixed the
    memory leaks that every other third party app will suffer after a GetValues of
    these resources. That probably needs to be documented somewhere.
  - fifteen.patch gets the shadow to follow the empty cell again and fixes some memory leaks
    (same thing as my latest changes to choice.c, all other examples are OK)
  - labelClipfix.patch fixes a bug I introduced in labelClip.patch (very apparent when scrollbars
    are TOP and/or LEFT). I had to remove some XClearArea calls from resize() . I had doubts about
    them for a while: they were using outdated values. I also decided to have labels clear their
    'cell' before redrawing and collapsed drawXmLlabel into drawLabel.
  - ClearArea breaks relayout out of resize and removes all calls to
    XClearArea from these functions, adding them to add/delete row/column.
    This hopefully gets all that working. It also eliminates private header
    dependence of some examples allowing to remove xbaeClearCell.
  - CopyPerCell.patch replaces calls to xbaeCopyPerCell by xbaeCreatePerCell
    where apropriate. After that there is a call to copypercell left in a dead
    piece of code and another one that is commented out. So I killed the dead
    code and the whloe xbaeCopyPerCell function.
  - userWidget.patch: (at least) since the new XbaeMatrixSetUserWidget apeared,
    user widgets can be treated just like the text widget and xbaeMoveUserWidget
    is not needed anymore.
* Fixes from Michel Bardiaux :
  - allow build using an older gcc (still the official compiler in Debian)
  - fix a 'BadWindow' happening with the following sequence:
	create a widget as child of matrix
* Another one from Tobias : The first part makes the scroll managers part of the clips,
  and the second part isolates all the scrolling to the clips widgets.
* Change the signature of XbaeMatrixGetCellPixmap so it has a return code.
* Implement XbaeMatrixSortRows() as the same function as XbaeMatrixSort().
  Maybe the latter should disappear.
* Document the new interfaces from Arcad.
* Include code for creating a DLL under the Exceed environment.
  Until we figure out how to auto-detect Exceed, a flag should be passed to configure
  to enable this.

Intermediate release 4.50.97

Revision 1.4 / (download) - annotate - [select for diffs], Wed Sep 22 08:09:57 2004 UTC (19 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.3: +1 -5 lines
Diff to previous 1.3 (colored)

Mechanical changes to package PLISTs to make use of LIBTOOLIZE_PLIST.
All library names listed by *.la files no longer need to be listed
in the PLIST, e.g., instead of:


one simply needs:


and will automatically ensure that the additional library
names are listed in the installed package +CONTENTS file.

Also make LIBTOOLIZE_PLIST default to "yes".

Revision 1.3 / (download) - annotate - [select for diffs], Mon Dec 9 16:01:54 2002 UTC (20 years, 11 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1, pkgsrc-2003Q4-base, pkgsrc-2003Q4, netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Replace "true" by "${TRUE}".

Revision 1.2 / (download) - annotate - [select for diffs], Fri Feb 15 10:13:05 2002 UTC (21 years, 9 months ago) by skrll
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.1: +3 -3 lines
Diff to previous 1.1 (colored)

mkdir -> ${MKDIR}
rmdir -> ${RMDIR}
rm -> ${RM} (${RM} added to PLIST_SUBST)
chmod -> ${CHMOD}
chown -> ${CHOWN}

Revision 1.1 / (download) - annotate - [select for diffs], Wed Oct 31 22:10:27 2001 UTC (22 years, 1 month ago) by zuntum
Branch: MAIN

Move pkg/ files into package's toplevel directory

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

CVSweb <>