[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / Xaw3d

File: [cvs.NetBSD.org] / pkgsrc / x11 / Xaw3d / Attic / Makefile (download)

Revision 1.47, Sat Mar 4 21:31:07 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.46: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.47 2006/03/04 21:31:07 jlam Exp $
#

DISTNAME=	Xaw3d-1.5E
PKGREVISION=	1
CATEGORIES=	x11
MASTER_SITES=	ftp://ftp.visi.com/users/hawkeyd/X/

MAINTAINER=	pkgsrc-users@NetBSD.org
#HOMEPAGE=	http://www.visi.com/~hawkeyd/xaw3d.html
COMMENT=	3-D widgets based on the Athena Widget set

CONFLICTS=	Xaw-Xpm-[0-9]*

PKG_INSTALLATION_TYPES=	overwrite pkgviews

WRKSRC=		${WRKDIR}/xc/lib/Xaw3d
USE_IMAKE=	YES
PLIST_SRC=	${WRKDIR}/PLIST-src

.include "../../mk/bsd.prefs.mk"

.if empty(X11BASE:M*openwin)
post-extract:
	@(cd ${WRKSRC}; ${LN} -s .. X11)
.else
IMAKE_FLAGS+=	-DXISOPENWIN
.endif

XMKMF_FLAGS+=	${IMAKE_FLAGS}

PLIST_SUBST+=	INCDIR=include/X11

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/Xaw3d
	${INSTALL_DATA} ${WRKSRC}/README.XAW3D ${PREFIX}/share/doc/Xaw3d
	${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
.if ${OPSYS} == "IRIX"
	${INSTALL_DATA} /usr/lib${ABI}/libXaw3d* ${PREFIX}/lib/
	${RM} -f /usr/lib${ABI}/libXaw3d*
.endif
	cd ${PREFIX} && ${LS} lib/libXaw3d* >>${PLIST_SRC}

.include "../../graphics/xpm/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"