[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / webkit24-gtk

File: [cvs.NetBSD.org] / pkgsrc / www / webkit24-gtk / Makefile (download)

Revision 1.29, Sun Dec 15 15:38:59 2019 UTC (21 months, 1 week ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.28: +2 -2 lines

Bump PKGREVISION by change of default Ruby version

Bump PKGREVISION by change of default Ruby version from 2.4.x to 2.6.x.
These packages are depends on Ruby in some ways.

# $NetBSD: Makefile,v 1.29 2019/12/15 15:38:59 taca Exp $

PKGREVISION= 25
.include "Makefile.common"

PKGNAME=	${DISTNAME:S/webkitgtk/webkit24-gtk/}

COMMENT=	GTK2 port of the WebKit browser engine (version 2.4)

CONFIGURE_ARGS+=	--with-gtk=2.0
CONFIGURE_ARGS+=	--disable-webkit2

.if ${OPSYS} == "NetBSD" && ${MACHINE_CPU:U} == "arm"
LDFLAGS+=	-Wl,-no-keep-memory -Wl,-reduce-memory
.endif

#introspection support
BUILDLINK_API_DEPENDS.gtk2+=	gtk2+>=2.24.17nb3
.include "../../x11/gtk2/buildlink3.mk"
.include "../../graphics/cairo-gobject/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"