The NetBSD Project

CVS log for pkgsrc/www/webkit-gtk/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / webkit-gtk

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2014Q3-base


Revision 1.86 / (download) - annotate - [select for diffs], Sun Aug 3 22:30:05 2014 UTC (9 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.85: +1 -2 lines
Diff to previous 1.85 (colored)

Update to 2.4.4, the latest stable release. Based on work by
Leonardo Taccari in wip.

Changes:

=================
WebKitGTK+  2.4.4
=================

What's new in WebKitGTK+ 2.4.4?

  - Fix annoying popup shown when visiting 8tracks.com.
  - Expose links rendered as blocks to accessibility.
  - Make text inside "span" block in "a" block accessible.
  - Implement windowed plugins visibility.
  - Fix the GObject introspection annotations of webkit_web_resource_get_data_finish().
  - Fix a crash in TSymbolTableLevel::~TSymbolTableLevel when WebKit
    is built with GCC 4.9.
  - Fix a crash when playing a video in facebook.
  - Several user agent changes to fix Google Maps and a few other issues.
  - Allo to include WebKitVersion.h from web extensions API too.
  - Fix web process leak when closing pages with network process enabled.
  - Fix the build with --disable-webgl --disable-accelerated-compositing.

=================
WebKitGTK+  2.4.3
=================

What's new in WebKitGTK+ 2.4.3?

  - Fix video playback rate used when resuming in GStreamer media backend.
  - Use GstMetaVideo as announced by WebKitVideoSink to fix some
    decoders and filters that rely on buffer's meta rather that in the
    caps structures.
  - Do not pass a valid pointer as redirected-response parameter to
    WebKitWebPage::send-request signal when not redirecting.
  - Add missing files to the build required for building in Windows.

=================
WebKitGTK+  2.4.2
=================

What's new in WebKitGTK+ 2.4.2?

  - Correctly handle TLS errors in case of a server redirection.
  - Fix a crash when submitting a form.
  - Fix several JavaScriptCore crashes when browsing facebook.
  - Fix a crash when closing a page with windowed plugins.
  - Fix a crash after getting web view context property with g_object_get.
  - Fix a new[] delete[] mismatch in SocketStreamHandleSoup.

=================
WebKitGTK+  2.4.1
=================

What's new in WebKitGTK+ 2.4.1?

  - Add CORS support for media elements to GStreamer media backend.
  - Fix wrong flags used in fcntl call that failed in FreeBSD.
  - Correctly handle HTTP authentication for cross-origin requests.
  - Correctly handle cookies for cross-origin requests.
  - Fix a crash in the plugin process with some plugins that redefine
    NPN functions.
  - Fix acceletared video when the video format has an alpha component.
  - Fix sites using geolocation after reloading when using Geoclue2.
  - Append Safari version to UserAgent to fix redirections in
    www.globalforestwatch.org.

=================
WebKitGTK+  2.4.0
=================

What's new in WebKitGTK+ 2.4.0?

  - Fix infinite loop in WebProcess due to a race condition that can
    happen when the socket event source is cancelled.
  - Fix more runtime critical warnings about main loop sources not found
    when trying to remove them.
  - Lower the timeout used when waiting for the ShoulTerminate reply
    in the WebProcess to release unused processes earlier.
  - Fix the build for non X11 platforms.

=================
WebKitGTK+ 2.3.92
=================

What's new in WebKitGTK+ 2.3.92?

  - Add support for Geoclue2.
  - Always finalize the soup session object when the networking
    process finishes.
  - Make sure the web process doesn't finish if there's an ongoing
    print operation.
  - Fix runtime critical warnings about main loop sources not found
    when trying to remove them.
  - Fixed several crashes in JavaScriptCore when visiting facebook.
  - Improve CSS properties performance.
  - Fix web process leak when the WebView is leaked by the application.
  - Fix the build when using vala bindings due to UI and web process
    main headers included together.

=================
WebKitGTK+ 2.3.91
=================

What's new in WebKitGTK+ 2.3.91?

  - Use a persistent cache for plugins metadata to avoid blocking the
    UI while scanning plugins during page loads.
  - Make the web inspector always load in multiprocess mode.
  - Add a pkg-config file for WebKit2 web process extensions API.
  - Fix the generation of g_return macros for GObject DOM bindings in
    some cases where non pointer parameters were handled as pointers.
  - Enable DFG_JIT on FreeBSD.
  - Use system default compiler instead of gcc when building DOM
    generated sources.
  - Several build fixes for FreeBSD.
  - Fix the build with wayland support enabled.

=================
WebKitGTK+ 2.3.90
=================

What's new in WebKitGTK+ 2.3.90?

  - Add initial touch support to WebKit2.
  - Add API to create a WebKitWebView related to another one to share
    the same Web Process.
  - Create the inspector view using the same web process as the
    inspected page.
  - Fix wrong mix of fcntl commands and flags in WebKit2.
  - Fix marshaller used in WebKitWebPage::document-loaded signal.
  - Fix a crash in GStreamer media backend when playback rate is too high.
  - Fix the build on FreeBSD.

=================
WebKitGTK+  2.3.5
=================

What's new in WebKitGTK+ 2.3.5?

  - Add API to allow setting a multiple web process model.
  - Add API to pass initialization user data from the UI process to
    the web extensions.
  - Implement languages support with network process.
  - Implement custom URI schemes with network process.
  - Disable MemoryCache when the DOCUMENT_VIEWER cache model is set.
  - Expose aria-describedby with ATK_RELATION_DESCRIBED_BY.
  - Fix a bug that prevented from entering fullscreen again in HTML5
    videos after fullscreen was left with ESC.
  - Set playback rate when pipeline is not ready in GStreamer media backend.
  - Fix a lockup when playing Icecast radio in GStreamer media backend.
  - Fix a web process crash when a download is cancelled.
  - Fix several crashes when printing via JavaScript.

=================
WebKitGTK+  2.3.4
=================

What's new in WebKitGTK+ 2.3.4?

  - Add API to WebKitResponsePolicyDecision to check if the MIME type
    can be shown.
  - Enable fullscreen API by default.
  - Fix handling of HTTP certificates with the network process enabled.
  - Fix downloads with the network process enabled.
  - Fix handling of cookies when network process is enabled.
  - Remove the partial file downloaded when the download operation
    fails or is cancelled.
  - Make WebKitWebPage::send-request signal work after a redirect.
  - Add xdg.origin.url extended attribute to downloads in WebKit2.
  - Fix WebGL with GLES.
  - Translation updates: Dutch, Brazilian Portuguese.

=================
WebKitGTK+  2.3.3
=================

What's new in WebKitGTK+ 2.3.3?

  - Initial Network Process support disabled by default.
  - CSS regions are now enabled by default.
  - Support right-side attachment of the inspector in WebKit2.
  - Add spatial navigation setting to WebKit2 GTK+ API.
  - Add media source setting to both WebKit1 and WebKit2.
  - Support custom types for drag and drop data.
  - Avoid extra copy when drawing images in cairo backend.
  - Fix scrolling in combo boxes when the dropdown menu is larger than
    the screen.
  - Render AC layers also when using GTK+ 2 in WebKit1.
  - Fix return value of webkit_web_view_get_view_source_mode() in
    WebKit1.
  - Emit stream-start, caps and segment events in webkitwebaudiosrc
    element.
  - Fix seeking on media content provided by servers not supporting
    range requests.
  - Fix a crash when using media source in GStreamer media backend.
  - Fix an X11 error when the backing store surface is destroyed.
  - Expose splitter elements with ATK_ROLE_SEPARATOR to accessibility.
  - Expose accessibility objects WAI-ARIA landmark roles.
  - Expose accessibility objects with ATK_ROLE_ARTICLE.
  - Expose accessibility objects with ATK_ROLE_CHECK_MENU_ITEM.
  - Remove support for GStreamer 0.10.
  - Memory leak due to incorrect use of gst_tag_list_merge in
    TextCombinerGStreamer.
  - Translation updates: Brazilian Portuguese.

=================
WebKitGTK+  2.3.2
=================

What's new in WebKitGTK+ 2.3.2?

  - Add enable-media-stream setting to WebKit2 GTK+ API.
  - Fix a crash when load fails due to SSL errors in WebKit2.
  - Fix a crash when printing via JavaScript in WebKit2.
  - Add support audio and video tracks to GStreamer media backend.
  - Properly expose video and audio elements to accessibility.
  - Fix invalid cairo matrix when drawing too small surfaces.
  - Avoid extra copy when drawing images using cairo.
  - Do not omit playback rate when seeking in GStreamer media backend.
  - Several build fixes on non-linux platforms.

=================
WebKitGTK+  2.3.1
=================

What's new in WebKitGTK+ 2.3.1?

  - Add WebKit2 API for TLS errors.
  - Make EventTarget interface introspectable in GObject DOM bindings.
  - Expose WheelEvent in the GObject DOM bindings API.
  - Generate API documentation for GObject DOM bindings.
  - Respect image orientation by default.
  - Enable text edition undo/redo operations support in WebKit2.
  - Add suppport for blob URLs to GStreamer media backend.
  - Add support for subtitles.
  - Allow running the web process with an arbitrary prefix command in
    debug builds.
  - Expose image links properly to accessibility.
  - Expose title and alternative text for links in image maps to
    accessibility.
  - Cancel the current active WebKitAuthenticationRequest on load
    fail.
  - Fix several memory leaks.

=================
WebKitGTK+  2.1.4
=================

What's new in WebKitGTK+ 2.1.4?

  - Add WebKitWebView::authenticate signal to WebKit2 GTK API.
  - Expose KeyboardEvent in GObject DOM bindings.
  - Implement attributesOfChildren() for AccessibilityUIElement.
  - Implement allAttributes() for AccessibilityUIElement.
  - Fix issues with edge cases when getting offsets for a text range
    in AtkText.
  - Remote inspector server now notifies about errors when loading
    resurces.
  - Disable HTTP request "Accept-Encoding:" header field on gstreamer
    source element to avoid receiving the wrong size when retrieving
    data.
  - Fix the final position when receiving several seek calls in a row,
    in GStreamer media backend.
  - When rendering accelerated video, upload onto the texture only the
    buffer to be painted.
  - Fix response property definition of WebKitResponsePolicyDecision.
  - Fix a crash in WebKit1 when the WebView is created and destroyed
    too fast.
  - Fix a crash in UI process when the web process crashes.
  - Fix a crash in WebKit2 when a context menu item is selected after
    the page has been closed.
  - Fix a crash when getting the editor command for a key event
    initiated by the web inspector.
  - Fix the build when building with GTK+ 2.
  - Fix several memory leaks.

=================
WebKitGTK+  2.1.3
=================

What's new in WebKitGTK+ 2.1.3?

  - Add support for preload="metadata" to GStreamer media backend.
  - Do not expose '\n' for wrapped lines with ATK_TEXT_BOUNDARY_CHAR.
  - Fix potential race condition in GStreamer media backend when
    getting the video sink caps.
  - Fix performance issues rendering a page with animations.
  - Several fixes and improvements in GStreamer video accelerated
    compositing support.
  - Adjust internal size on GStreamer HTTP source element when
    receiving data if necessary.
  - Actually disable the memory cache when DOCUMENT_VIEWER cache model
    is used in WebKit1.
  - Fix runtime critical warning in WebKit2 when unloading a module
    that failed to load.
  - Fix several memory leaks.

=================
WebKitGTK+  2.1.2
=================

What's new in WebKitGTK+ 2.1.2?

  - Set the subresources load priority using new libsoup API available
    in 2.43.
  - Do not use X11 WidgetBackingStore implementation in Wayland.
  - Support using GLContext from multiple threads.
  - Make sure gstreamer source element is thread-safe.
  - Prevent race condition when pad caps is set on gstreamer player.
  - Invalidate the ProcessLauncher when the process is terminated
    before it has finished launching
  - Use custom cairo code instead of Pango API for highlighting
    misspelled words.
  - Respect PKG_CONFIG env variable when generating gtk-doc.
  - Fix a crash due to an assert in gstreamer backend when seeking.
  - Fix memory leak when web process is terminated.
  - Translation updates: Telugu, Hindi, Kannada, Odia.

=================
WebKitGTK+  2.1.1
=================

What's new in WebKitGTK+ 2.1.1?

  - Add webkit_uri_scheme_request_finish_error to WebKit2 GTK+ API.
  - Add a setting to control whether or not accelerated 2D canvas is
    enabled in WebKit2.
  - Add a setting to WebKit2 to allow sending console log messages to
    stdout.
  - Always use EGL to create the GL context when running on Wayland.
  - Fix rendering of WebKitWebView child widgets with recent GTK+.
  - Notify the web process in WebKitURISchemeRequest when we fail to read
    from the user InputStream.
  - Fixed race conditions closing the socket descriptor when the web
    process crashes.
  - Add video accelerated compositing support to the GStreamer backend.
  - Add support for audio/speex MIME type to the GStreamer backend.
  - Fix seek after video finished in GStreamer backend.
  - Initialize WebKitWebPlugin path to prevent double-free in WebKit1.
  - Fix several GObject instrospection warnings.
  - Fixed several memory leaks.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>