[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / webkit-gtk

Annotation of pkgsrc/www/webkit-gtk/Makefile, Revision 1.205

1.205   ! leot        1: # $NetBSD: Makefile,v 1.204 2021/04/21 11:40:44 adam Exp $
1.4       snj         2:
1.203     leot        3: DISTNAME=      webkitgtk-2.32.0
1.62      drochner    4: PKGNAME=       ${DISTNAME:S/webkitgtk/webkit-gtk/}
1.205   ! leot        5: PKGREVISION=   2
1.98      leot        6: CATEGORIES=    www
1.127     wiz         7: MASTER_SITES=  https://www.webkitgtk.org/releases/
1.98      leot        8: EXTRACT_SUFX=  .tar.xz
1.1       ahoka       9:
1.98      leot       10: MAINTAINER=    pkgsrc-users@NetBSD.org
1.127     wiz        11: HOMEPAGE=      https://www.webkitgtk.org/
1.92      wiz        12: COMMENT=       GTK port of the WebKit browser engine
1.98      leot       13: LICENSE=       2-clause-bsd AND gnu-lgpl-v2
1.42      drochner   14:
1.92      wiz        15: # shm_open(3) and shm_unlink(3) appeared in NetBSD 7.0
1.145     leot       16: NOT_FOR_PLATFORM=      NetBSD-[1-6].*-*
1.87      joerg      17:
1.145     leot       18: TOOL_DEPENDS+= gettext-tools>=0.18:../../devel/gettext-tools
1.173     wiz        19: TOOL_DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
1.98      leot       20:
                     21: USE_CMAKE=     yes
1.126     jperkin    22: USE_LANGUAGES= c c++11
1.171     leot       23: USE_TOOLS+=    automake bash bison flex gmake perl pkg-config msgfmt
1.98      leot       24:
1.150     jperkin    25: # Enabling -gdwarf-2 hits GNU ar limits on file size.
                     26: CTF_SUPPORTED= no
                     27:
1.172     leot       28: # GCC >= 7.3.0 is required, checked via CMakeLists.txt
                     29: GCC_REQD+=             7
1.156     leot       30: USE_GCC_RUNTIME=       yes
1.98      leot       31:
                     32: # Using ld.gold subverts Pkgsrc wrappers, and this package also crashes buggy
                     33: # versions of ld.gold.
                     34: CMAKE_ARGS+=   -DUSE_LD_GOLD=OFF
                     35:
                     36: PKGCONFIG_OVERRIDE+=   Source/JavaScriptCore/javascriptcoregtk.pc.in
1.137     wiz        37: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk-web-extension.pc.in
                     38: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk.pc.in
1.98      leot       39:
1.132     wiz        40: CMAKE_ARGS+=           -DCMAKE_BUILD_TYPE=Release
1.98      leot       41: CMAKE_ARGS+=           -DPORT=GTK
                     42: CMAKE_ARGS+=           -DENABLE_X11_TARGET=ON
                     43: CMAKE_ARGS+=           -DENABLE_MINIBROWSER=ON
1.203     leot       44: CMAKE_ARGS+=           -DENABLE_GAMEPAD=OFF
1.98      leot       45: CMAKE_ARGS+=           -DENABLE_GEOLOCATION=OFF
1.183     tnn        46: CMAKE_ARGS+=           -DENABLE_BUBBLEWRAP_SANDBOX=OFF
1.132     wiz        47: CMAKE_ARGS+=           -DUSE_GSTREAMER_GL=OFF
1.98      leot       48: CMAKE_ARGS+=           -DUSE_LIBHYPHEN=OFF
1.159     leot       49: CMAKE_ARGS+=           -DUSE_OPENJPEG=OFF
1.193     leot       50: CMAKE_ARGS+=           -DUSE_SYSTEMD=OFF
1.98      leot       51:
1.171     leot       52: REPLACE_PERL+= Source/JavaScriptCore/Scripts/*.pl
1.136     wiz        53: REPLACE_PERL+= Source/JavaScriptCore/create_hash_table
1.171     leot       54: REPLACE_PERL+= Source/WebCore/Scripts/*.pl
1.136     wiz        55: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pl
1.145     leot       56: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pm
1.136     wiz        57: REPLACE_PERL+= Source/WebCore/css/*.pl
                     58: REPLACE_PERL+= Source/WebCore/dom/*.pl
                     59: REPLACE_PERL+= Source/WebCore/make-hash-tools.pl
1.171     leot       60: REPLACE_PERL+= Source/WebInspectorUI/Scripts/*.pl
                     61: REPLACE_PERL+= Source/WebKit/Scripts/*.pl
                     62: REPLACE_PERL+= Source/cmake/tools/scripts/*.pl
1.136     wiz        63:
1.145     leot       64: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/*.py
1.171     leot       65: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/wkbuiltins/*.py
1.145     leot       66: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/*.py
                     67: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/codegen/*.py
                     68: REPLACE_PYTHON+=       Source/JavaScriptCore/wasm/*.py
1.171     leot       69: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/*.py
1.136     wiz        70: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/create_regex_tables
                     71: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/generateYarrCanonicalizeUnicode
1.171     leot       72: REPLACE_PYTHON+=       Source/ThirdParty/ANGLE/src/compiler/translator/*.py
                     73: REPLACE_PYTHON+=       Source/ThirdParty/ANGLE/src/libANGLE/*.py
1.145     leot       74: REPLACE_PYTHON+=       Source/ThirdParty/gtest/scripts/*.py
                     75: REPLACE_PYTHON+=       Source/ThirdParty/gtest/test/*.py
                     76: REPLACE_PYTHON+=       Source/ThirdParty/gtest/xcode/Scripts/*.py
                     77: REPLACE_PYTHON+=       Source/WebCore/css/*.py
1.136     wiz        78: REPLACE_PYTHON+=       Source/WebCore/html/parser/create-html-entity-table
                     79: REPLACE_PYTHON+=       Source/WebCore/platform/network/create-http-header-name-table
1.145     leot       80: REPLACE_PYTHON+=       Source/WebKit/Scripts/*.py
                     81: REPLACE_PYTHON+=       Tools/glib/*.py
1.171     leot       82: REPLACE_PYTHON+=       Tools/gtkdoc/generate-gtkdoc
                     83:
1.187     rillig     84: REPLACE_BASH+=         Source/JavaScriptCore/postprocess-headers.sh
                     85: REPLACE_BASH+=         Source/ThirdParty/ANGLE/adjust-angle-include-paths-rule
1.171     leot       86: REPLACE_BASH+=         Source/ThirdParty/gtest/xcode/Samples/FrameworkSample/runtests.sh
                     87: REPLACE_BASH+=         Source/ThirdParty/gtest/xcode/Scripts/runtests.sh
1.187     rillig     88: REPLACE_BASH+=         Source/WebKit/Scripts/copy-webcontent-resources-to-private-headers.sh
                     89: REPLACE_BASH+=         Source/WebKit/Scripts/generate-https-upgrade-database.sh
1.171     leot       90: REPLACE_BASH+=         Source/WebKit/Scripts/process-entitlements.sh
                     91: REPLACE_BASH+=         Tools/gtk/install-dependencies
                     92:
                     93: REPLACE_RUBY+=         Source/JavaScriptCore/b3/air/*.rb
                     94: REPLACE_RUBY+=         Source/JavaScriptCore/offlineasm/*.rb
                     95: REPLACE_RUBY+=         Source/WebCore/Scripts/*.rb
                     96: REPLACE_RUBY+=         Source/WebCore/domjit/*.rb
                     97: REPLACE_RUBY+=         Source/WebInspectorUI/Scripts/*.rb
                     98: REPLACE_RUBY+=         Source/WebKit/Scripts/*.rb
1.136     wiz        99:
                    100: SUBST_CLASSES+=                python
                    101: SUBST_FILES.python+=   Source/WebInspectorUI/Scripts/copy-user-interface-resources.pl
                    102: SUBST_SED.python+=     -e 's,\(.\)python.;,\1${PYTHONBIN}\1;,'
                    103: SUBST_STAGE.python=    pre-configure
                    104: SUBST_MESSAGE.python=  Fixing path to python binary.
1.98      leot      105:
                    106: .include "../../lang/ruby/rubyversion.mk"
1.171     leot      107: .include "../../lang/ruby/replace.mk"
1.145     leot      108: TOOL_DEPENDS+= ${RUBY_BASE}>=${RUBY_VERSION}:${RUBY_SRCDIR}
1.98      leot      109: CMAKE_ARGS+=   -DRUBY_EXECUTABLE=${RUBY}
                    110:
                    111: PYTHON_FOR_BUILD_ONLY= yes
                    112: .include "../../lang/python/application.mk"
                    113: CMAKE_ARGS+=   -DPYTHON_EXECUTABLE=${PYTHONBIN}
                    114:
                    115: CXXFLAGS.SunOS+=       -fpermissive
                    116:
                    117: .include "../../mk/compiler.mk"
                    118: .if !empty(PKGSRC_COMPILER:Mclang)
1.126     jperkin   119: CXXFLAGS+=     -Wno-c++11-narrowing
1.98      leot      120: .endif
                    121:
1.138     jperkin   122: # This does not disable optimisations, merely avoids #error if there are none.
                    123: CFLAGS+=       -DRELEASE_WITHOUT_OPTIMIZATIONS
                    124:
1.166     leot      125: # Needed for JavaScript JIT
1.145     leot      126: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/WebKitWebProcess
                    127: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/jsc
                    128:
1.98      leot      129: .include "options.mk"
                    130:
                    131: BUILDLINK_API_DEPENDS.glib2+= glib2>=2.32.1
                    132: .include "../../devel/glib2/buildlink3.mk"
                    133: .include "../../devel/zlib/buildlink3.mk"
                    134: .include "../../databases/sqlite3/buildlink3.mk"
                    135: .include "../../devel/gperf/buildlink3.mk"
                    136: .include "../../devel/pango/buildlink3.mk"
1.197     nia       137: .include "../../fonts/harfbuzz-icu/buildlink3.mk"
1.136     wiz       138: .include "../../fonts/woff2/buildlink3.mk"
1.98      leot      139: .include "../../graphics/cairo-gobject/buildlink3.mk"
                    140: .include "../../graphics/freetype2/buildlink3.mk"
                    141: .include "../../graphics/libwebp/buildlink3.mk"
                    142: .include "../../mk/jpeg.buildlink3.mk"
                    143: BUILDLINK_API_DEPENDS.png+= png>=1.5.1beta08
                    144: .include "../../graphics/png/buildlink3.mk"
                    145: BUILDLINK_API_DEPENDS.gstreamer1+=     gstreamer1>=1.0.3
                    146: .include "../../multimedia/gstreamer1/buildlink3.mk"
                    147: BUILDLINK_API_DEPENDS.gst-plugins1-base+=      gst-plugins1-base>=1.0.3
                    148: .include "../../multimedia/gst-plugins1-base/buildlink3.mk"
                    149: BUILDLINK_API_DEPENDS.libsoup+= libsoup>=2.42.2nb3
                    150: .include "../../net/libsoup/buildlink3.mk"
                    151: .include "../../security/libsecret/buildlink3.mk"
1.168     leot      152: .include "../../security/libtasn1/buildlink3.mk"
1.98      leot      153: .include "../../sysutils/libnotify/buildlink3.mk"
                    154: .include "../../textproc/icu/buildlink3.mk"
                    155: .include "../../textproc/libxslt/buildlink3.mk"
1.92      wiz       156: .include "../../x11/gtk3/buildlink3.mk"
1.98      leot      157: .include "../../x11/libXdamage/buildlink3.mk"
                    158: .include "../../x11/libXt/buildlink3.mk"
                    159: .include "../../mk/pthread.buildlink3.mk"
1.200     nia       160: .include "../../mk/atomic64.mk"
1.1       ahoka     161: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>