[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / webkit-gtk

Annotation of pkgsrc/www/webkit-gtk/Makefile, Revision 1.191

1.191   ! leot        1: # $NetBSD: Makefile,v 1.190 2020/07/28 14:24:03 leot Exp $
1.4       snj         2:
1.190     leot        3: DISTNAME=      webkitgtk-2.28.4
1.62      drochner    4: PKGNAME=       ${DISTNAME:S/webkitgtk/webkit-gtk/}
1.191   ! leot        5: PKGREVISION=   1
1.98      leot        6: CATEGORIES=    www
1.127     wiz         7: MASTER_SITES=  https://www.webkitgtk.org/releases/
1.98      leot        8: EXTRACT_SUFX=  .tar.xz
1.1       ahoka       9:
1.98      leot       10: MAINTAINER=    pkgsrc-users@NetBSD.org
1.127     wiz        11: HOMEPAGE=      https://www.webkitgtk.org/
1.92      wiz        12: COMMENT=       GTK port of the WebKit browser engine
1.98      leot       13: LICENSE=       2-clause-bsd AND gnu-lgpl-v2
1.42      drochner   14:
1.92      wiz        15: # shm_open(3) and shm_unlink(3) appeared in NetBSD 7.0
1.145     leot       16: NOT_FOR_PLATFORM=      NetBSD-[1-6].*-*
1.87      joerg      17:
1.145     leot       18: TOOL_DEPENDS+= gettext-tools>=0.18:../../devel/gettext-tools
1.173     wiz        19: TOOL_DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
1.98      leot       20:
                     21: USE_CMAKE=     yes
1.126     jperkin    22: USE_LANGUAGES= c c++11
1.171     leot       23: USE_TOOLS+=    automake bash bison flex gmake perl pkg-config msgfmt
1.98      leot       24:
1.150     jperkin    25: # Enabling -gdwarf-2 hits GNU ar limits on file size.
                     26: CTF_SUPPORTED= no
                     27:
1.172     leot       28: # GCC >= 7.3.0 is required, checked via CMakeLists.txt
                     29: GCC_REQD+=             7
1.156     leot       30: USE_GCC_RUNTIME=       yes
1.98      leot       31:
                     32: # Using ld.gold subverts Pkgsrc wrappers, and this package also crashes buggy
                     33: # versions of ld.gold.
                     34: CMAKE_ARGS+=   -DUSE_LD_GOLD=OFF
                     35:
                     36: PKGCONFIG_OVERRIDE+=   Source/JavaScriptCore/javascriptcoregtk.pc.in
1.137     wiz        37: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk-web-extension.pc.in
                     38: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk.pc.in
1.98      leot       39:
1.132     wiz        40: CMAKE_ARGS+=           -DCMAKE_BUILD_TYPE=Release
1.98      leot       41: CMAKE_ARGS+=           -DPORT=GTK
                     42: CMAKE_ARGS+=           -DENABLE_X11_TARGET=ON
                     43: CMAKE_ARGS+=           -DENABLE_MINIBROWSER=ON
                     44: CMAKE_ARGS+=           -DENABLE_GEOLOCATION=OFF
1.183     tnn        45: CMAKE_ARGS+=           -DENABLE_BUBBLEWRAP_SANDBOX=OFF
1.132     wiz        46: CMAKE_ARGS+=           -DUSE_GSTREAMER_GL=OFF
1.98      leot       47: CMAKE_ARGS+=           -DUSE_LIBHYPHEN=OFF
1.159     leot       48: CMAKE_ARGS+=           -DUSE_OPENJPEG=OFF
1.98      leot       49:
1.171     leot       50: REPLACE_PERL+= Source/JavaScriptCore/Scripts/*.pl
1.136     wiz        51: REPLACE_PERL+= Source/JavaScriptCore/create_hash_table
1.171     leot       52: REPLACE_PERL+= Source/WebCore/Scripts/*.pl
1.136     wiz        53: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pl
1.145     leot       54: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pm
1.136     wiz        55: REPLACE_PERL+= Source/WebCore/css/*.pl
                     56: REPLACE_PERL+= Source/WebCore/dom/*.pl
                     57: REPLACE_PERL+= Source/WebCore/make-hash-tools.pl
1.171     leot       58: REPLACE_PERL+= Source/WebInspectorUI/Scripts/*.pl
                     59: REPLACE_PERL+= Source/WebKit/Scripts/*.pl
                     60: REPLACE_PERL+= Source/cmake/tools/scripts/*.pl
1.136     wiz        61:
1.145     leot       62: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/*.py
1.171     leot       63: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/wkbuiltins/*.py
1.145     leot       64: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/*.py
                     65: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/codegen/*.py
                     66: REPLACE_PYTHON+=       Source/JavaScriptCore/wasm/*.py
1.171     leot       67: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/*.py
1.136     wiz        68: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/create_regex_tables
                     69: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/generateYarrCanonicalizeUnicode
1.171     leot       70: REPLACE_PYTHON+=       Source/ThirdParty/ANGLE/src/compiler/translator/*.py
                     71: REPLACE_PYTHON+=       Source/ThirdParty/ANGLE/src/libANGLE/*.py
1.145     leot       72: REPLACE_PYTHON+=       Source/ThirdParty/gtest/scripts/*.py
                     73: REPLACE_PYTHON+=       Source/ThirdParty/gtest/test/*.py
                     74: REPLACE_PYTHON+=       Source/ThirdParty/gtest/xcode/Scripts/*.py
                     75: REPLACE_PYTHON+=       Source/WebCore/css/*.py
1.136     wiz        76: REPLACE_PYTHON+=       Source/WebCore/html/parser/create-html-entity-table
                     77: REPLACE_PYTHON+=       Source/WebCore/platform/network/create-http-header-name-table
1.145     leot       78: REPLACE_PYTHON+=       Source/WebKit/Scripts/*.py
                     79: REPLACE_PYTHON+=       Tools/glib/*.py
1.171     leot       80: REPLACE_PYTHON+=       Tools/gtkdoc/generate-gtkdoc
                     81:
1.187     rillig     82: REPLACE_BASH+=         Source/JavaScriptCore/postprocess-headers.sh
                     83: REPLACE_BASH+=         Source/ThirdParty/ANGLE/adjust-angle-include-paths-rule
1.171     leot       84: REPLACE_BASH+=         Source/ThirdParty/gtest/xcode/Samples/FrameworkSample/runtests.sh
                     85: REPLACE_BASH+=         Source/ThirdParty/gtest/xcode/Scripts/runtests.sh
1.187     rillig     86: REPLACE_BASH+=         Source/WebKit/Scripts/copy-webcontent-resources-to-private-headers.sh
                     87: REPLACE_BASH+=         Source/WebKit/Scripts/generate-https-upgrade-database.sh
1.171     leot       88: REPLACE_BASH+=         Source/WebKit/Scripts/process-entitlements.sh
                     89: REPLACE_BASH+=         Tools/gtk/install-dependencies
                     90:
                     91: REPLACE_RUBY+=         Source/JavaScriptCore/b3/air/*.rb
                     92: REPLACE_RUBY+=         Source/JavaScriptCore/offlineasm/*.rb
                     93: REPLACE_RUBY+=         Source/WebCore/Scripts/*.rb
                     94: REPLACE_RUBY+=         Source/WebCore/domjit/*.rb
                     95: REPLACE_RUBY+=         Source/WebInspectorUI/Scripts/*.rb
                     96: REPLACE_RUBY+=         Source/WebKit/Scripts/*.rb
1.136     wiz        97:
                     98: SUBST_CLASSES+=                python
                     99: SUBST_FILES.python+=   Source/WebInspectorUI/Scripts/copy-user-interface-resources.pl
                    100: SUBST_SED.python+=     -e 's,\(.\)python.;,\1${PYTHONBIN}\1;,'
                    101: SUBST_STAGE.python=    pre-configure
                    102: SUBST_MESSAGE.python=  Fixing path to python binary.
1.98      leot      103:
                    104: .include "../../lang/ruby/rubyversion.mk"
1.171     leot      105: .include "../../lang/ruby/replace.mk"
1.145     leot      106: TOOL_DEPENDS+= ${RUBY_BASE}>=${RUBY_VERSION}:${RUBY_SRCDIR}
1.98      leot      107: CMAKE_ARGS+=   -DRUBY_EXECUTABLE=${RUBY}
                    108:
                    109: PYTHON_FOR_BUILD_ONLY= yes
                    110: .include "../../lang/python/application.mk"
                    111: CMAKE_ARGS+=   -DPYTHON_EXECUTABLE=${PYTHONBIN}
                    112:
                    113: CXXFLAGS.SunOS+=       -fpermissive
                    114:
                    115: .include "../../mk/compiler.mk"
                    116: .if !empty(PKGSRC_COMPILER:Mclang)
1.126     jperkin   117: CXXFLAGS+=     -Wno-c++11-narrowing
1.98      leot      118: .endif
                    119:
1.138     jperkin   120: # This does not disable optimisations, merely avoids #error if there are none.
                    121: CFLAGS+=       -DRELEASE_WITHOUT_OPTIMIZATIONS
                    122:
1.166     leot      123: # Needed for JavaScript JIT
1.145     leot      124: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/WebKitWebProcess
                    125: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/jsc
                    126:
1.98      leot      127: .include "options.mk"
                    128:
                    129: BUILDLINK_API_DEPENDS.glib2+= glib2>=2.32.1
                    130: .include "../../devel/glib2/buildlink3.mk"
                    131: .include "../../devel/zlib/buildlink3.mk"
                    132: .include "../../databases/sqlite3/buildlink3.mk"
                    133: .include "../../devel/gperf/buildlink3.mk"
                    134: .include "../../devel/pango/buildlink3.mk"
1.136     wiz       135: .include "../../fonts/woff2/buildlink3.mk"
1.98      leot      136: .include "../../graphics/cairo-gobject/buildlink3.mk"
                    137: .include "../../graphics/freetype2/buildlink3.mk"
                    138: .include "../../graphics/libwebp/buildlink3.mk"
                    139: .include "../../mk/jpeg.buildlink3.mk"
                    140: BUILDLINK_API_DEPENDS.png+= png>=1.5.1beta08
                    141: .include "../../graphics/png/buildlink3.mk"
                    142: BUILDLINK_API_DEPENDS.gstreamer1+=     gstreamer1>=1.0.3
                    143: .include "../../multimedia/gstreamer1/buildlink3.mk"
                    144: BUILDLINK_API_DEPENDS.gst-plugins1-base+=      gst-plugins1-base>=1.0.3
                    145: .include "../../multimedia/gst-plugins1-base/buildlink3.mk"
                    146: BUILDLINK_API_DEPENDS.libsoup+= libsoup>=2.42.2nb3
                    147: .include "../../net/libsoup/buildlink3.mk"
                    148: .include "../../security/libsecret/buildlink3.mk"
1.168     leot      149: .include "../../security/libtasn1/buildlink3.mk"
1.98      leot      150: .include "../../sysutils/libnotify/buildlink3.mk"
                    151: .include "../../textproc/icu/buildlink3.mk"
                    152: .include "../../textproc/libxslt/buildlink3.mk"
1.92      wiz       153: .include "../../x11/gtk3/buildlink3.mk"
1.98      leot      154: .include "../../x11/libXdamage/buildlink3.mk"
                    155: .include "../../x11/libXt/buildlink3.mk"
                    156: .include "../../mk/pthread.buildlink3.mk"
1.1       ahoka     157: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>