[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / webkit-gtk

Annotation of pkgsrc/www/webkit-gtk/Makefile, Revision 1.156

1.156   ! leot        1: # $NetBSD: Makefile,v 1.155 2018/12/14 15:51:13 leot Exp $
1.4       snj         2:
1.156   ! leot        3: DISTNAME=      webkitgtk-2.22.6
1.62      drochner    4: PKGNAME=       ${DISTNAME:S/webkitgtk/webkit-gtk/}
1.98      leot        5: CATEGORIES=    www
1.127     wiz         6: MASTER_SITES=  https://www.webkitgtk.org/releases/
1.98      leot        7: EXTRACT_SUFX=  .tar.xz
1.1       ahoka       8:
1.98      leot        9: MAINTAINER=    pkgsrc-users@NetBSD.org
1.127     wiz        10: HOMEPAGE=      https://www.webkitgtk.org/
1.92      wiz        11: COMMENT=       GTK port of the WebKit browser engine
1.98      leot       12: LICENSE=       2-clause-bsd AND gnu-lgpl-v2
1.42      drochner   13:
1.92      wiz        14: # shm_open(3) and shm_unlink(3) appeared in NetBSD 7.0
1.145     leot       15: NOT_FOR_PLATFORM=      NetBSD-[1-6].*-*
1.87      joerg      16:
1.145     leot       17: TOOL_DEPENDS+= gettext-tools>=0.18:../../devel/gettext-tools
1.98      leot       18:
                     19: USE_CMAKE=     yes
1.126     jperkin    20: USE_LANGUAGES= c c++11
1.155     leot       21: USE_TOOLS+=    automake bison flex gmake perl pkg-config msgfmt
1.98      leot       22:
1.150     jperkin    23: # Enabling -gdwarf-2 hits GNU ar limits on file size.
                     24: CTF_SUPPORTED= no
                     25:
1.156   ! leot       26: GCC_REQD+=             6
        !            27: USE_GCC_RUNTIME=       yes
1.98      leot       28:
                     29: # Using ld.gold subverts Pkgsrc wrappers, and this package also crashes buggy
                     30: # versions of ld.gold.
                     31: CMAKE_ARGS+=   -DUSE_LD_GOLD=OFF
                     32:
                     33: PKGCONFIG_OVERRIDE+=   Source/JavaScriptCore/javascriptcoregtk.pc.in
1.137     wiz        34: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk-web-extension.pc.in
                     35: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk.pc.in
1.98      leot       36:
1.132     wiz        37: CMAKE_ARGS+=           -DCMAKE_BUILD_TYPE=Release
1.98      leot       38: CMAKE_ARGS+=           -DPORT=GTK
                     39: CMAKE_ARGS+=           -DENABLE_X11_TARGET=ON
                     40: CMAKE_ARGS+=           -DENABLE_MINIBROWSER=ON
                     41: CMAKE_ARGS+=           -DENABLE_GEOLOCATION=OFF
1.132     wiz        42: CMAKE_ARGS+=           -DUSE_GSTREAMER_GL=OFF
1.98      leot       43: CMAKE_ARGS+=           -DUSE_LIBHYPHEN=OFF
                     44:
1.136     wiz        45: REPLACE_PERL+= Source/JavaScriptCore/create_hash_table
                     46: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pl
1.145     leot       47: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pm
1.136     wiz        48: REPLACE_PERL+= Source/WebCore/css/*.pl
                     49: REPLACE_PERL+= Source/WebCore/dom/*.pl
                     50: REPLACE_PERL+= Source/WebCore/make-hash-tools.pl
                     51:
1.145     leot       52: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/*.py
                     53: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/builtins/*.py
1.136     wiz        54: REPLACE_PYTHON+=       Source/JavaScriptCore/generate-bytecode-files
1.145     leot       55: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/*.py
                     56: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/codegen/*.py
                     57: REPLACE_PYTHON+=       Source/JavaScriptCore/wasm/*.py
1.136     wiz        58: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/create_regex_tables
                     59: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/generateYarrCanonicalizeUnicode
1.145     leot       60: REPLACE_PYTHON+=       Source/ThirdParty/gtest/*.py
                     61: REPLACE_PYTHON+=       Source/ThirdParty/gtest/scripts/*.py
                     62: REPLACE_PYTHON+=       Source/ThirdParty/gtest/test/*.py
                     63: REPLACE_PYTHON+=       Source/ThirdParty/gtest/xcode/Scripts/*.py
                     64: REPLACE_PYTHON+=       Source/WebCore/PAL/*.py
                     65: REPLACE_PYTHON+=       Source/WebCore/css/*.py
1.136     wiz        66: REPLACE_PYTHON+=       Source/WebCore/html/parser/create-html-entity-table
                     67: REPLACE_PYTHON+=       Source/WebCore/platform/network/create-http-header-name-table
1.145     leot       68: REPLACE_PYTHON+=       Source/WebKit/Scripts/*.py
                     69: REPLACE_PYTHON+=       Tools/glib/*.py
1.136     wiz        70: REPLACE_PYTHON+=       Tools/gtk/*.py
                     71: REPLACE_PYTHON+=       Tools/gtk/generate-gtkdoc
                     72:
                     73: SUBST_CLASSES+=                python
                     74: SUBST_FILES.python+=   Source/WebInspectorUI/Scripts/copy-user-interface-resources.pl
                     75: SUBST_SED.python+=     -e 's,\(.\)python.;,\1${PYTHONBIN}\1;,'
                     76: SUBST_STAGE.python=    pre-configure
                     77: SUBST_MESSAGE.python=  Fixing path to python binary.
1.98      leot       78:
                     79: .include "../../lang/ruby/rubyversion.mk"
1.145     leot       80: TOOL_DEPENDS+= ${RUBY_BASE}>=${RUBY_VERSION}:${RUBY_SRCDIR}
1.98      leot       81: CMAKE_ARGS+=   -DRUBY_EXECUTABLE=${RUBY}
                     82:
                     83: PYTHON_FOR_BUILD_ONLY= yes
1.155     leot       84: PYTHON_VERSIONS_INCOMPATIBLE=  34 35 36 37 # not yet ported as of 2.22.5
1.98      leot       85: .include "../../lang/python/application.mk"
                     86: CMAKE_ARGS+=   -DPYTHON_EXECUTABLE=${PYTHONBIN}
                     87:
                     88: CXXFLAGS.SunOS+=       -fpermissive
                     89:
                     90: .include "../../mk/compiler.mk"
                     91: .if !empty(PKGSRC_COMPILER:Mclang)
1.126     jperkin    92: CXXFLAGS+=     -Wno-c++11-narrowing
1.98      leot       93: .endif
                     94:
1.138     jperkin    95: # This does not disable optimisations, merely avoids #error if there are none.
                     96: CFLAGS+=       -DRELEASE_WITHOUT_OPTIMIZATIONS
                     97:
1.145     leot       98: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/WebKitWebProcess
                     99: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/jsc
                    100:
1.98      leot      101: .include "options.mk"
                    102:
                    103: BUILDLINK_API_DEPENDS.glib2+= glib2>=2.32.1
                    104: .include "../../devel/glib2/buildlink3.mk"
                    105: .include "../../devel/zlib/buildlink3.mk"
                    106: .include "../../databases/sqlite3/buildlink3.mk"
                    107: .include "../../devel/gperf/buildlink3.mk"
                    108: .include "../../devel/pango/buildlink3.mk"
1.136     wiz       109: .include "../../fonts/woff2/buildlink3.mk"
1.98      leot      110: .include "../../graphics/cairo-gobject/buildlink3.mk"
                    111: .include "../../graphics/freetype2/buildlink3.mk"
                    112: .include "../../graphics/libwebp/buildlink3.mk"
                    113: .include "../../mk/jpeg.buildlink3.mk"
                    114: BUILDLINK_API_DEPENDS.png+= png>=1.5.1beta08
                    115: .include "../../graphics/png/buildlink3.mk"
                    116: BUILDLINK_API_DEPENDS.gstreamer1+=     gstreamer1>=1.0.3
                    117: .include "../../multimedia/gstreamer1/buildlink3.mk"
                    118: BUILDLINK_API_DEPENDS.gst-plugins1-base+=      gst-plugins1-base>=1.0.3
                    119: .include "../../multimedia/gst-plugins1-base/buildlink3.mk"
                    120: BUILDLINK_API_DEPENDS.libsoup+= libsoup>=2.42.2nb3
                    121: .include "../../net/libsoup/buildlink3.mk"
                    122: .include "../../security/libsecret/buildlink3.mk"
                    123: .include "../../security/gnutls/buildlink3.mk"
                    124: .include "../../sysutils/libnotify/buildlink3.mk"
                    125: .include "../../textproc/icu/buildlink3.mk"
                    126: .include "../../textproc/libxslt/buildlink3.mk"
1.75      obache    127: BUILDLINK_API_DEPENDS.gtk2+=   gtk2+>=2.24.17nb3
1.1       ahoka     128: .include "../../x11/gtk2/buildlink3.mk"
1.92      wiz       129: .include "../../x11/gtk3/buildlink3.mk"
1.98      leot      130: .include "../../x11/libXdamage/buildlink3.mk"
                    131: .include "../../x11/libXt/buildlink3.mk"
                    132: .include "../../mk/pthread.buildlink3.mk"
1.1       ahoka     133: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>