File:  [cvs.NetBSD.org] / pkgsrc / www / webalizer / Makefile
Revision 1.66: download - view: text, annotated - select for diffs
Thu Jan 19 18:52:29 2017 UTC (8 years, 1 month ago) by agc
Branches: MAIN
CVS tags: HEAD
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.66 2017/01/19 18:52:29 agc Exp $

DISTNAME=	webalizer-2.21-02-src
PKGNAME=	webalizer-2.21.2
PKGREVISION=	13
CATEGORIES=	www
MASTER_SITES=	ftp://ftp.mrunix.net/pub/webalizer/
MASTER_SITES+=	http://gd.tuwien.ac.at/infosys/logeval/webalizer/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.webalizer.org/
COMMENT=	Web server log file analysis program

WRKSRC=			${WRKDIR}/${DISTNAME:S/-src//}
BDB_ACCEPTED=		db4 db5
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+=	--enable-dns

EGDIR=		${PREFIX}/share/examples
CONF_FILES=	${EGDIR}/webalizer.conf.sample ${PKG_SYSCONFDIR}/webalizer.conf
DOC_SUBDIR=	share/doc/webalizer
DOCDIR=		${PREFIX}/${DOC_SUBDIR}
DOCFILES=	CHANGES Copyright DNS.README README README.FIRST

INSTALLATION_DIRS=	bin ${PKGMANDIR}/man1 share/examples ${DOC_SUBDIR}

SUBST_CLASSES+=		webalizer
SUBST_STAGE.webalizer=	post-build
SUBST_FILES.webalizer=	sample.conf webalizer.1
SUBST_SED.webalizer=	-e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g"

PKG_OPTIONS_VAR=	PKG_OPTIONS.webalizer
PKG_SUPPORTED_OPTIONS=	bzip2 geoip
.include "../../mk/bsd.options.mk"

.if !empty(PKG_OPTIONS:Mbzip2)
.  include "../../archivers/bzip2/buildlink3.mk"
CONFIGURE_ARGS+=	--enable-bz2
.endif # option bzip2

.if !empty(PKG_OPTIONS:Mgeoip)
.  include "../../net/GeoIP/buildlink3.mk"
CONFIGURE_ARGS+=	--enable-geoip
CONFIGURE_ARGS+=	--with-geodb=${BUILDLINK_PREFIX.GeoIP}/share/GeoIP
.endif # option geoip

post-install:
.for f in ${DOCFILES}
	${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${DOCDIR}/${f}
.endfor

BUILDLINK_TRANSFORM+=	l:db:${BDB_TYPE}
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/gd/buildlink3.mk"
.include "../../mk/bdb.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>