File:  [cvs.NetBSD.org] / pkgsrc / www / trac / Makefile
Revision 1.96: download - view: text, annotated - select for diffs
Mon May 8 14:21:56 2023 UTC (21 months ago) by gdt
Branches: MAIN
CVS tags: HEAD
www/trac: Update to 1.5.4

This update has been build-tested only; no one responded on
pkgsrc-users about testing or doing the update.

Packaging changes:
  Switch to python3.

Upstream changes:

  Support python 3.5+.  Drop support for python 2.7.
  Drop Genshi; plugins must be migrated to Jinja2.
  Allow retargeting tickets from the milestone admin page.

# $NetBSD: Makefile,v 1.96 2023/05/08 14:21:56 gdt Exp $

DISTNAME=	Trac-1.5.4
PKGNAME=	${DISTNAME:tl}
CATEGORIES=	www devel
MASTER_SITES=	http://ftp.edgewall.org/pub/trac/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://trac.edgewall.org/
COMMENT=	Repository browser, wiki, and issue tracking system
LICENSE=	modified-bsd

# Updates to micro-releases along stable branches are commited without
# testing.
#
# Trac supports svn and git in the base, plus others via plugins,
# using them at runtime if configured.  Therefore this package does
# not depend on svn or git to avoid installing them for trac installs
# that use the other.

DEPENDS+=	${PYPKGPREFIX}-genshi>=0.6:../../www/py-genshi
DEPENDS+=	${PYPKGPREFIX}-jinja2>=2.11:../../textproc/py27-jinja2

USE_TOOLS+=	pax

PYTHON_VERSIONS_INCOMPATIBLE=	27

USE_PKG_RESOURCES=	yes

REPLACE_PYTHON=		contrib/*.py contrib/*-hook
REPLACE_PYTHON+=	trac/tests/functional/*.py

.include "../../lang/python/application.mk"

EGDIR=		${PREFIX}/share/examples/trac

post-install:
	${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
	cd ${WRKSRC}/contrib && pax -rwppm -s ',./rpm/.*$$,,' -s ',./rpm$$,,' \
		. ${DESTDIR}${EGDIR}

.include "options.mk"

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>