File:  [cvs.NetBSD.org] / pkgsrc / www / squidclamav / Makefile
Revision 1.5: download - view: text, annotated - select for diffs
Sun Oct 28 06:31:05 2012 UTC (12 years, 5 months ago) by asau
Branches: MAIN
CVS tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4, HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.5 2012/10/28 06:31:05 asau Exp $

DISTNAME=	squidclamav-6.8
PKGREVISION=	1
CATEGORIES=	www
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=squidclamav/}

MAINTAINER=	adam@NetBSD.org
HOMEPAGE=	http://squidclamav.darold.net/
COMMENT=	Clamav ICAP service and redirector for Squid
LICENSE=	gnu-lgpl-v2.1

DEPENDS+=	clamav>=0.97:../../security/clamav
DEPENDS+=	squid>=3.1.12:../../www/squid31

USE_LANGUAGES=		c
USE_LIBTOOL=		yes
USE_TOOLS+=		perl
GNU_CONFIGURE=		yes
CONFIGURE_ARGS=		--sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS=		--with-c-icap=${BUILDLINK_PREFIX.c-icap}

REPLACE_PERL=		cgi-bin/*

EGDIR=		${PREFIX}/share/squidclamav
CONF_FILES=	${EGDIR}/squidclamav.conf ${PKG_SYSCONFDIR}/squidclamav.conf

SUBST_CLASSES+=		fix-cfg
SUBST_STAGE.fix-cfg=	pre-configure
SUBST_MESSAGE.fix-cfg=	Fixing config path.
SUBST_FILES.fix-cfg=	configure
SUBST_FILES.fix-cfg+=	src/squidclamav.h
SUBST_SED.fix-cfg=	-e 's,CFGDIR=/etc,CFGDIR=${PKG_SYSCONFDIR},'
SUBST_SED.fix-cfg+=	-e '/CONFIG_FILE/s,/etc,${PKG_SYSCONFDIR},'

.include "../../www/c-icap/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>