[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / squid

Annotation of pkgsrc/www/squid/Makefile, Revision 1.201

1.201   ! taca        1: # $NetBSD: Makefile,v 1.200 2007/12/20 03:17:14 taca Exp $
1.1       tron        2:
1.201   ! taca        3: DISTNAME=      squid-2.6.STABLE18
1.187     taca        4: PKGNAME=       ${DISTNAME:S/STABLE//}
1.1       tron        5: CATEGORIES=    www
1.198     wiz         6: MASTER_SITES=  http://www.squid-cache.org/Versions/v2/2.6/
1.69      taca        7: EXTRACT_SUFX=  .tar.bz2
1.119     taca        8:
1.87      grant       9: MAINTAINER=    taca@NetBSD.org
1.27      tron       10: HOMEPAGE=      http://www.squid-cache.org/
1.41      wiz        11: COMMENT=       Post-Harvest_cached WWW proxy cache and accelerator
1.1       tron       12:
1.101     agc        13: WRKSRC=                ${WRKDIR}/${DISTNAME:S/-src//}
1.120     taca       14:
1.79      taca       15: DOCDIR=                ${PREFIX}/share/doc/squid
                     16: EXAMPLESDIR=   ${PREFIX}/share/examples/squid
                     17:
                     18: DOCFILES=      ChangeLog RELEASENOTES.html doc/debug-sections.txt
1.21      tron       19:
1.165     taca       20: USE_TOOLS+=            perl
1.75      jlam       21: GNU_CONFIGURE=         yes
1.166     rillig     22: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR:Q} \
1.200     taca       23:                        --localstatedir=${SQUID_DATADIR:Q}
1.74      grant      24:
1.165     taca       25: MAKE_ENV+=     INSTALL_SCRIPT=${INSTALL_SCRIPT:Q}
                     26: MAKE_ENV+=     PKG_PREFIX=${PREFIX:Q} VARBASE=${VARBASE:Q}
1.120     taca       27: PLIST_SRC=     ${WRKDIR}/PLIST
                     28: RCD_SCRIPTS=   squid
                     29:
1.182     taca       30: CONF_FILES+=   ${EXAMPLESDIR}/cachemgr.conf ${PKG_SYSCONFDIR}/cachemgr.conf
1.120     taca       31: CONF_FILES+=   ${EXAMPLESDIR}/mime.conf ${PKG_SYSCONFDIR}/mime.conf
                     32: CONF_FILES+=   ${EXAMPLESDIR}/squid.conf ${PKG_SYSCONFDIR}/squid.conf
1.155     taca       33: CONF_FILES+=   ${EXAMPLESDIR}/msntauth.conf ${PKG_SYSCONFDIR}/msntauth.conf
1.200     taca       34: OWN_DIRS=      ${SQUID_DATADIR}
                     35: OWN_DIRS_PERMS+= ${SQUID_DATADIR}/cache ${SQUID_USER} ${SQUID_GROUP} 0750 \
                     36:                 ${SQUID_DATADIR}/logs ${SQUID_USER} ${SQUID_GROUP} 0750
1.155     taca       37: EXAMPLES_FILES=        src/mime.conf.default src/squid.conf.default \
1.182     taca       38:                helpers/basic_auth/MSNT/msntauth.conf.default \
                     39:                tools/cachemgr.conf
1.15      agc        40:
1.152     taca       41: .include "../../mk/bsd.prefs.mk"
1.200     taca       42: .include "Makefile.common"
1.152     taca       43:
1.193     jlam       44: BUILD_DEFS+=   VARBASE
1.117     taca       45:
1.152     taca       46: CONFIGURE_ARGS+=       --enable-auth=basic,digest,ntlm \
1.57      taca       47:                        --enable-cachemgr-hostname=localhost \
1.33      tron       48:                        --enable-delay-pools \
1.69      taca       49:                        --enable-removal-policies=lru,heap \
                     50:                        --enable-poll \
1.53      tron       51:                        --enable-underscores \
1.192     taca       52:                        --enable-storeio=${SQUID_BACKENDS:Q} \
                     53:                        --with-aio
1.69      taca       54:
1.152     taca       55: #
                     56: # generic helpers
                     57: #
1.183     taca       58: OPTIONAL_FILES+= bin/cossdump libexec/diskd-daemon libexec/dnsserver
1.182     taca       59: OPTIONAL_FILES+= libexec/pinger libexec/unlinkd
1.152     taca       60: #
                     61: # basic auth helpers (except LDAP, multi-domain-NTLM and SASL)
                     62: #
                     63: OPTIONAL_FILES+= libexec/getpwname_auth libexec/msnt_auth libexec/ncsa_auth
1.182     taca       64: OPTIONAL_FILES+= libexec/pam_auth man/man8/ncsa_auth.8 man/man8/pam_auth.8
                     65: OPTIONAL_FILES+= libexec/smb_auth libexec/yp_auth libexec/wb_auth
1.152     taca       66: #
                     67: # digest auth helpers
                     68: #
                     69: OPTIONAL_FILES+= libexec/digest_pw_auth
                     70: #
                     71: # ntlm auth helpers (except no_check and winbind)
                     72: #
1.155     taca       73: OPTIONAL_FILES+= libexec/fakeauth_auth libexec/ntlm_auth
1.70      taca       74: OPTIONAL_FILES+= libexec/wb_ntlmauth man/man8/squid_unix_group.8
1.152     taca       75: #
                     76: # external acl helpers (except ldap_group, wbinfo_group and winbind_group)
                     77: #
                     78: OPTIONAL_FILES+= libexec/ip_user_check libexec/squid_unix_group
1.1       tron       79:
1.176     taca       80: SUBST_CLASSES+=                confs
                     81: SUBST_STAGE.confs=     pre-configure
                     82: SUBST_FILES.confs=     src/cf.data.pre
                     83: SUBST_SED.confs=       -e "s/@USER@/${SQUID_USER}/"
                     84: SUBST_MESSAGE.confs=   Fixing configuration files.
                     85:
1.195     rillig     86: CHECK_PORTABILITY_SKIP+=       icons/icons.shar
                     87:
1.4       tron       88: pre-install:
1.176     taca       89:        ${INSTALL_DATA_DIR} ${PREFIX}/share/squid
                     90:        ${INSTALL_DATA_DIR} ${PREFIX}/share/squid/errors
                     91:        ${INSTALL_DATA_DIR} ${PREFIX}/share/squid/icons
1.51      tron       92:
                     93: post-install:
1.176     taca       94:        ${INSTALL_DATA_DIR} ${EXAMPLESDIR}
1.155     taca       95: .for f in ${EXAMPLES_FILES}
1.182     taca       96:        ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}/`basename ${f} .default`
1.155     taca       97: .endfor
1.176     taca       98:        ${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
1.79      taca       99:        ${INSTALL_DATA_DIR} ${DOCDIR}
1.192     taca      100:        cd ${WRKSRC};                                           \
1.79      taca      101:        for i in ${DOCFILES}; do                                \
1.171     taca      102:                ${INSTALL_DATA} $$i ${DOCDIR};                  \
1.79      taca      103:        done
1.176     taca      104:        (                                                       \
1.172     taca      105:        for i in ${OPTIONAL_FILES}; do                          \
                    106:          ${TEST} ! -r ${PREFIX}/$$i || ${ECHO} $$i;            \
1.51      tron      107:        done;                                                   \
1.69      taca      108:        cd ${WRKSRC}/errors;                                    \
1.79      taca      109:        for i in *; do                                          \
1.172     taca      110:                ${TEST} -d $$i &&                               \
1.171     taca      111:                (${LS} $$i/ERR_* |                              \
1.69      taca      112:                ${SED} -e 's@^@share/squid/errors/@';           \
1.171     taca      113:                ${ECHO} "@dirrm share/squid/errors/$$i");       \
1.69      taca      114:        done;                                                   \
1.10      tron      115:        ${ECHO} "@dirrm share/squid/errors";                    \
1.4       tron      116:        cd ${WRKSRC}/icons;                                     \
1.172     taca      117:        ${LS} anthony-*.gif |                                   \
1.173     taca      118:                ${SED} -e 's@^@share/squid/icons/@';            \
1.10      tron      119:        ${ECHO} "@dirrm share/squid/icons";                     \
                    120:        ${ECHO} "share/squid/mib.txt";                          \
1.51      tron      121:        ${ECHO} "@dirrm share/squid"                            \
1.47      tron      122:        ) >>${PLIST_SRC}
1.69      taca      123:
1.152     taca      124: .include "options.mk"
1.17      soren     125: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>