[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / sope

File: [cvs.NetBSD.org] / pkgsrc / www / sope / Attic / Makefile (download)

Revision 1.8, Sat Mar 4 21:31:03 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.7: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.8 2006/03/04 21:31:03 jlam Exp $
#

DISTNAME=		sope-4.5.4-nevermind-r878
PKGNAME=		sope-4.5.4
PKGREVISION=		3
CATEGORIES=		www gnustep
MASTER_SITES=		ftp://ftp.opengroupware.org/nightly/sources/releases/ \
			http://download.opengroupware.org/nightly/sources/releases/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://sope.opengroupware.org/
COMMENT=		Set of frameworks for a complete web application server environment

BUILD_DEPENDS+=		bash-[0-9]*:../../shells/bash

WRKSRC=			${WRKDIR}/sope
USE_PKGLOCALEDIR=	yes
HAS_CONFIGURE=		yes
CONFIGURE_ARGS+=	--with-gnustep
CONFIGURE_ARGS+=	--enable-strip
CONFIGURE_ARGS+=	--disable-debug
CONFIG_SHELL=		${PREFIX}/bin/bash
MAKE_ENV+=		ADDITIONAL_OBJCFLAGS="-Wno-import"

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	${CONFIGURE_SCRIPT}
SUBST_SED.paths+=	-e 's,/usr/local,${PREFIX},g'
SUBST_STAGE.paths=	pre-configure

pre-configure:
	for f in ${WRKSRC}/*/config.guess ${WRKSRC}/*/*/config.guess; do \
	    ${CP} ${PKGSRCDIR}/mk/gnu-config/config.guess $$f; \
	done
	for f in ${WRKSRC}/*/config.sub ${WRKSRC}/*/*/config.sub; do \
	    ${CP} ${PKGSRCDIR}/mk/gnu-config/config.sub $$f; \
	done

post-configure:
	cd ${WRKSRC}/sope-core/NGStreams			&&	\
	${LN} -s `${FIND} ${GNUSTEP_HOST_CPU} -name config.h` .

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/libFoundation/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../databases/openldap/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/pgsql.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"