[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / sitecopy

File: [cvs.NetBSD.org] / pkgsrc / www / sitecopy / Makefile (download)

Revision 1.11, Tue Aug 20 08:52:33 2002 UTC (21 years, 8 months ago) by uebayasi
Branch: MAIN
CVS Tags: buildlink2-base
Changes since 1.10: +2 -2 lines

Sitecopy 0.11.4. New features are,

	* Added basic --verify mode, to check whether the remote copy of a
	  site using safe mode has been modified outside sitecopy's control.
	* Added Norwegian Nynorsk translation, nn.po (Karl Ove Hufthammer
	  <huftis@bigfoot.com>)
	* Added 'http tolerant' option, to skip OPTIONS check in WebDAV mode.

And many fixes & updates.

# $NetBSD: Makefile,v 1.11 2002/08/20 08:52:33 uebayasi Exp $

DISTNAME=		sitecopy-0.11.4
CATEGORIES=		www
MASTER_SITES=		http://www.lyra.org/sitecopy/

MAINTAINER=		jlam@netbsd.org
HOMEPAGE=		http://www.lyra.org/sitecopy/
COMMENT=		utility for synchronizing remote and local web sites

USE_GMAKE=		# defined
USE_BUILDLINK_ONLY=	# defined
BUILD_USES_MSGFMT=	# defined

GNU_CONFIGURE=		# defined
CONFIGURE_ARGS+=	--with-ssl=${BUILDLINK_DIR}
CONFIGURE_ARGS+=	--with-included-neon
CONFIGURE_ARGS+=	--enable-libxml

LIBS+=			${LIBGETOPT}

# The build process doesn't correctly find the header for GNU fnmatch, which
# is provided in ${WRKSRC}/lib.  Help the compiler by linking the header
# to ${WRKSRC} and explicitly passing -I. to the compiler.
#
CFLAGS+=		-I.

pre-build:
	${RM} -f ${WRKSRC}/fnmatch.h
	${LN} -sf ${WRKSRC}/lib/fnmatch.h ${WRKSRC}/fnmatch.h

.include "../../devel/gettext-lib/buildlink.mk"
.include "../../devel/libgetopt/buildlink.mk"
.include "../../security/openssl/buildlink.mk"
.include "../../textproc/libxml/buildlink.mk"
.include "../../mk/bsd.pkg.mk"