The NetBSD Project

CVS log for pkgsrc/www/ruby-patron/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / ruby-patron

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.47 / (download) - annotate - [select for diffs], Wed Oct 26 10:32:06 2022 UTC (3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, HEAD
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

*: bump PKGREVISION for libunistring shlib major bump

Revision 1.46 / (download) - annotate - [select for diffs], Wed Dec 8 16:07:00 2021 UTC (13 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.45: +2 -2 lines
Diff to previous 1.45 (colored)

revbump for icu and libffi

Revision 1.45 / (download) - annotate - [select for diffs], Wed Sep 29 19:01:29 2021 UTC (16 months ago) by adam
Branch: MAIN
Changes since 1.44: +2 -2 lines
Diff to previous 1.44 (colored)

revbump for boost-libs

Revision 1.44 / (download) - annotate - [select for diffs], Wed Apr 21 13:25:31 2021 UTC (21 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.43: +2 -2 lines
Diff to previous 1.43 (colored)

revbump for boost-libs

Revision 1.43 / (download) - annotate - [select for diffs], Fri May 22 10:56:46 2020 UTC (2 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

revbump after updating security/nettle

Revision 1.42 / (download) - annotate - [select for diffs], Wed May 6 14:05:07 2020 UTC (2 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.41: +2 -1 lines
Diff to previous 1.41 (colored)

revbump after boost update

Revision 1.41 / (download) - annotate - [select for diffs], Fri Mar 20 17:58:37 2020 UTC (2 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.40: +2 -3 lines
Diff to previous 1.40 (colored)

www/ruby-patron: update to 0.13.3

Update ruby-patron to 0.13.3.


### 0.13.3

* Fix a number of specs that were failing due to use of threads

### 0.13.2

* Eagerly initialize libCURL handle when creating the Session instance instead of initializing it lazily
* Remove special treatment of `Session#reset` and make it the same as `Session#interrupt`

Revision 1.40 / (download) - annotate - [select for diffs], Sun Mar 8 16:51:39 2020 UTC (2 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.39: +2 -2 lines
Diff to previous 1.39 (colored)

*: recursive bump for libffi

Revision 1.39 / (download) - annotate - [select for diffs], Sat Jan 18 21:51:11 2020 UTC (3 years ago) by jperkin
Branch: MAIN
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

*: Recursive revision bump for openssl 1.1.1.

Revision 1.38 / (download) - annotate - [select for diffs], Sun Jan 12 20:20:49 2020 UTC (3 years ago) by ryoon
Branch: MAIN
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

*: Recursive revbump from devel/boost-libs

Revision 1.37 / (download) - annotate - [select for diffs], Thu Aug 22 12:23:54 2019 UTC (3 years, 5 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

Recursive revbump from boost-1.71.0

Revision 1.36 / (download) - annotate - [select for diffs], Sat Jul 20 22:46:56 2019 UTC (3 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.35: +2 -2 lines
Diff to previous 1.35 (colored)

*: recursive bump for nettle 3.5.1

Revision 1.35 / (download) - annotate - [select for diffs], Mon Jul 1 04:08:54 2019 UTC (3 years, 7 months ago) by ryoon
Branch: MAIN
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

Recursive revbump from boost-1.70.0

Revision 1.34 / (download) - annotate - [select for diffs], Thu Dec 13 19:52:26 2018 UTC (4 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

revbump for boost 1.69.0

Revision 1.33 / (download) - annotate - [select for diffs], Thu Aug 16 18:55:16 2018 UTC (4 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.32: +2 -1 lines
Diff to previous 1.32 (colored)

revbump after boost-libs update

Revision 1.32 / (download) - annotate - [select for diffs], Sun May 6 02:26:34 2018 UTC (4 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.31: +2 -3 lines
Diff to previous 1.31 (colored)

www/ruby-patron: update to 0.13.0

### 0.13.0

* Permit timeouts to be set as a Float of seconds and use `CURLOPT_(CONNECT)TIMEOUT_MS` instead of `CURLOPT_(CONNECT)TIMEOUT` so that
  sub-second timeouts can be configured, which is useful for performant services using accelerated DNS resolution.
* Remove the restriction that `Session#timeout` should be non-zero - a timeout set to 0 means "no timeout" in libCURL

Revision 1.31 / (download) - annotate - [select for diffs], Sun Apr 29 21:32:08 2018 UTC (4 years, 9 months ago) by adam
Branch: MAIN
Changes since 1.30: +2 -1 lines
Diff to previous 1.30 (colored)

revbump for boost-libs update

Revision 1.30 / (download) - annotate - [select for diffs], Sat Mar 17 14:43:29 2018 UTC (4 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.29: +2 -3 lines
Diff to previous 1.29 (colored)

www/ruby-patron: update to 0.12.1

### 0.12.1

* Ensure HTTP2 response headers/status lines are correctly handled

### 0.12.0

* Replace StringScanner in HeaderParser with StringIO, fix Webmock regression when the headers string would
  not have an empty CRLF-terminated line at the end - which would cause the parser to return a nil.
* Added `Session#dns_cache_timeout` as a config option for CURLOPT_DNS_CACHE_TIMEOUT

### 0.11.1

* Make sure StringScanner is available to HeaderParser.

### 0.11.0

* Added `Session#progress_callback` which accepts a callable object, which can be used to report session progress during request
  execution.
* Fixed parsing of response headers when multiple responses are involved (redirect chains and HTTP proxies)

### 0.10.0

* Added `Session#low_speed_time` and `Session#low_speed_limit`. When used, they will force libCURL to raise
  a timeout if a certain speed limit is not met performing the request. These can be used for better timeout
  handling. These are available in all libCURL versions. See https://curl.haxx.se/libcurl/c/CURLOPT_LOW_SPEED_TIME.html
  and https://curl.haxx.se/libcurl/c/CURLOPT_LOW_SPEED_LIMIT.html

Revision 1.29 / (download) - annotate - [select for diffs], Mon Jan 1 21:18:56 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.28: +2 -1 lines
Diff to previous 1.28 (colored)

Revbump after boost update

Revision 1.28 / (download) - annotate - [select for diffs], Mon Sep 11 15:35:37 2017 UTC (5 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.27: +2 -3 lines
Diff to previous 1.27 (colored)

Update ruby-patron to 0.9.1.

### 0.9.1

o Added ssl_version options `TLSv1_1`, `TLSv1_2`, `TLSv1_3` for explicitly
  forcing the SSL version

    * requires the appropriate versions of libCURL and OpenSSL installed to
      support these new options
    * reference: https://curl.haxx.se/libcurl/c/CURLOPT_SSLVERSION.html

o Added a new `:http_version` option with `HTTPv1_1` and `HTTPv2_0` values to
  explicitly set the HTTP version of HTTP/1.1 or HTTP/2.0

    * requires the appropriate versions of libCURL and OpenSSL installed to
      support these new options
    * reference: https://curl.haxx.se/libcurl/c/CURLOPT_HTTP_VERSION.html

o Updates the gem release procedure for more convenience, using the updated
  Rubygems.org tasks

o Update a few minor dependencies and documentation to be Ruby
  2.4.1-compatible, add 2.4.1. to Travis CI matrix

o Add `Session#download_byte_limit` for limiting the permitted download size.

  This can be very useful in dealing with untrusted download sources, which
  might attempt to send very large responses that would overwhelm the
  receiving client.

o Add `Patron.libcurl_version_exact` which returns a triplet of major, minor
  and patch libCURL version numbers. This can be used for more fine-grained
  matching when using some more esoteric Curl features which might not
  necessarily be available on libCURL Patron has been linked against.

Revision 1.27 / (download) - annotate - [select for diffs], Thu Aug 24 20:03:42 2017 UTC (5 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

Revbump for boost update

Revision 1.26 / (download) - annotate - [select for diffs], Sun Apr 30 01:22:03 2017 UTC (5 years, 9 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.25: +2 -2 lines
Diff to previous 1.25 (colored)

Recursive revbump from boost update

Revision 1.25 / (download) - annotate - [select for diffs], Sun Jan 1 16:06:39 2017 UTC (6 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.24: +2 -1 lines
Diff to previous 1.24 (colored)

Revbump after boost update

Revision 1.24 / (download) - annotate - [select for diffs], Tue Oct 18 16:02:47 2016 UTC (6 years, 3 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.23: +2 -3 lines
Diff to previous 1.23 (colored)

Update ruby-patron to 0.8.0.

### 0.8.0

* Add `Response#inspectable_body`, `Response#decoded_body`. `decoded_body` will atempt to decode
  the HTTP response into your internal encoding, using the charset header that the server has
  provided. Note that this operation may fail - if the server said that the body is in a certain
  encoding, but this is then overridden with, say, `meta` elements in the HTML Patron is _not_
  going to parse the HTML to figure out how to decode.

### 0.7.0

* Allow Ruby File objects to be passed as `data` to `Session#put`, `Sesion#post` etc.

### 0.6.5

* Prevent libCURL from doing requests to non-HTTP/HTTPS URLs, and from following redirects to such URLs

### 0.6.4

* Set the default User-Agent string, since some sites require it (like the Github API).
* Add Response#ok? and Response#error? for cleaner branching on the returned Response objects
* Explain a segfault with SSL in forked processes on OSX, document the way to avoid the issue
* Fix segfault when attempting multiple post requests with multipart (#119)

### 0.6.3

* Fix timeout when uploading a body using all verbs except POST
* Add PATCH HTTP verb support
* Populate the curl state object from the reader methods of `Request`

### 0.6.1

* Fix compilation on older versions of libCURL
* Fix cookie jar files not being saved after request
* Reformat the gem documentation to YARD, document a few behaviors

### 0.6.0

* Add `Patron::Session#automatic_content_encoding` for automatic deflate handling via `Accept`/`Content-Encoding`

### 0.5.1

* Allow customizing the class used for the response (now uses `Session#response_class` to determine the class at runtime)
* Do not fail body decoding if the charset name set in the header is invalid

Revision 1.23 / (download) - annotate - [select for diffs], Fri Oct 7 18:26:13 2016 UTC (6 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.22: +2 -1 lines
Diff to previous 1.22 (colored)

Revbump post boost update

Revision 1.22 / (download) - annotate - [select for diffs], Tue Mar 15 17:00:29 2016 UTC (6 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.21: +2 -3 lines
Diff to previous 1.21 (colored)

Update ruby-patron to 0.5.1.

* Cast request body to string when uploading
* Add the ability to override the Response class
* Ensure the form data is freed in cleanup
* Don't fail with invalid charset names

Revision 1.21 / (download) - annotate - [select for diffs], Sat Mar 5 11:29:39 2016 UTC (6 years, 10 months ago) by jperkin
Branch: MAIN
Changes since 1.20: +2 -1 lines
Diff to previous 1.20 (colored)

Bump PKGREVISION for security/openssl ABI bump.

Revision 1.20 / (download) - annotate - [select for diffs], Sun Oct 4 15:38:00 2015 UTC (7 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.19: +3 -3 lines
Diff to previous 1.19 (colored)

Update ruby-patron to 0.5.0.

Changes are not available.  Please refer:
	https://github.com/toland/patron/compare/v0.4.20...v0.5.0

Revision 1.19 / (download) - annotate - [select for diffs], Fri Mar 13 17:14:02 2015 UTC (7 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.18: +2 -3 lines
Diff to previous 1.18 (colored)

Update ruby-patronto 0.4.20.

* fix base url concatenation

* Adds instantiation settings via block or hash.
  Fixes .downcase being called on symbols.

  Cleaned up

  Cleans up hash setter. Adds block support

  Adds tests for hash and block instantiation

  Undoes string fix for patron/request.rb to keep with scope.

* Handle two failing specs

  One is failing due to no OS support for SSLv2. This is reasonable,
  so I just removed SSLv2 from the list of SSL versions to test. This
  doesn't change the meaning of the test at all.

  I could not find the root cause of the other spec failure, though
  I suspect it is a setup problem. I have disabled the spec for now
  and will revisit it later on.

* Add doc comment
* Add a way to get the Request object

* Revert request action to be a symbol, but still allow upcase and
  downcase strings.

Revision 1.18 / (download) - annotate - [select for diffs], Thu Mar 13 11:08:53 2014 UTC (8 years, 10 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.17: +3 -1 lines
Diff to previous 1.17 (colored)

Set USE_GCC_RUNTIME=yes for packages which build shared libraries but do
not use libtool to do so.  This is required to correctly depend upon a
gcc runtime package (e.g. gcc47-libs) when using USE_PKGSRC_GCC_RUNTIME.

Revision 1.17 / (download) - annotate - [select for diffs], Wed Feb 12 23:18:46 2014 UTC (8 years, 11 months ago) by tron
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.16 / (download) - annotate - [select for diffs], Mon Sep 9 12:29:26 2013 UTC (9 years, 4 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Resign as maintainer (not really using Ruby at all any more).

Revision 1.15 / (download) - annotate - [select for diffs], Wed Feb 6 23:24:03 2013 UTC (9 years, 11 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

PKGREVISION bumps for the security/openssl 1.0.1d update.

Revision 1.14 / (download) - annotate - [select for diffs], Sun Dec 16 01:52:39 2012 UTC (10 years, 1 month ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.13: +2 -1 lines
Diff to previous 1.13 (colored)

recursive bump from cyrus-sasl libsasl2 shlib major bump.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Mar 18 05:11:32 2012 UTC (10 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.12: +2 -3 lines
Diff to previous 1.12 (colored)

Update ruby-patron to 0.4.18.

Exact changes are unknown.

Revision 1.12 / (download) - annotate - [select for diffs], Tue Nov 8 15:37:34 2011 UTC (11 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.11: +2 -1 lines
Diff to previous 1.11 (colored)

* Remove .require_paths from PLIST
* Bump PKGREVISION.

Revision 1.11 / (download) - annotate - [select for diffs], Mon Sep 12 14:39:22 2011 UTC (11 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Update ruby-patron package to 0.4.16.

Changes are unknown.

Revision 1.10 / (download) - annotate - [select for diffs], Thu Aug 25 15:49:12 2011 UTC (11 years, 5 months ago) by taca
Branch: MAIN
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Update www/ruby-patron package to 0.4.15.

Compact changes are not available but some ruby19 related improvement.
Please refer detail: https://github.com/toland/patron/commits/master

Revision 1.9 / (download) - annotate - [select for diffs], Sat Aug 13 00:30:55 2011 UTC (11 years, 5 months ago) by taca
Branch: MAIN
Changes since 1.8: +2 -3 lines
Diff to previous 1.8 (colored)

Update www/ruby-patron package to 0.4.14.

Changes are unknown.

Revision 1.8 / (download) - annotate - [select for diffs], Fri Apr 22 13:45:00 2011 UTC (11 years, 9 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.7: +2 -1 lines
Diff to previous 1.7 (colored)

recursive bump from gettext-lib shlib bump.

Revision 1.7 / (download) - annotate - [select for diffs], Wed Mar 23 16:41:03 2011 UTC (11 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Update ruby-patron pacakge to 0.4.11.

* Added URL encoding when an action is a POST.

Revision 1.6 / (download) - annotate - [select for diffs], Wed Mar 23 15:30:25 2011 UTC (11 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.5: +2 -3 lines
Diff to previous 1.5 (colored)

Update ruby-patron package to 0.4.10.

0.4.10.

* buffer size option.
* Added mutipart post.

Revision 1.4.4.1 / (download) - annotate - [select for diffs], Sun Feb 27 00:26:31 2011 UTC (11 years, 11 months ago) by tron
Branch: pkgsrc-2010Q4
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored) next main 1.5 (colored)

Pullup ticket #3361 - requested by taca
archivers/ruby-libarchive: dependence update
comms/ruby-termios: dependence update
converters/ruby-uconv: dependence update
databases/ruby-do_sqlite3: dependence update
databases/ruby-ldap: dependence update
databases/ruby-mysql: dependence update
databases/ruby-odbc: dependence update
databases/ruby-pg: dependence update
databases/ruby-postgresql: dependence update
databases/ruby-qdbm: dependence update
databases/ruby-sqlite: dependence update
databases/ruby-sqlite3: dependence update
databases/ruby-tokyocabinet: dependence update
devel/ruby-SDL: dependence update
devel/ruby-debug-base: dependence update
devel/ruby-eet: dependence update
devel/ruby-eventmachine: dependence update
devel/ruby-ffi: dependence update
devel/ruby-gnome2-atk: dependence update
devel/ruby-gnome2-bonobo: dependence update
devel/ruby-gnome2-bonoboui: dependence update
devel/ruby-gnome2-gconf: dependence update
devel/ruby-gnome2-gio: dependence update
devel/ruby-gnome2-glib: dependence update
devel/ruby-gnome2-libglade: dependence update
devel/ruby-gnome2-pango: dependence update
devel/ruby-linecache: dependence update
devel/ruby-memcache: dependence update
devel/ruby-ncurses: dependence update
devel/ruby-priority-queue: dependence update
devel/ruby-racc: dependence update
devel/ruby-rbtree: dependence update
devel/ruby-rcov: dependence update
devel/ruby-rcsparse: dependence update
devel/ruby-subversion: dependence update
devel/ruby-thrift: dependence update
graphics/ruby-RMagick: dependence update
graphics/ruby-clutter-cairo: dependence update
graphics/ruby-clutter-core: dependence update
graphics/ruby-clutter-gtk: dependence update
graphics/ruby-gd: dependence update
graphics/ruby-gnome2-gdkpixbuf: dependence update
graphics/ruby-gnome2-gnomecanvas: dependence update
graphics/ruby-gnome2-goocanvas: dependence update
graphics/ruby-gnome2-gtkglext: dependence update
graphics/ruby-gnome2-libart: dependence update
graphics/ruby-gnome2-rsvg: dependence update
graphics/ruby-imlib2: dependence update
graphics/ruby-opengl: dependence update
graphics/ruby-rcairo: dependence update
inputmethod/ruby-zinnia: dependence update
lang/ruby: dependence update
lang/ruby18-base: security update
lang/ruby19-base: security update
mail/ruby-tmail: dependence update
math/ruby-rb-gsl: dependence update
multimedia/ruby-clutter-gst: dependence update
multimedia/ruby-gnome2-gstreamer: dependence update
multimedia/ruby-ming: dependence update
print/ruby-gnome2-gnomeprint: dependence update
print/ruby-gnome2-gnomeprintui: dependence update
print/ruby-gnome2-poppler: dependence update
security/ruby-password: dependence update
security/ruby-tcpwrap: dependence update
sysutils/ruby-quota: dependence update
textproc/ruby-bluecloth: dependence update
textproc/ruby-cabocha: dependence update
textproc/ruby-eruby: dependence update
textproc/ruby-ferret: dependence update
textproc/ruby-hpricot: dependence update
textproc/ruby-itex2MML: dependence update
textproc/ruby-json: dependence update
textproc/ruby-libxml: dependence update
textproc/ruby-mecab: dependence update
textproc/ruby-native-hyperestraier: dependence update
textproc/ruby-nokogiri: dependence update
textproc/ruby-oniguruma: dependence update
textproc/ruby-redcloth: dependence update
textproc/ruby-sary: dependence update
textproc/ruby-xmlparser: dependence update
textproc/ruby-xslt: dependence update
textproc/ruby-yamcha: dependence update
www/mongrel: dependence update
www/ruby-clearsilver: dependence update
www/ruby-fcgi: dependence update
www/ruby-gnome2-gtkhtml2: dependence update
www/ruby-gnome2-gtkmozembed: dependence update
www/ruby-patron: dependence update
www/thin: dependence update
x11/ruby-gnome2-gnome: dependence update
x11/ruby-gnome2-gtk: dependence update
x11/ruby-gnome2-gtksourceview: dependence update
x11/ruby-gnome2-gtksourceview2: dependence update
x11/ruby-gnome2-panelapplet: dependence update
x11/ruby-gnome2-vte: dependence update

Revisions pulled up:
- archivers/ruby-libarchive/Makefile				1.2
- comms/ruby-termios/Makefile					1.23
- converters/ruby-uconv/Makefile				1.19
- databases/ruby-do_sqlite3/Makefile				1.2
- databases/ruby-ldap/Makefile					1.7
- databases/ruby-mysql/Makefile					1.34 via patch
- databases/ruby-odbc/Makefile					1.10 via patch
- databases/ruby-pg/Makefile					1.6
- databases/ruby-postgresql/Makefile				1.37
- databases/ruby-qdbm/Makefile					1.12
- databases/ruby-sqlite/Makefile				1.3
- databases/ruby-sqlite3/Makefile				1.15
- databases/ruby-tokyocabinet/Makefile				1.24
- devel/ruby-SDL/Makefile					1.9 via patch
- devel/ruby-debug-base/Makefile				1.7
- devel/ruby-eet/Makefile					1.8
- devel/ruby-eventmachine/Makefile				1.7
- devel/ruby-ffi/Makefile					1.3
- devel/ruby-gnome2-atk/Makefile				1.8
- devel/ruby-gnome2-bonobo/Makefile				patch
- devel/ruby-gnome2-bonoboui/Makefile				patch
- devel/ruby-gnome2-gconf/Makefile				patch
- devel/ruby-gnome2-gio/Makefile				1.3 via patch
- devel/ruby-gnome2-glib/Makefile				1.11
- devel/ruby-gnome2-libglade/Makefile				patch
- devel/ruby-gnome2-pango/Makefile				1.18 via patch
- devel/ruby-linecache/Makefile					1.5
- devel/ruby-memcache/Makefile					1.4
- devel/ruby-ncurses/Makefile					1.9
- devel/ruby-priority-queue/Makefile				1.6
- devel/ruby-racc/Makefile					1.18
- devel/ruby-rbtree/Makefile					1.6
- devel/ruby-rcov/Makefile					1.5
- devel/ruby-rcsparse/Makefile					1.10
- devel/ruby-subversion/Makefile				1.28
- devel/ruby-thrift/Makefile					1.4 via patch
- graphics/ruby-RMagick/Makefile				1.76 via patch
- graphics/ruby-clutter-cairo/Makefile				1.8 via patch
- graphics/ruby-clutter-core/Makefile				1.11 via patch
- graphics/ruby-clutter-gtk/Makefile				1.8 via patch
- graphics/ruby-gd/Makefile					1.34 via patch
- graphics/ruby-gnome2-gdkpixbuf/Makefile			1.20 via patch
- graphics/ruby-gnome2-gnomecanvas/Makefile			patch
- graphics/ruby-gnome2-goocanvas/Makefile			1.12 via patch
- graphics/ruby-gnome2-gtkglext/Makefile			patch
- graphics/ruby-gnome2-libart/Makefile				patch
- graphics/ruby-gnome2-rsvg/Makefile				1.21 va patch
- graphics/ruby-imlib2/Makefile					1.24 va patch
- graphics/ruby-opengl/Makefile					1.31
- graphics/ruby-rcairo/Makefile					1.22 via patch
- inputmethod/ruby-zinnia/Makefile				1.3
- lang/ruby/buildlink3.mk					1.13
- lang/ruby/rubyversion.mk					1.58-1.59
- lang/ruby18-base/distinfo					1.47
- lang/ruby19-base/DEINSTALL					1.2
- lang/ruby19-base/Makefile					1.7
- lang/ruby19-base/PLIST					1.4
- lang/ruby19-base/distinfo					1.4
- lang/ruby19-base/patches/patch-string.c			1.1
- mail/ruby-tmail/Makefile					1.19
- math/ruby-rb-gsl/Makefile					1.9
- multimedia/ruby-clutter-gst/Makefile				1.9 via patch
- multimedia/ruby-gnome2-gstreamer/Makefile			1.7
- multimedia/ruby-ming/Makefile					1.15 via patch
- print/ruby-gnome2-gnomeprint/Makefile				patch
- print/ruby-gnome2-gnomeprintui/Makefile			patch
- print/ruby-gnome2-poppler/Makefile				1.19 via patch
- security/ruby-password/Makefile				1.5
- security/ruby-tcpwrap/Makefile				1.18
- sysutils/ruby-quota/Makefile					1.21
- textproc/ruby-bluecloth/Makefile				1.5
- textproc/ruby-cabocha/Makefile				1.3
- textproc/ruby-eruby/Makefile					1.26
- textproc/ruby-ferret/Makefile					1.6
- textproc/ruby-hpricot/Makefile				1.8
- textproc/ruby-itex2MML/Makefile				1.7
- textproc/ruby-json/Makefile					1.9
- textproc/ruby-libxml/Makefile					1.7
- textproc/ruby-mecab/Makefile					1.6
- textproc/ruby-native-hyperestraier/Makefile			1.6
- textproc/ruby-nokogiri/Makefile				1.4
- textproc/ruby-oniguruma/Makefile				1.6
- textproc/ruby-redcloth/Makefile				1.14
- textproc/ruby-sary/Makefile					1.7
- textproc/ruby-xmlparser/Makefile				1.15
- textproc/ruby-xslt/Makefile					1.7
- textproc/ruby-yamcha/Makefile					1.3
- www/mongrel/Makefile						1.13 via patch
- www/ruby-clearsilver/Makefile					1.15
- www/ruby-fcgi/Makefile					1.15
- www/ruby-gnome2-gtkhtml2/Makefile				patch
- www/ruby-gnome2-gtkmozembed/Makefile				1.17 via patch
- www/ruby-patron/Makefile					1.5
- www/thin/Makefile						1.8 via patch
- x11/ruby-gnome2-gtk/Makefile					1.25 via patch
- x11/ruby-gnome2-gtksourceview/Makefile			patch via 1.12
- x11/ruby-gnome2-gtksourceview2/Makefile			patch
- x11/ruby-gnome2-panelapplet/Makefile				patch
- x11/ruby-gnome2-vte/Makefile					1.16 via patch
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:31:06 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: rubyversion.mk

Log Message:
* Start upate of ruby18 and ruby19 packags.
* Remove redundant GEM_HOME definition from PLIST.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:35:38 UTC 2011

Modified Files:
	pkgsrc/lang/ruby18-base: distinfo

Log Message:
Update ruby18-base package to 1.8.7.334 (Ruby 1.8.7p334).

* The FileUtils Vulnerability

	http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* The $SAFE Vulnerability

Fri Feb 18 21:18:55 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* test/ruby/test_exception.rb (TestException::test_to_s_taintness_propagation):
	  Test for below.

Fri Feb 18 21:18:55 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* error.c (exc_to_s): untainted strings can be tainted via
	  Exception#to_s, which enables attackers to overwrite sane strings.
	  Reported by: Yusuke Endoh <mame at tsg.ne.jp>.

	* error.c (name_err_to_s): ditto.

Fri Feb 18 21:17:22 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* lib/fileutils.rb (FileUtils::remove_entry_secure): there is a
	  race condition in the case where the given path is a directory,
	  and some other user can move that directory, and create a
	  symlink while this method is executing.
	  Reported by: Nicholas Jefferson <nicholas at pythonic.com.au>

Fri Feb 18 19:46:46 2011  NAKAMURA Usaku  <usa@ruby-lang.org>

	* win32/win32.c (init_stdhandle): backport mistake of r29382.
	  some code are needless in ruby 1.8.
	  [ruby-core:34579]

Fri Feb 18 19:22:17 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* configure.in: revert revision r29854.	 This revision introduced
	  binary incompatibilities on some circumstances.  The bug that
	  revision was fixing gets reopened by this reversion.
	  [ruby-dev:43152] cf. [Bug #2553]
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:44:11 UTC 2011

Modified Files:
	pkgsrc/lang/ruby19-base: DEINSTALL Makefile PLIST distinfo
Added Files:
	pkgsrc/lang/ruby19-base/patches: patch-string.c

Log Message:
Update ruby19-base package to 1.9.2pl180 (Ruby 1.9.2 p180).

* The FileUtils Vulnerability

    http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* Add a patch r30779 from repository; a bug of utf-8 string handling.

For more detail changes of Ruby 1.9.2pl180, please refer:
	http://svn.ruby-lang.org/repos/ruby/tags/v1_9_2_180/ChangeLog
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 15:00:34 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: buildlink3.mk rubyversion.mk

Log Message:
Introduce RUBY_ABI_VERSION and use it BUILDLINK_ABI_DEPENDS.

There are ABI incompatibility amaong Ruby 1.8.7 patchlevel 302, 330 and 334,
So it would be handle if such problem in future.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 16:01:24 UTC 2011

Modified Files:
	pkgsrc/archivers/ruby-libarchive: Makefile
	pkgsrc/comms/ruby-termios: Makefile
	pkgsrc/converters/ruby-uconv: Makefile
	pkgsrc/databases/ruby-do_sqlite3: Makefile
	pkgsrc/databases/ruby-ldap: Makefile
	pkgsrc/databases/ruby-mysql: Makefile
	pkgsrc/databases/ruby-odbc: Makefile
	pkgsrc/databases/ruby-pg: Makefile
	pkgsrc/databases/ruby-postgresql: Makefile
	pkgsrc/databases/ruby-qdbm: Makefile
	pkgsrc/databases/ruby-sqlite: Makefile
	pkgsrc/databases/ruby-sqlite3: Makefile
	pkgsrc/databases/ruby-tokyocabinet: Makefile
	pkgsrc/devel/ruby-SDL: Makefile
	pkgsrc/devel/ruby-debug-base: Makefile
	pkgsrc/devel/ruby-eet: Makefile
	pkgsrc/devel/ruby-eventmachine: Makefile
	pkgsrc/devel/ruby-ffi: Makefile
	pkgsrc/devel/ruby-gnome2-atk: Makefile
	pkgsrc/devel/ruby-gnome2-gio: Makefile
	pkgsrc/devel/ruby-gnome2-glib: Makefile
	pkgsrc/devel/ruby-gnome2-pango: Makefile
	pkgsrc/devel/ruby-linecache: Makefile
	pkgsrc/devel/ruby-memcache: Makefile
	pkgsrc/devel/ruby-ncurses: Makefile
	pkgsrc/devel/ruby-priority-queue: Makefile
	pkgsrc/devel/ruby-racc: Makefile
	pkgsrc/devel/ruby-rbtree: Makefile
	pkgsrc/devel/ruby-rcov: Makefile
	pkgsrc/devel/ruby-rcsparse: Makefile
	pkgsrc/devel/ruby-subversion: Makefile
	pkgsrc/devel/ruby-thrift: Makefile
	pkgsrc/graphics/ruby-RMagick: Makefile
	pkgsrc/graphics/ruby-clutter-cairo: Makefile
	pkgsrc/graphics/ruby-clutter-core: Makefile
	pkgsrc/graphics/ruby-clutter-gtk: Makefile
	pkgsrc/graphics/ruby-gd: Makefile
	pkgsrc/graphics/ruby-gnome2-gdkpixbuf: Makefile
	pkgsrc/graphics/ruby-gnome2-goocanvas: Makefile
	pkgsrc/graphics/ruby-gnome2-rsvg: Makefile
	pkgsrc/graphics/ruby-imlib2: Makefile
	pkgsrc/graphics/ruby-opengl: Makefile
	pkgsrc/graphics/ruby-rcairo: Makefile
	pkgsrc/inputmethod/ruby-zinnia: Makefile
	pkgsrc/mail/ruby-tmail: Makefile
	pkgsrc/math/ruby-rb-gsl: Makefile
	pkgsrc/multimedia/ruby-clutter-gst: Makefile
	pkgsrc/multimedia/ruby-gnome2-gstreamer: Makefile
	pkgsrc/multimedia/ruby-ming: Makefile
	pkgsrc/print/ruby-gnome2-poppler: Makefile
	pkgsrc/security/ruby-password: Makefile
	pkgsrc/security/ruby-tcpwrap: Makefile
	pkgsrc/sysutils/ruby-quota: Makefile
	pkgsrc/textproc/ruby-bluecloth: Makefile
	pkgsrc/textproc/ruby-cabocha: Makefile
	pkgsrc/textproc/ruby-eruby: Makefile
	pkgsrc/textproc/ruby-ferret: Makefile
	pkgsrc/textproc/ruby-hpricot: Makefile
	pkgsrc/textproc/ruby-itex2MML: Makefile
	pkgsrc/textproc/ruby-json: Makefile
	pkgsrc/textproc/ruby-libxml: Makefile
	pkgsrc/textproc/ruby-mecab: Makefile
	pkgsrc/textproc/ruby-native-hyperestraier: Makefile
	pkgsrc/textproc/ruby-nokogiri: Makefile
	pkgsrc/textproc/ruby-oniguruma: Makefile
	pkgsrc/textproc/ruby-redcloth: Makefile
	pkgsrc/textproc/ruby-sary: Makefile
	pkgsrc/textproc/ruby-xmlparser: Makefile
	pkgsrc/textproc/ruby-xslt: Makefile
	pkgsrc/textproc/ruby-yamcha: Makefile
	pkgsrc/www/mongrel: Makefile
	pkgsrc/www/ruby-clearsilver: Makefile
	pkgsrc/www/ruby-fcgi: Makefile
	pkgsrc/www/ruby-gnome2-gtkmozembed: Makefile
	pkgsrc/www/ruby-patron: Makefile
	pkgsrc/www/thin: Makefile
	pkgsrc/x11/ruby-gnome2-gtk: Makefile
	pkgsrc/x11/ruby-gnome2-gtksourceview2: Makefile
	pkgsrc/x11/ruby-gnome2-vte: Makefile

Log Message:
Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.5 / (download) - annotate - [select for diffs], Mon Feb 21 16:01:23 2011 UTC (11 years, 11 months ago) by taca
Branch: MAIN
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.4 / (download) - annotate - [select for diffs], Thu Sep 23 06:53:58 2010 UTC (12 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Branch point for: pkgsrc-2010Q4
Changes since 1.3: +3 -3 lines
Diff to previous 1.3 (colored)

Update www/ruby-patron to 0.4.9.


0.4.9

use rb_hash_foreach to make this work on rubinius and jruby

Revision 1.3 / (download) - annotate - [select for diffs], Fri Sep 10 13:15:44 2010 UTC (12 years, 4 months ago) by taca
Branch: MAIN
Changes since 1.2: +3 -9 lines
Diff to previous 1.2 (colored)

Update www/ruby-patron to 0.4.8.

* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Remove default value of GEM_BUILD.
* Ajust new ruby package's framework.

Changes are unknown.

Revision 1.2 / (download) - annotate - [select for diffs], Sun Jan 17 12:02:50 2010 UTC (13 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Recursive PKGREVISION bump for jpeg update to 8.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Wed Dec 2 12:13:28 2009 UTC (13 years, 2 months ago) by fhajny
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Import ruby18-patron-0.4.4 as www/ruby-patron.

Patron is a Ruby HTTP client library based on libcurl. It does not try
to expose the full "power" (read complexity) of libcurl but instead
tries to provide a sane API while taking advantage of libcurl under
the hood.

Revision 1.1 / (download) - annotate - [select for diffs], Wed Dec 2 12:13:28 2009 UTC (13 years, 2 months ago) by fhajny
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>