[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / ruby-html-proofer

File: [cvs.NetBSD.org] / pkgsrc / www / ruby-html-proofer / Makefile (download)

Revision 1.4, Sun Dec 19 06:48:46 2021 UTC (9 months, 2 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.3: +3 -3 lines

www/ruby-html-proofer: update to 3.19.3

3.19.3 (2021-12-17)

Fixed bugs:

* mailto without email shouldn't fail #552

Closed issues:

* links without html suffix claimed to be broken #654
* Unexpected 404 link #648
* Thread 0 Crashes on M1 chip (MacOS Big Sur 13.1) #646
* Add GitHub Action wrappers to README? #642
* Add support for site.baseurl, workaround #618
* Some URLs are reported invalid but are in fact OK #581
* Internally linking to <valid URL> which does not exist #542

Merged pull requests:

* Add typhoeus-config user agent and cookies snippets to the README #666
  (JackWilb)
* Run htmlproofer and precede it with the correct ruby binary #665
  (dleidert)
* Document how to adjust for a baseurl #658 (PeterJCLaw)
* Add flag to allow no-email mailto links #657 (PeterJCLaw)
* fix redirect (after changing name of master branch) #653 (matkoniecz)
* Add example using proof-html GitHub action #651 (anishathalye)
* Replace Nokogumbo with Nokogiri #650 (stevecheckoway)
* Apply Uniq filter to remove duplicate issues #649 (uberfuzzy)

# $NetBSD: Makefile,v 1.4 2021/12/19 06:48:46 taca Exp $

DISTNAME=	html-proofer-3.19.3
CATEGORIES=	www
MASTER_SITES=	http://rubygems.org/downloads/

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	https://rubygems.org/gems/html-proofer/
COMMENT=	Test your rendered HTML files to make sure they're accurate
LICENSE=	mit

DEPENDS+=	${RUBY_PKGPREFIX}-addressable>=2.3:../../net/ruby-addressable
DEPENDS+=	${RUBY_PKGPREFIX}-mercenary>=0.3:../../devel/ruby-mercenary
DEPENDS+=	${RUBY_PKGPREFIX}-nokogumbo>=2.0.2:../../textproc/ruby-nokogumbo
DEPENDS+=	${RUBY_PKGPREFIX}-parallel>=1.3:../../misc/ruby-parallel
DEPENDS+=	${RUBY_PKGPREFIX}-rainbow>=3.0:../../misc/ruby-rainbow
DEPENDS+=	${RUBY_PKGPREFIX}-typhoeus>=1.3.1:../../www/ruby-typhoeus
DEPENDS+=	${RUBY_PKGPREFIX}-yell>=2.0<3:../../devel/ruby-yell

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"