File:  [cvs.NetBSD.org] / pkgsrc / www / ruby-css-parser / Makefile
Revision 1.30: download - view: text, annotated - select for diffs
Sun Sep 22 07:54:34 2024 UTC (7 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
www/ruby-css-parser: update to 1.19.0

1.19.0 (2024-08-24)

* Deprecate load_uri!, load_file! and load_string! positional arguments over
  keyword argument

* Deprecate add_rule! (positional arguments)and add_rule_with_offsets! for
  add_rule! (keyword argument)

* RuleSet initialize now takes keyword argument, positional arguments are
  still supported but deprecated

* Removed OffsetAwareRuleSet, it's a RuleSet with optional attributes
  filename and offset

* Improved performance of block parsing by using StringScanner

* Improve RuleSet#parse_declarations! performance by using substring search
  istead of regexps

# $NetBSD: Makefile,v 1.30 2024/09/22 07:54:34 taca Exp $

DISTNAME=	css_parser-1.19.0
PKGNAME=	${RUBY_PKGPREFIX}-${DISTNAME:S/_/-/g}
CATEGORIES=	www

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/premailer/css_parser
COMMENT=	Ruby CSS parser
LICENSE=	mit

DEPENDS+=	${RUBY_PKGPREFIX}-addressable>=0:../../net/ruby-addressable

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>