File:  [cvs.NetBSD.org] / pkgsrc / www / qDecoder / Makefile
Revision 1.11: download - view: text, annotated - select for diffs
Sun Oct 28 06:31:02 2012 UTC (12 years, 5 months ago) by asau
Branches: MAIN
CVS tags: HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.11 2012/10/28 06:31:02 asau Exp $
#

DISTNAME=	qDecoder-9.0.1
CATEGORIES=	www
MASTER_SITES=	ftp://ftp.qDecoder.org/pub/qDecoder/

MAINTAINER=	jypak@users.sourceforge.net
HOMEPAGE=	http://www.qDecoder.org/
COMMENT=	Web Application Interface for C/C++ (CGI Library)

GNU_CONFIGURE=	YES
USE_LIBTOOL=	YES
INSTALLATION_DIRS=	include lib share/doc/qDecoder share/doc/qDecoder/html \
			share/examples/qDecoder share/examples/qDecoder/qDecoder-upload

post-install:
	cd ${WRKSRC}; ${INSTALL_DATA} AUTHORS CHANGES COPYING \
		qDecoder.jpg ${DESTDIR}${PREFIX}/share/doc/qDecoder
	cd ${WRKSRC}/src; ${INSTALL_DATA} qDecoder.h ${DESTDIR}${PREFIX}/include
	cd ${WRKSRC}/doc/html; ${INSTALL_DATA} * ${DESTDIR}${PREFIX}/share/doc/qDecoder/html
	cd ${WRKSRC}/examples; ${INSTALL_DATA} *.c *.conf s*.in \
		*.html ${DESTDIR}${PREFIX}/share/examples/qDecoder
	cd ${WRKSRC}/examples/qDecoder-upload; ${INSTALL_DATA} *.html *.js \
		${DESTDIR}${PREFIX}/share/examples/qDecoder/qDecoder-upload

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>