The NetBSD Project

CVS log for pkgsrc/www/py-wtforms/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-wtforms

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.21: download - view: text, markup, annotated - select for diffs
Fri Feb 7 09:27:02 2025 UTC (2 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, HEAD
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +8 -13 lines
py-wtforms: updated to 3.2.1

Version 3.2.1

- Fix :class:`~fields.SelectMultipleBase` import. :issue:`861` :pr:`862`

Version 3.2.0

- Translations update: korean, chinese (traditional), portugese, russian,
  dutch, kazakh, swedish, turkish, slovak, ukranian, spanish, french.
- Move the repository to the pallets-eco organization. :pr:`854`
- Stop supporting Python 3.9 and start supporting Python 3.13 :pr:`855`
- Removed `required` flag support from :class:`~fields.HiddenWidget`,
  :class:`~fields.RangeWidget` and :class:`~fields.SelectWidget` to
  conform to W3C :pr:`810`
- :class:`~wtforms.validators.NoneOf` and :class:`~wtforms.validators.AnyOf`
  can validate multiple valued fields like :class:`~fields.SelectMultipleField`
  :pr:`538` :pr:`807`
- Use GHA and pre-commit workflows inspired from Flask. :pr:`856` :pr:`860`
- ⚠️Breaking change⚠️: Some deprecated code was removed (:pr:`859`):

  - :class:`~wtforms.Flags` can no longer be tuples. :issue:`467`
  - `iter_choices` needs a tuple of 4 items :issue:`816`

- ⚠️Breaking change⚠️: The key for form errors moved from :data:`None` to
  empty string `""`. :issue:`829` :pr:`858`

.. note::
   If you need to keep the old behavior you can set the ``_form_error_key``
   parameter of your form to :data:`None`.

Revision 1.20: download - view: text, markup, annotated - select for diffs
Wed Mar 6 21:39:44 2024 UTC (13 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +7 -1 lines
py-wtforms: fix build with Python 3.12

Revision 1.19: download - view: text, markup, annotated - select for diffs
Wed Mar 6 21:25:50 2024 UTC (13 months, 1 week ago) by wiz
Branches: MAIN
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +7 -6 lines
py-wtforms: update to 3.1.2.

Version 3.1.2
-------------

Released 2024-01-06

- Fix :class:`~fields.SelectMultipleField` value coercion on validation.
  :issue:`822` :pr:`823`

Version 3.1.1
-------------

Released 2023-11-01

- Display :class:`~wtforms.Flags` values in their repr. :pr:`808`
- :class:`~fields.SelectField` and :class:`~fields.SelectMultipleField`
  ``choices`` can be `None` if `validate_choice` is `False` :pr:`809`
- Documentation improvements :pr:`812` :pr:`815` :pr:`817`
- Unit tests improvements :pr:`813`
- Python 3.12 support :pr:`818`
- Restored support for 3-items tuple return value from `iter_choices`
  :pr:`816`


Version 3.1.0
-------------

Released 2023-10-10

-   Documentation improvements :pr:`726` :pr:`733` :pr:`749`
    :pr:`767` :pr:`788` :pr:`789` :pr:`793`
-   Translation improvements :pr:`732` :pr:`734` :pr:`754`
-   Implement :class:`~fields.ColorField` :pr:`755`
-   Delayed import of ``email_validator``. :issue:`727`
-   ``<option>`` attributes can be passed by the :class:`~fields.SelectField`
    ``choices`` parameter :issue:`692` :pr:`739`.
    ⚠️breaking change⚠️: `iter_choices` now returns a tuple of 4 items
-   Use the standard datetime formats by default for
    :class:`~fields.DateTimeLocalField`  :pr:`761`
-   Python 3.11 support :pr:`763`
-   Added shorter format to :class:`~fields.DateTimeLocalField`
    defaults :pr:`761`
-   Stop support for python 3.7 :pr:`794`
-   Added shorter format to :class:`~fields.WeekField`
    defaults :pr:`765`
-   Move to pyproject.toml :pr:`796`
-   URL validator takes a ``allow_ip`` parameter :pr:`800`
-   Implement :class:`~validators.ReadOnly` and
    :class:`~validators.Disabled` `:pr:`788`

Revision 1.18: download - view: text, markup, annotated - select for diffs
Wed May 25 15:19:54 2022 UTC (2 years, 10 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +4 -8 lines
py-wtforms: Update to 3.0.1.

Version 3.0.1
-------------

Released 2021-12-23

-   Fixed :class:`~fields.DateTimeField` and other similar fields can
    handle multiple formats. :issue:`720` :pr:`721`
-   Stop support for python 3.6 :pr:`722`

Version 3.0.0
-------------

Released 2021-11-07

-   Fixed :class:`~fields.RadioField` validators. :issue:`477` :pr:`615`
-   :meth:`~fields.FormField.populate_obj` always calls :func:`setattr`
    :pr:`675`
-   WTForms has a new logo. :issue:`569` :pr:`689`
-   Fixed :class:`~fields.RadioField` `render_kw` rendering. :issue:`490`
    :pr:`628` :pr:`688`
-   Support for optgroups in :class:`~fields.SelectField` and
    :class:`~fields.SelectMultipleField`. :issue:`656` :pr:`667`
-   Minor documentation fix. :issue:`701`
-   Custom separators for :class:`~fields.FieldList`. :issue:`681` :pr:`694`
-   :class:`~fields.DateTimeField`, :class:`~fields.DateField` and
    :class:`~fields.TimeField` support time formats that removes leading
    zeros. :pr:`703`
-   Refactoring: split `fields/core.py` and `fields/simple.py` :pr:`710`

Version 3.0.0a1
---------------

Released 2020-11-23

-   Drop support for Python < 3.6. :pr:`554`
-   :class:`~fields.StringField` sets ``data`` to ``None`` when form
    data is empty and an initial value was not provided. Although it
    previously set an empty string, ``None`` is consistent with the
    behavior of other fields. :pr:`355`
-   Specified version of Babel required for setup to avoid errors.
    :pr:`430`
-   Replaced use of ``getattr``/``setattr`` with regular variable
    access. :issue:`482`
-   :class:`ValueError` raised by a validator are handled like regular
    exceptions. Validators need to raise
    :class:`~validators.ValidationError` or
    :class:`~validators.StopValidation` to make a validation fail.
    :issue:`445`
-   :class:`~fields.SelectField`, :class:`~fields.SelectMultipleField` and
    :class:`~fields.RadioField` *choices* parameter can be a callable.
    :pr:`608`
-   Choices shortcut for :class:`~fields.core.SelectMultipleField`.
    :issue:`603` :pr:`605`
-   Forms can have form-level errors. :issue:`55` :pr:`595`
-   Implemented :class:`~wtforms.fields.core.MonthField`. :pr:`530` :pr:`593`
-   Filters can be inline. :meth:`form.BaseForm.process` takes a
    *extra_filters* parameter. :issue:`128` :pr:`592`
-   Fields can be passed the ``name`` argument to use a HTML name
    different than their Python name. :issue:`205`, :pr:`601`
-   Render attribute names like ``for_`` and ``class_`` are normalized
    consistently so later values override those specified earlier.
    :issue:`449`, :pr:`596`
-   Flags can take non-boolean values. :issue:`406` :pr:`467`
-   Widgets are HTML5 by default. :issue:`594` :pr:`614`
-   Fixed a bug when the :class:`~wtforms.fields.core.SelectField` choices
    are list of strings. :pr:`598`
-   Error messages standardization. :issue:`613` :pr:`620` :pr:`626` :pr:`627`
-   :class:`~wtforms.fields.core.SelectMultipleField` `validate_choice`
    bugfix. :issue:`606` :pr:`642`
-   Fixed SelectMultipleField validation when using choices list shortcut.
    :issue:`612` :pr:`661`

Revision 1.17: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:55:38 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.16: download - view: text, markup, annotated - select for diffs
Thu Sep 3 19:20:23 2020 UTC (4 years, 7 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
py-wtforms: Update to 2.3.3.

Version 2.3.3
-------------

Released 2020-07-30

-   This release includes the translation files that were missing in the
    2.3.2 release. :issue:`641`


Version 2.3.2
-------------

Released 2020-07-29

-   Fixed a bug with :class:`~fields.SelectField` choices shortcut at
    form submission. :pr:`598, 639`

Revision 1.15: download - view: text, markup, annotated - select for diffs
Mon May 11 13:38:37 2020 UTC (4 years, 11 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2 lines
py-wtforms: Update to 2.3.1.

Version 2.3.1
-------------

Released 2020-04-22

-   All modules in ``wtforms.ext`` show a deprecation warning on import.
    They will be removed in version 3.0.
-   Fixed a bug when :class:`~fields.SelectField` choices is ``None``.
    :issue:`572, 585`
-   Restored ``HTMLString`` and ``escape_html`` as aliases for
    MarkupSafe functions. Their use shows a ``DeprecationWarning``.
    :issue:`581`, :pr:`583`
-   ``Form.validate`` takes an ``extra_validators`` parameter, mapping
    field names to lists of extra validator functions. This matches
    ``BaseForm.validate``. :pr:`584`
-   Update locale catalogs.


Version 2.3.0
-------------

Released 2020-04-21

-   Drop support for Python 2.6, 3.3, and 3.4.
-   :class:`~fields.SelectField` uses ``list()`` to construct a new list
    of choices. :pr:`475`
-   Permitted underscores in ``HostnameValidation``. :pr:`463`
-   :class:`~validators.URL` validator now allows query parameters in
    the URL. :issue:`523`, :pr:`524`
-   Updated ``false_values`` param in ``BooleanField`` docs.
    :issue:`483`, :pr:`485`
-   Fixed broken format string in Arabic translation :pr:`471`
-   Updated French and Japanese translations. :pr:`506, 514`
-   Updated Ukrainian translation. :pr:`433`
-   ``FieldList`` error list keeps entries in order for easier
    identification of which fields had errors. :issue:`257`, :pr:`407`
-   :class:`~validators.Length` gives a more helpful error message when
    ``min`` and ``max`` are the same value. :pr:`266`
-   :class:`~fields.SelectField` no longer coerces ``None`` to
    ``"None"`` allowing use of ``"None"`` as an option. :issue:`289`,
    :pr:`288`
-   The :class:`~widgets.TextArea` widget prepends a ``\r\n`` newline
    when rendering to account for browsers stripping an initial line for
    display. This does not affect the value. :issue:`238`, :pr:`395`
-   HTML5 :class:`~fields.html5.IntegerField` and
    :class:`~fields.html5.RangeInput` don't render the ``step="1"``
    attribute by default. :pr:`343`
-   ``aria_`` args are rendered the same way as ``data_`` args, by
    converting underscores to hyphens. ``aria_describedby="name-help"``
    becomes ``aria-describedby="name-help"``. :issue:`239`, :pr:`389`
-   Added a ``check_validators`` method to :class:`~fields.Field` which
    checks if the given validators are both callable, and not classes.
    :pr:`298, 410`
-   ``form.errors`` is not cached and will update if an error is
    appended to a field after access. :pr:`568`
-   :class:`~wtforms.validators.NumberRange` correctly handle NaN
    values. :issue:`505`, :pr:`548`
-   :class:`~fields.IntegerField` checks input type when processing
    data. :pr:`451`
-   Added a parameter to :class:`~fields.SelectField` to skip choice
    validation. :issue:`434`, :pr:`493`
-   Choices which name and data are the same do not need to use tuples.
    :pr:`526`
-   Added more documentation on HTML5 fields. :pr:`326, 409`
-   HTML is escaped using MarkupSafe instead of the previous internal
    implementation. :func:`~widgets.core.escape_html` is removed,
    replaced by :func:`markupsafe.escape`.
    :class:`~widgets.core.HTMLString` is removed, replaced by
    :class:`markupsafe.Markup`. :pr:`400`
-   Fixed broken IPv6 validator, validation now uses the ``ipaddress``
    package. :issue:`385`, :pr:`403`
-   :class:`~fields.core.Label` text is escaped before rendering.
    :issue:`315`, :pr:`375`
-   Email validation is now handled by an optional library,
    ``email_validator``. :pr:`429`

Revision 1.14: download - view: text, markup, annotated - select for diffs
Mon Nov 12 12:25:51 2018 UTC (6 years, 5 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +12 -4 lines
py-wtforms: Update to 2.2.1.


Version 2.2.1
-------------

Released on June 7th, 2018

-   :class:`~fields.StringField` only sets ``data = ''`` when form data
    is empty and an initial value was not provided. This fixes an issue
    where the default value wasn't rendered with the initial form.
    (`#291`_, `#401`_)

.. _#291: https://github.com/wtforms/wtforms/issues/291
.. _#401: https://github.com/wtforms/wtforms/issues/401


Version 2.2
-----------

Released on June 2nd, 2018

-   Merged new and updated translations from the community.
-   Passing ``data_`` args to render a field converts all the
    underscores to hyphens when rendering the HTML attribute, not just
    the first one. ``data_foo_bar`` becomes ``data-foo-bar``. (`#248`_)
-   The :class:`~validators.UUID` validator uses the :class:`uuid.UUID`
    class instead of a regex. (`#251`_)
-   :class:`~fields.SelectField` copies the list of ``choices`` passed
    to it so modifying an instance's choices will not modify the global
    form definition. (`#286`_)
-   Fields call :meth:`~fields.Field.process_formdata` even if the raw
    data is empty. (`#280`_)
-   Added a :class:`~fields.MultipleFileField` to handle a multi-file
    input. :class:`~fields.FileField` continues to handle only one
    value. The underlying :class:`~widgets.FileInput` widget gained a
    ``multiple`` argument. (`#281`_)
-   :class:`~fields.SelectField` choices can contain HTML (MarkupSafe
    ``Markup`` object or equivalent API) and will be rendered properly.
    (`#302`_)
-   :class:`~fields.TimeField` and
    :class:`html5.TimeField <fields.html5.TimeField>` were added.
    (`#254`_)
-   Improved :class:`~validators.Email`. Note that it is still
    unreasonable to validate all emails with a regex and you should
    prefer validating by actually sending an email. (`#294`_)
-   Widgets render the ``required`` attribute when using a validator
    that provides the ``'required'`` flag, such as
    :class:`~validators.DataRequired`. (`#361`_)
-   Fix a compatibility issue with SQLAlchemy 2.1 that caused
    :class:`~ext.sqlalchemy.fields.QuerySelectField` to fail with
    ``ValueError: too many values to unpack``. (`#391`_)

.. _#248: https://github.com/wtforms/wtforms/pull/248
.. _#251: https://github.com/wtforms/wtforms/pull/251
.. _#254: https://github.com/wtforms/wtforms/pull/254
.. _#280: https://github.com/wtforms/wtforms/pull/280
.. _#281: https://github.com/wtforms/wtforms/pull/281
.. _#286: https://github.com/wtforms/wtforms/pull/286
.. _#294: https://github.com/wtforms/wtforms/pull/294
.. _#302: https://github.com/wtforms/wtforms/pull/302
.. _#361: https://github.com/wtforms/wtforms/pull/361
.. _#391: https://github.com/wtforms/wtforms/pull/391

Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Jun 8 17:43:46 2016 UTC (8 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Switch to MASTER_SITES_PYPI.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Fri Jan 8 16:56:23 2016 UTC (9 years, 3 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
Update py-wtforms to 2.1.


Version 2.1
-----------
Released December 15, 2015

- Added `render_kw` to allow default rendering time options.
- Updated / added a number of localizations
- Updated docs
- Allow widgets to set flags

Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri Jan 30 21:12:58 2015 UTC (10 years, 2 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
Update py-wtforms to 2.0.2.

Version 2.0.2
-------------
Released January 18, 2015

- Added more localizations and updated some.
- Validators for email and URL can validate IDNA-encoded domain names and
  new TLDs
- Better DeprecationWarnings
- Support localization files in /usr/share/locale (for distro packaging)

Revision 1.10: download - view: text, markup, annotated - select for diffs
Fri Jan 9 21:03:27 2015 UTC (10 years, 3 months ago) by kleink
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
Update py-wtforms to 2.0.1.

Version 2.0.1
-------------
Released July 1, 2014

- Update wheel install to conditionally install ordereddict for python 2.6.
- Doc improvements

Version 2.0
-----------
Released May 20, 2014

- Add new `class Meta` paradigm for much more powerful customization
  of WTForms.
- Move i18n into core. Deprecate `wtforms.ext.i18n`.
- Move CSRF into core. Deprecate `wtforms.ext.csrf`.
- Fix issue rendering SelectFields with ``value=True``
- Make `DecimalField` able to use babel locale-based number formatting.
- Drop Python 3.2 support (Python3 support for 3.3+ only)
- passing ``attr=False`` to WTForms widgets causes the value to be ignored.
- `Unique` validator in `wtforms.ext.sqlalchemy` has been removed.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Sat Jan 25 10:30:30 2014 UTC (11 years, 2 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +1 -3 lines
Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sun Jan 12 09:45:25 2014 UTC (11 years, 3 months ago) by wiz
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +1 -2 lines
PYTHON_VERSIONS_INCOMPATIBLE cleanup.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun Oct 27 21:51:02 2013 UTC (11 years, 5 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -3 lines
Update py-wtforms to 1.0.5.

Version 1.0.5
-------------
Released September 10, 2013

- Fix a bug in validators which causes translations to happen once then
  clobber any future translations.
- ext.sqlalchemy / ext.appengine: minor cleanups / deprecation.
- Allow blank string and the string 'false' to be considered false values
  for BooleanField (configurable). This is technically a breaking change,
  but it is not likey to affect the majority of users adversely.
- ext.i18n form allows passing LANGUAGES to the constructor.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Sep 23 20:36:27 2013 UTC (11 years, 6 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Add upstream commit 723c40a8153d20dce0c6dd1a91f193ef0375a194 via patch:
    Update ext.appengine.fields for unicode_literals. Fixes #153.

Fixes build failure with on py32.  Bump PKGREVISION.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed May 8 08:30:47 2013 UTC (11 years, 11 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -1 lines
Update py-wtforms to 1.0.4. (Forgot to commit updated PLIST in previous.)

Bump PKGREVISION.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue May 7 20:49:33 2013 UTC (11 years, 11 months ago) by kleink
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Update py-wtforms to 1.0.4.

Version 1.0.4
-------------
Released April 28, 2013

- Add widgets and field implementations for HTML5 specialty input types.
- ext.appengine: Add NDB support.
- Add translations: Korean, Traditional Chinese

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Jan 27 16:50:20 2013 UTC (12 years, 2 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -2 lines
Update py-wtforms to 1.0.3.

Version 1.0.3
-------------
Released January 24, 2013

- Tests complete in python 3.2/3.3.
- Localization for ru, fr.
- Minor fixes in documentation for clarity.
- FieldList now can take validators on the entire FieldList.
- ext.sqlalchemy model_form:
  * Fix issue with QuerySelectField
  * Fix issue in ColumnDefault conversion
  * Support Enum type
- Field class now allows traversal in Django 1.4 templates.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Jan 9 19:02:44 2013 UTC (12 years, 3 months ago) by kleink
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -1 lines
Sprinkle empty USE_LANGUAGES definitions in pure python packages
where missed at import time.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Jan 7 21:49:38 2013 UTC (12 years, 3 months ago) by kleink
Branches: MAIN
Import WTForms-1.0.2 as www/py-wtforms.

WTForms is a flexible forms validation and rendering library for
python web development.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>