[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / py-uvicorn

File: [cvs.NetBSD.org] / pkgsrc / www / py-uvicorn / Makefile (download)

Revision 1.28, Sat Feb 5 12:11:09 2022 UTC (19 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.27: +2 -2 lines

py-uvicorn: updated to 0.17.4

0.17.4

Fixed

Replace create_server by create_unix_server

0.17.3

Fixed

Drop wsproto version checking.

0.17.2

Fixed

Revert 1332. While trying to solve the memory leak, it introduced an issue
Revert stream interface changes. This was introduced on 0.14.0, and caused an issue
Fix wsproto version check expression

# $NetBSD: Makefile,v 1.28 2022/02/05 12:11:09 adam Exp $

DISTNAME=	uvicorn-0.17.4
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	www python
MASTER_SITES=	${MASTER_SITE_PYPI:=u/uvicorn/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://www.uvicorn.org/
COMMENT=	The lightning-fast ASGI server
LICENSE=	modified-bsd

DEPENDS+=	${PYPKGPREFIX}-asgiref>=3.4.0:../../www/py-asgiref
DEPENDS+=	${PYPKGPREFIX}-click>=7.0:../../devel/py-click
DEPENDS+=	${PYPKGPREFIX}-h11>=0.8:../../www/py-h11
DEPENDS+=	${PYPKGPREFIX}-httptools>=0.2.0:../../www/py-httptools
DEPENDS+=	${PYPKGPREFIX}-uvloop>=0.14.0:../../devel/py-uvloop
DEPENDS+=	${PYPKGPREFIX}-websockets>=10.0:../../www/py-websockets

PYTHON_VERSIONS_INCOMPATIBLE=	27

USE_PKG_RESOURCES=	yes

.include "../../lang/python/pyversion.mk"
.if ${_PYTHON_VERSION} < 38
DEPENDS+=	${PYPKGPREFIX}-typing-extensions-[0-9]*:../../devel/py-typing-extensions
.endif

USE_LANGUAGES=	# none

post-install:
	cd ${DESTDIR}${PREFIX}/bin && \
	${MV} uvicorn uvicorn-${PYVERSSUFFIX} || ${TRUE}

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"