The NetBSD Project

CVS log for pkgsrc/www/py-twill/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-twill

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.19 / (download) - annotate - [select for diffs], Mon Nov 14 19:29:38 2022 UTC (12 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, HEAD
Changes since 1.18: +14 -13 lines
Diff to previous 1.18 (colored)

py-twill: updated to 3.1

3.1 (released 2022-10-30)
-------------------------
* The submit command now takes an additional parameter to specify a form
  that can be used in rare cases when there are no form fields.
* Most commands do not return values any more, they are just commands.
  If you are using twill from Python, you should check browser properties
  like 'forms' or 'url' instead of using the return values of commands
  like 'show_forms' or 'back'.
* Two-word commands now consistently have underscores in their names,
  (e.g. 'form_action', 'get_input', 'show_links'). However, for convenience
  and backward compatibility, you can still use the names without underscores
  (e.g. 'formaction', 'getinput', 'showlinks'), and the old two-letter
  abbreviations (e.g. 'fa' for 'form_action').
* Instead of 'showforms' or 'show_forms' you can now also write 'show forms',
  and similarly for 'cookies', 'links', 'history' and 'html'. The command
  'show html' does the same as 'show' without any arguments.
* Renamed shortcuts for user agent strings, and added some more existing ones.
* Added type hints.
* Support Python 3.11.
* Many minor fixes and improvements.

3.0.3 (released 2022-10-12)
---------------------------

* Form numbers are now printed correctly with 'showforms'.

3.0.2 (released 2022-04-10)
---------------------------

* Save HTML file with browser encoding or as UTF-8.
* Do not modify root logger any more.

3.0.1 (released 2021-12-04)
---------------------------

* This version now also supports Python 3.10.
* The twill language now allows 8-bit letters to appear in strings unquoted.

3.0 (released 2021-02-25)
-------------------------

* In this version we require Python 3.6 to 3.9.
  If you still need support for Python 2 or Python 3.5,
  then please use the latest version from the 2.x branch.
* The code has been optimized for Python 3 now.
* Some minor fixes.

2.0.3 (released 2021-02-25)
---------------------------

* Backported the fixes in version 3.0.

2.0.2 (released 2021-02-13)
---------------------------

* This version now also supports Python 3.9.
* 'tidy_should_exist' has been renamed ot 'require_tidy'.
* Support for setting options to be used with HTML Tidy.
* Cleanup scripts are now also read as UTF-8 in Python 3.

2.0.1 (released 2020-07-12)
---------------------------

* Fixes an issue with encoding declarations.

2.0 (released 2020-04-04)
-------------------------

This version is based on twill 1.8, which was a refactoring
of version 0.9 that used requests_ and lxml_ instead of mechanize_,
done by Ben Taylor in April 2014. It also integrates ideas and
code from Flunc_ which was created by Luke Tucker and Robert Marianski
in 2006-2007, and from ReTwill_ which was created in April 2012
as a fork from twill 0.9 by Adam Victor Brandizzi.
The following improvements and changes were made in this version:

* Larger refactoring, clean-up and modernization efforts to support
  Python 2.7, 3.5 and higher.
* The console script has been renamed from 'twill-sh' to just 'twill'.
* We assume the default file extension '.twill' for twill scripts now.
* Uses lxml_ and requests_ instead of mechanize_ (like in version 1.8),
  but doesn't need cssselect_ and `Beautiful Soup`_ any more (unlike 1.8).
* Removed bundled packages which have become unnecessary (mechanize)
  or are available in newer versions on PyPI (pyparsing, wsgi_intercept)
  or in the standard library (subprocess).
* Removed parsing options (use_tidy, use_BeautifulSoup, allow_parse_errors)
  which have become insignificant due to the use of lxml.html.
* We use pytest_ instead of nose_ for testing twill now.
* A tox_ configuration file for running tests with different Python versions
  has been added.
* Optimized the order of the URLs that are tried out by the twill browser.
* Added an option '-d' to dump the last HTML to a file or standard output
  and an option '-w' to show the HTML directly in the web browser (this
  feature was taken over from Flunc).
* Added alias 'rf' for 'runfiles' and made runfiles run directories of
  scripts as well. This helps writing test suites for twill scripts.
* Added command 'add_cleanup' to unconditionally run cleanup scripts after
  the current script finished. This allows resetting the state of the
  tested server, so that tests will always re-run on a clean state.
  Together with a small init.twill script, this creates a test fixture.
  (This idea was taken from Flunc, which supports cleanup scripts for
  test suites, although in a somewhat different way.)
* Non string values are now accepted in variable substitution (this feature
  has been backported from ReTwill).
* XPath expressions are now supported in find/notfind commands (this feature
  has been backported from ReTwill).
* Made output better controllable by using log levels (this feature has
  been backported from ReTwill). See options '-l' and '-o'.
* Updated the map of predefined user agent strings.
* Basic authentication with realm is now supported again
  (the 'with_default_realm' option, which was broken in version 1.8,
  has been switched off).
* Server certificates are not verified by default any more, since they are
  usually not valid on test and staging servers.
* Improved handling of meta refresh. Circular redirects are detected and
  'debug equiv-refresh' is functional again. A limit for the refresh time
  interval can be set with the 'equiv_refresh_interval' option. By default
  this is set to 2, so refresh intervals of 2 or more seconds are ignored.
* Moved the  examples and additional stuff into an 'extras' directory.
* The documentation in the 'docs' directory has been updated and is now
  created with Sphinx_.
* Made sure everything (except twill-forks) also works on Windows.
* Fixed a lot of smaller and larger bugs and problems.

Revision 1.18 / (download) - annotate - [select for diffs], Wed Jan 5 20:07:11 2022 UTC (22 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.17: +4 -2 lines
Diff to previous 1.17 (colored)

*: set USE_PKG_RESOURCES for some more packages

Revision 1.17 / (download) - annotate - [select for diffs], Tue Jan 4 20:55:36 2022 UTC (22 months, 3 weeks ago) by wiz
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.16 / (download) - annotate - [select for diffs], Mon Nov 4 22:10:13 2019 UTC (4 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

www: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

Manually excluded phraseanet since pkglint got the indentation wrong.

Revision 1.15 / (download) - annotate - [select for diffs], Mon Sep 2 13:20:04 2019 UTC (4 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for future Python 3.8

Revision 1.14 / (download) - annotate - [select for diffs], Fri Apr 26 13:14:22 2019 UTC (4 years, 7 months ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Omit mentions of python 34 and 35, after those were removed.

- Includes some whitespace changes, to be handled in a separate commit.

Revision 1.13 / (download) - annotate - [select for diffs], Tue Jul 3 05:03:41 2018 UTC (5 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

extend PYTHON_VERSIONS_ for Python 3.7

Revision 1.12 / (download) - annotate - [select for diffs], Sat Sep 16 19:27:24 2017 UTC (6 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Reset maintainer

Revision 1.11 / (download) - annotate - [select for diffs], Sun Feb 5 10:20:50 2017 UTC (6 years, 9 months ago) by leot
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Fix DEPENDS pattern.

If we depends on a foo package, mark its dependency via:

 DEPENDS+= foo-*:../../misc/foo

...and then a new foo-bar package will appear it can be problematic.
Use foo-[0-9]* pattern to avoid that.

Kindly pointed out by <wiz>

Revision 1.10 / (download) - annotate - [select for diffs], Sun Feb 5 10:08:13 2017 UTC (6 years, 9 months ago) by leot
Branch: MAIN
Changes since 1.9: +4 -1 lines
Diff to previous 1.9 (colored)

twill.utils needs cssselect, add it to DEPENDS

Bump PKGREVISION

Discussed with <rodent>

Revision 1.9 / (download) - annotate - [select for diffs], Tue Jan 3 13:23:05 2017 UTC (6 years, 10 months ago) by jperkin
Branch: MAIN
Changes since 1.8: +3 -3 lines
Diff to previous 1.8 (colored)

Use "${MV} || ${TRUE}" and "${RM} -f" consistently in post-install targets.

Revision 1.8 / (download) - annotate - [select for diffs], Sun Jan 1 14:44:06 2017 UTC (6 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Add python-3.6 to incompatible versions.

Revision 1.7 / (download) - annotate - [select for diffs], Sun Aug 28 15:48:37 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.6: +1 -3 lines
Diff to previous 1.6 (colored)

Remove unnecessary PLIST_SUBST and FILES_SUBST that are now provided
by the infrastructure.

Mark a couple more packages as not ready for python-3.x.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Jul 9 13:04:15 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.5 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:47 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.4 / (download) - annotate - [select for diffs], Sat Dec 5 21:26:06 2015 UTC (7 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.3 / (download) - annotate - [select for diffs], Fri May 9 07:37:26 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

Revision 1.2 / (download) - annotate - [select for diffs], Sun May 4 13:45:27 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Mark as not for python-3.3.

Revision 1.1 / (download) - annotate - [select for diffs], Sat May 3 01:56:29 2014 UTC (9 years, 7 months ago) by rodent
Branch: MAIN

Import py27-twill-1.8.0 as www/py-twill.

A scripting system for automating Web browsing. Useful for testing Web pages or
grabbing data from password-protected sites automatically.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>