[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / py-test-sanic

File: [cvs.NetBSD.org] / pkgsrc / www / py-test-sanic / Makefile (download)

Revision 1.1, Fri Mar 3 08:26:54 2023 UTC (6 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, HEAD

py-test-sanic: added version 1.9.1

A pytest plugin for Sanic. It helps you to test your code asynchronously.

This plugin provides:
- very easy testing with async coroutines
- common and useful fixtures
- asynchronous fixture support
- test_client/sanic_client for Sanic application
- test_server for Sanic application

# $NetBSD: Makefile,v 1.1 2023/03/03 08:26:54 adam Exp $

DISTNAME=	pytest-sanic-1.9.1
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/^py//}
CATEGORIES=	www python
MASTER_SITES=	${MASTER_SITE_PYPI:=p/pytest-sanic/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/yunstanford/pytest-sanic
COMMENT=	Pytest plugin for Sanic
LICENSE=	apache-2.0

DEPENDS+=	${PYPKGPREFIX}-async_generator>=1.10:../../devel/py-async_generator
DEPENDS+=	${PYPKGPREFIX}-httpx>=0.18.1:../../www/py-httpx
DEPENDS+=	${PYPKGPREFIX}-test>=5.2:../../devel/py-test
DEPENDS+=	${PYPKGPREFIX}-websockets>=9.1:../../www/py-websockets

USE_LANGUAGES=	# none

PYTHON_VERSIONS_INCOMPATIBLE=	27

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"