The NetBSD Project

CVS log for pkgsrc/www/py-test-django/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-test-django

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.27: download - view: text, markup, annotated - select for diffs
Wed Sep 4 09:33:57 2024 UTC (3 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, HEAD
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +4 -4 lines
py-test-django: updated to 4.9.0

v4.9.0 (2024-09-02)

Compatibility

* Added official support for Django 5.1.
* Dropped support for Django 3.2 and 4.1.

Improvements

* Respect the ``string_if_invalid`` template setting when
  ``--fail-on-template-vars`` is active and
  :func:`@pytest.mark.ignore_template_errors <pytest.mark.ignore_template_errors>`
  is used.

* Avoid running database migrations for :class:`~django.test.SimpleTestCase`
  unittest tests.

* Added docstrings to public fixtures.

Bugfixes

* Fix type hints for ``pytest_django.asserts.assertFormError()`` and
  ``pytest_django.asserts.assertForSetError()``.

Revision 1.26: download - view: text, markup, annotated - select for diffs
Fri Feb 2 16:09:00 2024 UTC (10 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +4 -4 lines
py-test-django: updated to 4.8.0

v4.8.0 (2024-01-30)

Improvements

* Add `pytest.asserts.assertMessages()` to mimic the behaviour of the
  ``django.contrib.messages.test.MessagesTestMixin.assertMessages`` function
  for Django versions >= 5.0.

Bugfixes

* Fix `--help`/`--version` crash in a partially configured app.

Revision 1.25: download - view: text, markup, annotated - select for diffs
Thu Nov 9 06:54:18 2023 UTC (13 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +4 -4 lines
py-test-django: updated to 4.7.0

v4.7.0 (2023-11-08)
-------------------

Compatibility

* Official Django 5.0 support.

* Official Python 3.12 support.

Improvements

* The Django test tags from the previous release now works on any
  :class:`~django.test.SimpleTestCase` (i.e. any Django test framework test
  class), not just :class:`~django.test.TransactionTestCase` classes.

* Some improvements for those of us who like to type their tests:

  - Add ``pytest_django.DjangoAssertNumQueries`` for typing
    :fixture:`django_assert_num_queries` and
    :fixture:`django_assert_max_num_queries`.

  - Add ``pytest_django.DjangoCaptureOnCommitCallbacks`` for typing
    :fixture:`django_capture_on_commit_callbacks`.

  - Add ``pytest_django.DjangoDbBlocker`` for typing
    :fixture:`django_db_blocker`.

Revision 1.24: download - view: text, markup, annotated - select for diffs
Fri Nov 3 08:21:59 2023 UTC (13 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +4 -4 lines
py-test-django: updated to 4.6.0

v4.6.0 (2023-10-30)
-------------------

Compatibility

* Official Django 4.1 & 4.2 support.

* Official Python 3.11 support.

* Drop support for Python version 3.5, 3.6 & 3.7.

* Drop official support for Django 4.0.

* Drop support for pytest < 7.

Improvements

* Add support for setting :py:attr:`available_apps
  <django.test.TransactionTestCase.available_apps>` in the :func:`django_db
  <pytest.mark.django_db>` marker.

* Convert Django :ref:`test tags <django:topics-tagging-tests>` to :ref:`Pytest
  markers <pytest:mark examples>`.

* Show Django's version in the pytest ``django`` report header.

* Add precise ``pytest_django.asserts.assertQuerySetEqual`` typing.

Bugfixes

* Fix bug where the effect of :func:`@pytest.mark.ignore_template_errors
  <pytest.mark.ignore_template_errors>` was not reset when using
  ``--fail-on-template-vars``.

Revision 1.23: download - view: text, markup, annotated - select for diffs
Wed Sep 6 20:17:50 2023 UTC (15 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +4 -4 lines
py-test-django: updated to 4.5.2

v4.5.2 (2021-12-07)
-------------------

Bugfixes

* Fix regression in v4.5.0 - ``pytest.mark.django_db(reset_sequence=True)`` now
  implies ``transaction=True`` again.


v4.5.1 (2021-12-02)
-------------------

Bugfixes

* Fix regression in v4.5.0 - database tests inside (non-unittest) classes were
  not ordered correctly to run before non-database tests, same for transactional
  tests before non-transactional tests.


v4.5.0 (2021-12-01)
-------------------

Improvements

* Add support for :ref:`rollback emulation/serialized rollback
  <test-case-serialized-rollback>`. The :func:`pytest.mark.django_db` marker
  has a new ``serialized_rollback`` option, and a
  :fixture:`django_db_serialized_rollback` fixture is added.

* Official Python 3.10 support.

* Official Django 4.0 support (tested against 4.0rc1 at the time of release).

* Drop official Django 3.0 support. Django 2.2 is still supported, and 3.0
  will likely keep working until 2.2 is dropped, but it's not tested.

* Added pyproject.toml file.

* Skip Django's `setUpTestData` mechanism in pytest-django tests. It is not
  used for those, and interferes with some planned features. Note that this
  does not affect ``setUpTestData`` in unittest tests (test classes which
  inherit from Django's `TestCase`).

Bugfixes

* Fix :fixture:`live_server` when using an in-memory SQLite database.

* Fix typing of ``assertTemplateUsed`` and ``assertTemplateNotUsed``.


v4.4.0 (2021-06-06)
-------------------

Improvements

* Add a fixture :fixture:`django_capture_on_commit_callbacks` to capture
  :func:`transaction.on_commit() <django.db.transaction.on_commit>` callbacks
  in tests.


v4.3.0 (2021-05-15)
-------------------

Improvements

* Add experimental :ref:`multiple databases <multi-db>` (multi db) support.

* Add type annotations. If you previously excluded ``pytest_django`` from
  your type-checker, you can remove the exclusion.

* Documentation improvements.


v4.2.0 (2021-04-10)
-------------------

Improvements

* Official Django 3.2 support.

* Documentation improvements.

Bugfixes

* Disable atomic durability check on non-transactional tests


v4.1.0 (2020-10-22)
-------------------

Improvements

* Add the :fixture:`async_client` and :fixture:`async_rf` fixtures

* Add :ref:`django_debug_mode <usage>` to configure how ``DEBUG`` is set in tests

* Documentation improvements.

Bugfixes

* Make :fixture:`admin_user` work for custom user models without an ``email`` field.


v4.0.0 (2020-10-16)
-------------------

Compatibility

This release contains no breaking changes, except dropping compatibility
with some older/unsupported versions.

* Drop support for Python versions before 3.5

  Previously 2.7 and 3.4 were supported. Running ``pip install pytest-django``
  on Python 2.7 or 3.4 would continue to install the compatible 3.x series.

* Drop support for Django versions before 2.2

  Previously Django>=1.8 was supported.

* Drop support for pytest versions before 5.4

  Previously pytest>=3.6 was supported.

Improvements

* Officially support Python 3.9.

* Add ``pytest_django.__version__``

* Minor documentation improvements

Bugfixes

* Make the ``admin_user`` and ``admin_client`` fixtures compatible with custom
  user models which don't have a ``username`` field

* Change the ``admin_user`` fixture to use ``get_by_natural_key()`` to get the
  user instead of directly using ``USERNAME_FIELD``, in case it is overridden,
  and to match Django

Misc

* Fix pytest-django's own tests failing due to some deprecation warnings

Revision 1.22: download - view: text, markup, annotated - select for diffs
Tue Oct 26 11:30:49 2021 UTC (3 years, 1 month ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -2 lines
www: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Not committed (merge conflicts):
www/nghttp2/distinfo

Unfetchable distfiles (almost certainly fetched conditionally...):
./www/nginx-devel/distinfo array-var-nginx-module-0.05.tar.gz
./www/nginx-devel/distinfo echo-nginx-module-0.62.tar.gz
./www/nginx-devel/distinfo encrypted-session-nginx-module-0.08.tar.gz
./www/nginx-devel/distinfo form-input-nginx-module-0.12.tar.gz
./www/nginx-devel/distinfo headers-more-nginx-module-0.33.tar.gz
./www/nginx-devel/distinfo lua-nginx-module-0.10.19.tar.gz
./www/nginx-devel/distinfo naxsi-1.3.tar.gz
./www/nginx-devel/distinfo nginx-dav-ext-module-3.0.0.tar.gz
./www/nginx-devel/distinfo nginx-rtmp-module-1.2.2.tar.gz
./www/nginx-devel/distinfo nginx_http_push_module-1.2.10.tar.gz
./www/nginx-devel/distinfo ngx_cache_purge-2.5.1.tar.gz
./www/nginx-devel/distinfo ngx_devel_kit-0.3.1.tar.gz
./www/nginx-devel/distinfo ngx_http_geoip2_module-3.3.tar.gz
./www/nginx-devel/distinfo njs-0.5.0.tar.gz
./www/nginx-devel/distinfo set-misc-nginx-module-0.32.tar.gz
./www/nginx/distinfo array-var-nginx-module-0.05.tar.gz
./www/nginx/distinfo echo-nginx-module-0.62.tar.gz
./www/nginx/distinfo encrypted-session-nginx-module-0.08.tar.gz
./www/nginx/distinfo form-input-nginx-module-0.12.tar.gz
./www/nginx/distinfo headers-more-nginx-module-0.33.tar.gz
./www/nginx/distinfo lua-nginx-module-0.10.19.tar.gz
./www/nginx/distinfo naxsi-1.3.tar.gz
./www/nginx/distinfo nginx-dav-ext-module-3.0.0.tar.gz
./www/nginx/distinfo nginx-rtmp-module-1.2.2.tar.gz
./www/nginx/distinfo nginx_http_push_module-1.2.10.tar.gz
./www/nginx/distinfo ngx_cache_purge-2.5.1.tar.gz
./www/nginx/distinfo ngx_devel_kit-0.3.1.tar.gz
./www/nginx/distinfo ngx_http_geoip2_module-3.3.tar.gz
./www/nginx/distinfo njs-0.5.0.tar.gz
./www/nginx/distinfo set-misc-nginx-module-0.32.tar.gz

Revision 1.21: download - view: text, markup, annotated - select for diffs
Thu Oct 7 15:08:32 2021 UTC (3 years, 2 months ago) by nia
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +1 -2 lines
www: Remove SHA1 hashes for distfiles

Revision 1.20: download - view: text, markup, annotated - select for diffs
Fri Oct 2 19:31:39 2020 UTC (4 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +5 -5 lines
py-test-django: updated to 3.10.0

v3.10.0

Improvements
Officialy support Django 3.1
Preliminary supoprt for upcoming Django 3.2
Support for pytest-xdist 2.0

Misc
Fix running pytest-django’s own tests against pytest 6.0

Revision 1.19: download - view: text, markup, annotated - select for diffs
Mon Apr 6 16:55:46 2020 UTC (4 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +5 -5 lines
py-test-django: updated to 3.9.0

v3.9.0:

Improvements
* Improve test ordering with Django test classes
* Remove import of pkg_resources for parsing pytest version (performance)

Bugfixes
* Work around unittest issue with pytest 5.4.{0,1}
* Don't break --failed-first when re-ordering tests
* pytest_addoption: use `group.addoption`

Misc
* Remove Django version from --nomigrations heading
* docs: changelog: prefix headers with v for permalink anchors
* changelog: add custom/fixed anchor for last version
* setup.py: add Changelog to project_urls

Revision 1.18: download - view: text, markup, annotated - select for diffs
Tue Jan 14 16:05:04 2020 UTC (4 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +5 -5 lines
py-test-django: updated to 3.8.0

3.8.0:
* Make Django's assertion helpers available in pytest_django.asserts.
* Report django-configurations setting

Revision 1.17: download - view: text, markup, annotated - select for diffs
Wed Nov 13 20:56:56 2019 UTC (5 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +5 -5 lines
py-test-django: updated to 3.7.0

3.7.0:
Bugfixes
* Monkeypatch pytest to not use ``TestCase.debug`` with unittests, instead
  of patching it into Django.
* Work around pytest crashing due to ``pytest.fail`` being used from within the
  DB blocker, and pytest trying to display an object representation involving
  DB access.  pytest-django uses a ``RuntimeError`` now instead.

Revision 1.16: download - view: text, markup, annotated - select for diffs
Tue Nov 5 07:49:37 2019 UTC (5 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +5 -5 lines
py-test-django: updated to 3.6.0

3.6.0:
Features
* Rename test databases when running parallel Tox

Bugfixes
* Django unittests: restore "debug" function

Misc
* Improve/harden internal tests / infrastructure.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Mon Jul 1 11:02:31 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +5 -5 lines
py-test-django: updated to 3.5.1

3.5.1:
Bugfixes
Fix compatibility with pytest 5.x

Revision 1.14: download - view: text, markup, annotated - select for diffs
Wed Jun 5 05:14:05 2019 UTC (5 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +5 -5 lines
py-test-django: updated to 3.5.0

3.5.0:

Features
* Run tests in the same order as Django
* Use verbosity=0 with disabled migrations

Bugfixes
* django_db_setup: warn instead of crash with teardown errors

Misc
* tests: fix test_sqlite_database_renamed
* tests/conftest.py: move import of db_helpers
* Cleanup/improve coverage, mainly with tests
* Slightly revisit unittest handling

Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Feb 27 12:07:14 2019 UTC (5 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +5 -5 lines
py-test-django: updated to 3.4.8

3.4.8:
Fix DB renaming fixture for Multi-DB environment with SQLite

Revision 1.12: download - view: text, markup, annotated - select for diffs
Wed Feb 6 08:51:48 2019 UTC (5 years, 10 months ago) by adam
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +5 -5 lines
py-test-django: updated to 3.4.7

3.4.7:
Bugfixes
* Fix disabling/handling of unittest methods with pytest 4.2+


3.4.6:
Bugfixes
* django_find_project: add cwd as fallback always

Misc
* Enable tests for Django 2.2 and add classifier
* Disallow pytest 4.2.0 in install_requires

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue Jan 8 09:13:11 2019 UTC (5 years, 11 months ago) by adam
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +5 -5 lines
py-test-django: updated to 3.4.5

3.4.5:

Bugfixes
* Use request.config instead of pytest.config
* :fixture:admin_user: handle "email" username_field

Misc
* Minor doc fixes
* tests: fix for pytest 4

Revision 1.10: download - view: text, markup, annotated - select for diffs
Wed Nov 14 09:10:45 2018 UTC (6 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +5 -5 lines
py-test-django: updated to 3.4.4

3.4.4:

Bugfixes
* Refine the django.conf module check to see if the settings really are
  configured.
* Avoid crash after OSError during Django path detection.

Features
* Add parameter info to fixture assert_num_queries to display additional message on failure.

Docs
* Improve doc for django_assert_num_queries/django_assert_max_num_queries.
* Add warning about sqlite specific snippet + fix typos.

Misc
* MANIFEST.in: include tests for downstream distros.
* Ensure that the LICENSE file is included in wheels.
* Run black on source.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Tue Oct 2 08:45:10 2018 UTC (6 years, 2 months ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +5 -5 lines
py-test-django: updated to 3.4.3

3.4.3:

Bugfixes
Fix OSError with arguments containing :: on Windows

Revision 1.8: download - view: text, markup, annotated - select for diffs
Tue Aug 28 11:02:37 2018 UTC (6 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +5 -5 lines
py-test-django: updated to 3.4.2

3.4.2:
Bugfixes
- Changed dependency for pathlib to pathlib2.
- Fixed code for inserting the project to sys.path with pathlib to use an absolute path, regression in 3.4.0

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sat Aug 18 21:14:49 2018 UTC (6 years, 3 months ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +5 -5 lines
py-test-django: updated to 3.4.1

3.4.1:
Unknown changes

3.4.0:
Features
Added new fixture django_assert_max_num_queries.
Added support for connection and returning the wrapped context manager with django_assert_num_queries.
Added support for resetting sequences via django_db_reset_sequences.

Bugfixes
Made sure to not call django.setup() multiple times.

Compatibility
Removed py dependency, use pathlib instead

Revision 1.6: download - view: text, markup, annotated - select for diffs
Tue Aug 7 10:11:22 2018 UTC (6 years, 4 months ago) by adam
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +5 -5 lines
py-test-django: updated to 3.3.3

3.3.3:

Bug fixes
Fixed registration of ignore_template_errors() marker, which is required with pytest --strict
Fixed another regression with unittest

Docs
Use sphinx_rtf_theme
Minor fixes.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Jun 24 11:19:33 2018 UTC (6 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +5 -5 lines
py-test-django: updated to 3.3.2

3.3.2:
Unknown changes

3.3.1:
Bug fixes
* Fixed test for classmethod with Django TestCases again
Compatibility
* Support Django 2.1 (no changes necessary)

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat Jun 16 06:23:35 2018 UTC (6 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +5 -5 lines
py-test-django: updated to 3.3.0

3.3.0:
Features
Added new fixtures django_mail_dnsname and django_mail_patch_dns, used by mailoutbox to monkeypatch the DNS_NAME used in django.core.mail to improve performance and reproducibility.

Bug fixes
Fixed test for classmethod with Django TestCases
Fixed RemovedInPytest4Warning: MarkInfo objects are deprecated
Fixed scope of overridden settings with live_server fixture: previously they were visible to following tests

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Apr 18 07:09:02 2018 UTC (6 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -6 lines
py-test-django: updated to 3.2.1

3.2.1
Fix automatic deployment to PyPI.

3.2.0
Features:
Added new fixture django_assert_num_queries for testing the number of database queries
–fail-on-template-vars has been improved and should now return full/absolute path
Support for setting the live server port
unittest: help with setUpClass not being a classmethod

Bug fixes:
Fix –reuse-db and –create-db not working together
Numerous fixes in the documentation. These should not go unnoticed.

Compatibilitya:
Support for Django 2.0 has been added.
Support for Django before 1.8 has been dropped.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Mar 24 17:06:44 2018 UTC (6 years, 8 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Relax overly restrictive dependency.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Jan 11 14:07:11 2018 UTC (6 years, 11 months ago) by adam
Branches: MAIN
py-test-django: added version 3.1.2

pytest-django allows you to test your Django project/applications with the
pytest testing tool.

Running your test suite with pytest-django allows you to tap into the features
that are already present in pytest. Here are some advantages:
* Manage test dependencies with pytest fixtures.
* Less boilerplate tests: no need to import unittest, create a subclass with
  methods. Write tests as regular functions.
* Database re-use: no need to re-create the test database for every test run.
* Run tests in multiple processes for increased speed (with the pytest-xdist
  plugin).
* Make use of other pytest plugins.
* Works with both worlds: Existing unittest-style TestCase's still work
  without any modifications.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>