[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / py-moin

File: [cvs.NetBSD.org] / pkgsrc / www / py-moin / Makefile (download)

Revision 1.26, Fri May 9 07:37:25 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.25: +2 -2 lines

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

# $NetBSD: Makefile,v 1.26 2014/05/09 07:37:25 wiz Exp $

VER=		1.9.7
DISTNAME=	moin-${VER}
PKGNAME=	${PYPKGPREFIX}-moin-${VER}
CATEGORIES=	www python
MASTER_SITES=	http://static.moinmo.in/files/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://moinmo.in/
COMMENT=	MoinMoin, a Python clone of WikiWiki
LICENSE=	gnu-gpl-v2

USE_LANGUAGES=	# none

PYTHON_VERSIONS_INCOMPATIBLE=	33 34 # not yet ported as of 1.9.7

REPLACE_PYTHON=	jabberbot/bot.py \
		MoinMoin/version.py \
		MoinMoin/filter/EXIF.py \
		MoinMoin/i18n/msgfmt.py \
		MoinMoin/i18n/tools/*.py \
		MoinMoin/script/moin.py \
		MoinMoin/script/old/*.py \
		MoinMoin/script/old/xmlrpc-tools/*.py \
		MoinMoin/script/migration/1050800.py \
		MoinMoin/script/migration/1059997.py \
		MoinMoin/script/migration/1059998.py \
		MoinMoin/script/migration/1059999.py \
		MoinMoin/script/migration/1089999.py \
		MoinMoin/script/old/migration/*.py \
		MoinMoin/support/difflib.py \
		MoinMoin/support/tarfile.py \
		MoinMoin/support/parsedatetime/*.py \
		MoinMoin/support/xappy/*.py \
		MoinMoin/web/static/htdocs/applets/FCKeditor/editor/filemanager/connectors/py/*.py \
		wiki/server/moin* \
		wiki/server/test.wsgi

REPLACE_PERL=	MoinMoin/web/static/htdocs/applets/FCKeditor/editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.pl
REPLACE_PERL+=	MoinMoin/web/static/htdocs/applets/FCKeditor/editor/filemanager/connectors/perl/connector.cgi
REPLACE_PERL+=	MoinMoin/web/static/htdocs/applets/FCKeditor/editor/filemanager/connectors/perl/upload.cgi

PYTHON_SELF_CONFLICT=	yes

.include "../../lang/python/distutils.mk"
.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"