The NetBSD Project

CVS log for pkgsrc/www/py-httpcore/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-httpcore

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.22 / (download) - annotate - [select for diffs], Thu Dec 29 12:40:51 2022 UTC (2 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

py-httpcore: updated to 0.16.3

0.16.3
- Allow `ws` and `wss` schemes. Allows us to properly support websocket upgrade connections.
- Forwarding HTTP proxies use a connection-per-remote-host. Required by some proxy implementations.
- Don't raise `RuntimeError` when closing a connection pool with active connections. Removes some error cases when cancellations are used.
- Lazy import `anyio`, so that it's no longer a hard dependancy, and isn't imported if unused.

Revision 1.21 / (download) - annotate - [select for diffs], Sat Nov 26 17:58:27 2022 UTC (3 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

py-httpcore: updated to 0.16.2

0.16.2
- Revert 'Fix async cancellation behaviour', which introduced race conditions.
- Raise `RuntimeError` if attempting to us UNIX domain sockets on Windows.

Revision 1.20 / (download) - annotate - [select for diffs], Thu Nov 17 17:07:19 2022 UTC (4 months ago) by adam
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

py-httpcore: updated to 0.16.1

0.16.1 (November 17th, 2022)
- Fix HTTP/1.1 interim informational responses, such as "100 Continue".

Revision 1.19 / (download) - annotate - [select for diffs], Wed Nov 9 09:32:18 2022 UTC (4 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.18: +4 -4 lines
Diff to previous 1.18 (colored)

py-httpcore: updated to 0.16.0

0.16.0
- Support HTTP/1.1 informational responses.
- Fix async cancellation behaviour.
- Support `h11` 0.14.

Revision 1.18 / (download) - annotate - [select for diffs], Tue May 24 12:30:25 2022 UTC (10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

py-httpcore: updated to 0.15.0

0.15.0
- Drop Python 3.6 support
- Ensure HTTP proxy CONNECT requests include `timeout` configuration.
- Switch to explicit `typing.Optional` for type hints
- For `trio` map OSError exceptions to `ConnectError`

Revision 1.17 / (download) - annotate - [select for diffs], Sat Feb 5 12:05:43 2022 UTC (13 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

py-httpcore: updated to 0.14.7

0.14.7
- Requests which raise a PoolTimeout need to be removed from the pool queue.
- Fix AttributeError that happened when Socks5Connection were terminated.

Revision 1.16 / (download) - annotate - [select for diffs], Thu Feb 3 08:05:45 2022 UTC (13 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

py-httpcore: updated to 0.14.6

0.14.6
- Fix SOCKS support for `http://` URLs.
- Resolve race condition around exceptions during streaming a response.

Revision 1.15 / (download) - annotate - [select for diffs], Wed Jan 19 06:08:09 2022 UTC (14 months ago) by adam
Branch: MAIN
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

py-httpcore: updated to 0.14.5

0.14.5
- SOCKS proxy support.
- Add proxy_auth argument to HTTPProxy
- Improve error message on 'RemoteProtocolError' exception when server disconnects without sending a response

Revision 1.14 / (download) - annotate - [select for diffs], Thu Jan 6 08:53:30 2022 UTC (14 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.13: +2 -3 lines
Diff to previous 1.13 (colored)

py-httpcore: updated to 0.14.4

0.14.4
- Support HTTP/2 on HTTPS tunnelling proxies.
- Fix proxy headers missing on HTTP forwarding.
- Only instantiate SSL context if required.
- More robust HTTP/2 handling.

Revision 1.13 / (download) - annotate - [select for diffs], Tue Jan 4 20:55:30 2022 UTC (14 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.12: +2 -1 lines
Diff to previous 1.12 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.12 / (download) - annotate - [select for diffs], Thu Dec 30 13:05:41 2021 UTC (14 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Forget about Python 3.6

Revision 1.11 / (download) - annotate - [select for diffs], Wed Nov 17 17:06:06 2021 UTC (16 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

py-httpcore: updated to 0.14.3

0.14.3
- Fix race condition when removing closed connections from the pool

Revision 1.10 / (download) - annotate - [select for diffs], Wed Nov 17 08:35:12 2021 UTC (16 months ago) by adam
Branch: MAIN
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

py-httpcore: updated to 0.14.2

0.14.2
- Failed connections no longer remain in the pool.

Revision 1.9 / (download) - annotate - [select for diffs], Mon Nov 15 17:41:18 2021 UTC (16 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.8: +4 -3 lines
Diff to previous 1.8 (colored)

py-httpcore: updated to 0.14.1

0.14.1 (November 12th, 2021)

max_connections becomes optional.
certifi is now included in the install dependancies.
h2 is now strictly optional.


0.14.0 (November 11th, 2021)

The 0.14 release is a complete reworking of httpcore, comprehensively addressing some underlying issues in the connection pooling, as well as substantially redesigning the API to be more user friendly.

Some of the lower-level API design also makes the components more easily testable in isolation, and the package now has 100% test coverage.

There's some other neat bits in there too, such as the "trace" extension, which gives a hook into inspecting the internal events that occur during the request/response cycle. This extension is needed for the HTTPX cli, in order to...

Log the point at which the connection is established, and the IP/port on which it is made.
Determine if the outgoing request should log as HTTP/1.1 or HTTP/2, rather than having to assume it's HTTP/2 if the --http2 flag was passed. (Which may not actually be true.)
Log SSL version info / certificate info.
Note that curio support is not currently available in 0.14.0. If you're using httpcore with curio please get in touch, so we can assess if we ought to prioritize it as a feature or not.

Revision 1.8 / (download) - annotate - [select for diffs], Tue Sep 14 06:42:49 2021 UTC (18 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

py-httpcore: updated to 0.13.7

0.13.7
- Fix broken error messaging when URL scheme is missing, or a non HTTP(S) scheme is used.

Revision 1.7 / (download) - annotate - [select for diffs], Thu Jul 8 08:36:26 2021 UTC (20 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.6: +4 -3 lines
Diff to previous 1.6 (colored)

py-httpcore: updated to 0.13.6

0.13.6

Fixed
- Close sockets when read or write timeouts occur.

0.13.5

Fixed
- Resolved niggles with AnyIO EOF behaviours.

0.13.4

Added
- Improved error messaging when URL scheme is missing, or a non HTTP(S) scheme is used.

Fixed
- Switched to `anyio` as the default backend implementation when running with `asyncio`. Resolves some awkward [TLS timeout issues](https://github.com/encode/httpx/discussions/1511).

Revision 1.6 / (download) - annotate - [select for diffs], Sat May 8 08:56:56 2021 UTC (22 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

py-httpcore: updated to 0.13.3

0.13.3 (May 6th, 2021)

Added

- Support HTTP/2 prior knowledge, using `httpcore.SyncConnectionPool(http1=False)`.

Fixed

- Handle cases where environment does not provide `select.poll` support.

0.13.2 (April 29th, 2021)

Added

- Improve error message for specific case of `RemoteProtocolError` where server disconnects without sending a response.

0.13.1 (April 28th, 2021)

Fixed

- More resiliant testing for closed connections.
- Don't raise exceptions on ungraceful connection closes.

0.13.0 (April 21st, 2021)

The 0.13 release updates the core API in order to match the HTTPX Transport API,
introduced in HTTPX 0.18 onwards.

An example of making requests with the new interface is:

```python
with httpcore.SyncConnectionPool() as http:
    status_code, headers, stream, extensions = http.handle_request(
        method=b'GET',
        url=(b'https', b'example.org', 443, b'/'),
        headers=[(b'host', b'example.org'), (b'user-agent', b'httpcore')]
        stream=httpcore.ByteStream(b''),
        extensions={}
    )
    body = stream.read()
    print(status_code, body)
```

Changed

- The `.request()` method is now `handle_request()`.
- The `.arequest()` method is now `.handle_async_request()`.
- The `headers` argument is no longer optional.
- The `stream` argument is no longer optional.
- The `ext` argument is now named `extensions`, and is no longer optional.
- The `"reason"` extension keyword is now named `"reason_phrase"`.
- The `"reason_phrase"` and `"http_version"` extensions now use byte strings for their values.
- The `httpcore.PlainByteStream()` class becomes `httpcore.ByteStream()`.

Added

- Streams now support a `.read()` interface.

Fixed

- Task cancelation no longer leaks connections from the connection pool.

Revision 1.5 / (download) - annotate - [select for diffs], Fri Feb 5 20:34:10 2021 UTC (2 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

py-httpcore: updated to 0.12.3

0.12.3

Fixed

- Abort SSL connections on close rather than waiting for remote EOF when using `asyncio`.
- Fix exception raised in case of connect timeouts when using the `anyio` backend.
- Fix `Host` header precedence for `:authority` in HTTP/2.
- Handle extra edge case when detecting for socket readability when using `asyncio`.
- Fix `asyncio` SSL warning when using proxy tunneling.

Revision 1.4 / (download) - annotate - [select for diffs], Thu Nov 26 10:53:59 2020 UTC (2 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

py-httpcore: updated to 0.12.2

0.12.2

Fixed
- Properly wrap connect errors on the asyncio backend.
- Fix `ImportError` occurring on Python 3.9 when using the HTTP/1.1 sync client in a multithreaded context.

0.12.1

Added
- Add connect retries.

Fixed
- Tweak detection of dropped connections, resolving an issue with open files limits on Linux.
- Avoid leaking connections when establishing an HTTP tunnel to a proxy has failed.
- Properly wrap OS errors when using `trio`.

Revision 1.3 / (download) - annotate - [select for diffs], Tue Oct 13 11:12:41 2020 UTC (2 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

py-httpcore: updated to 0.12.0

0.12.0

Changed
- HTTP header casing is now preserved, rather than always sent in lowercase.

Added
- Add Python 3.9 to officially supported versions.

Fixed
- Gracefully handle a stdlib asyncio bug when a connection is closed while it is in a paused-for-reading state.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Oct 1 06:48:37 2020 UTC (2 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

py-httpcore: updated to 0.11.1

0.11.1

Fixed
- Add await to async semaphore release() coroutine
- Drop incorrect curio classifier


0.11.0

The Transport API with 0.11.0 has a couple of significant changes.

Firstly we've moved changed the request interface in order to allow extensions, which will later enable us to support features
such as trailing headers, HTTP/2 server push, and CONNECT/Upgrade connections.

The interface changes from:

```python
def request(method, url, headers, stream, timeout):
    return (http_version, status_code, reason, headers, stream)
```

To instead including an optional dictionary of extensions on the request and response:

```python
def request(method, url, headers, stream, ext):
    return (status_code, headers, stream, ext)
```

Having an open-ended extensions point will allow us to add later support for various optional features, that wouldn't otherwise be supported without these API changes.

In particular:

* Trailing headers support.
* HTTP/2 Server Push
* sendfile.
* Exposing raw connection on CONNECT, Upgrade, HTTP/2 bi-di streaming.
* Exposing debug information out of the API, including template name, template context.

Currently extensions are limited to:

* request: `timeout` - Optional. Timeout dictionary.
* response: `http_version` - Optional. Include the HTTP version used on the response.
* response: `reason` - Optional. Include the reason phrase used on the response. Only valid with HTTP/1.*.

See https://github.com/encode/httpx/issues/1274#issuecomment-694884553 for the history behind this.

Secondly, the async version of `request` is now namespaced as `arequest`.

This allows concrete transports to support both sync and async implementations on the same class.

Added
- Add curio support.
- Add anyio support, with `backend="anyio"`.

Changed
- Update the Transport API to use 'ext' for optional extensions.
- Update the Transport API to use `.request` and `.arequest` so implementations can support both sync and async.


0.10.2

Added
- Added Unix Domain Socket support.

Fixed
- Always include the port on proxy CONNECT requests.
- Fix `max_keepalive_connections` configuration.
- Fixes behaviour in HTTP/1.1 where server disconnects can be used to signal the end of the response body.

0.10.1
- Include `max_keepalive_connections` on `AsyncHTTPProxy`/`SyncHTTPProxy` classes.


0.10.0

The most notable change in the 0.10.0 release is that HTTP/2 support is now fully optional.

Use either `pip install httpcore` for HTTP/1.1 support only, or `pip install httpcore[http2]` for HTTP/1.1 and HTTP/2 support.

Added
- HTTP/2 support becomes optional.
- Add `local_address=...` support.
- Add `PlainByteStream`, `IteratorByteStream`, `AsyncIteratorByteStream`. The `AsyncByteSteam` and `SyncByteStream` classes are now pure interface classes.
- Add `LocalProtocolError`, `RemoteProtocolError` exceptions.
- Add `UnsupportedProtocol` exception.
- Add `.get_connection_info()` method.
- Add better TRACE logs.

Changed
- `max_keepalive` is deprecated in favour of `max_keepalive_connections`.

Fixed
- Improve handling of server disconnects.

Revision 1.1 / (download) - annotate - [select for diffs], Wed Jun 3 14:18:43 2020 UTC (2 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2

py-httpcore: added version 0.9.1

The HTTP Core package provides a minimal low-level HTTP client, which does one
thing only. Sending HTTP requests.

It does not provide any high level model abstractions over the API, does not
handle redirects, multipart uploads, building authentication headers,
transparent HTTP caching, URL parsing, session cookie handling, content or
charset decoding, handling JSON, environment based configuration defaults, or
any of that Jazz.

Some things HTTP Core does do:
* Sending HTTP requests.
* Provides both sync and async interfaces.
* Supports HTTP/1.1 and HTTP/2.
* Async backend support for asyncio and trio.
* Automatic connection pooling.
* HTTP(S) proxy support.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>