The NetBSD Project

CVS log for pkgsrc/www/py-gunicorn/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-gunicorn

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.23 / (download) - annotate - [select for diffs], Fri Jul 21 06:20:39 2023 UTC (4 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Changes since 1.22: +6 -6 lines
Diff to previous 1.22 (colored)

py-gunicorn: updated to 21.2.0

21.2.0 - 2023-07-19
===================

- fix thread worker: revert change considering connection as idle .

*** NOTE ***

This is fixing the bad file description error.

21.0.1 - 2023-07-17
===================

- fix documentation build

21.0.0 - 2023-07-17
===================

- support python 3.11
- fix gevent and eventlet workers
- fix threads support (gththread): improve performance and unblock requests
- SSL: noaw use SSLContext object
- HTTP parser: miscellaneous fixes
- remove unecessary setuid calls
- fix testing
- improve logging
- miscellaneous fixes to core engine

*** RELEASE NOTE ***

We made this release major to start our new release cycle. More info will be provided on our discussion forum.

Revision 1.22 / (download) - annotate - [select for diffs], Wed Jan 5 15:41:29 2022 UTC (23 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.21: +4 -2 lines
Diff to previous 1.21 (colored)

python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.21 / (download) - annotate - [select for diffs], Tue Jan 4 20:55:29 2022 UTC (23 months ago) by wiz
Branch: MAIN
Changes since 1.20: +2 -1 lines
Diff to previous 1.20 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.20 / (download) - annotate - [select for diffs], Tue Apr 6 15:50:44 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.19: +6 -2 lines
Diff to previous 1.19 (colored)

py-gunicorn: updated to 20.1.0

20.1.0 - 2021-02-12

document WEB_CONCURRENCY is set by, at least, Heroku
capture peername from accept: Avoid calls to getpeername by capturing the peer name returned by accept
log a warning when a worker was terminated due to a signal
fix tornado usage with latest versions of Django
add support for python -m gunicorn
fix systemd socket activation example
allows to set wsgi application in configg file using wsgi_app
document --timeout = 0
always close a connection when the number of requests exceeds the max requests
Disable keepalive during graceful shutdown
kill tasks in the gthread workers during upgrade
fix latency in gevent worker when accepting new requests
fix file watcher: handle errors when new worker reboot and ensure the list of files is kept
document the default name and path of the configuration file
document how variable impact configuration
document the $PORT environment variable
added milliseconds option to request_time in access_log
added PIP requirements to be used for example
remove version from the Server header
fix sendfile: use socket.sendfile instead of os.sendfile
reloader: use absolute path to prevent empty to prevent0 InotifyError when a file is added to the working directory
Add ãàÅÑrint-config option to print the resolved settings at startup.
remove the --log-dict-config CLI flag because it never had a working format (the logconfig_dict setting in configuration files continues to work)

** Breaking changes **

minimum version is Python 3.5
remove version from the Server header

** Others **

miscellaneous changes in the code base to be a better citizen with Python 3
remove dead code
fix documentation generation

Revision 1.19 / (download) - annotate - [select for diffs], Wed Dec 4 12:57:06 2019 UTC (4 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

py-gunicorn: updated to 20.0.4

20.0.4:
fix binding a socket using the file descriptor
remove support for the bdist_rpm build

Revision 1.18 / (download) - annotate - [select for diffs], Tue Nov 26 12:37:18 2019 UTC (4 years ago) by adam
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

py-gunicorn: updated to 20.0.3

20.0.3:
- fixed load of a config file without a Python extension
- fixed `socketfromfd.fromfd` when defaults are not set
we now warn when we load a config file without Python Extension

Revision 1.17 / (download) - annotate - [select for diffs], Sun Nov 24 11:29:54 2019 UTC (4 years ago) by adam
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

py-gunicorn: updated to 20.0.2

20.0.2:
fix changelog

20.0.1:
fixed the way the config module is loaded. __file__ is now available
fixed wsgi.input_terminated. It is always true.
use the highest protocol version of openssl by default
only support Python >= 3.5
added __repr__ method to Config instance
fixed support of AIX platform and musl libc in socketfromfd.fromfd function
fixed support of applications loaded from a factory function
fixed chunked encoding support to prevent any request smuggling
Capture os.sendfile before patching in gevent and eventlet workers. fix RecursionError.
removed locking in reloader when adding new files
load the WSGI application before the loader to pick up all files

Revision 1.16 / (download) - annotate - [select for diffs], Wed Nov 20 11:32:32 2019 UTC (4 years ago) by adam
Branch: MAIN
Changes since 1.15: +5 -4 lines
Diff to previous 1.15 (colored)

py-gunicorn: updated to 20.0.0

20.0:
- Fixed `fdopen` `RuntimeWarning` in Python 3.8
- Added  check and exception for str type on value in Response process_headers method.
- Ensure WSGI header value is string before conducting regex search on it.
- Added pypy3 to list of tested environments
- Grouped `StopIteration` and `KeyboardInterrupt` exceptions with same body together in Arbiter.run()
- Added `setproctitle` module to `extras_require` in setup.py
- Avoid unnecessary chown of temporary files
- Logging: Handle auth type case insensitively
- Removed `util.import_module`
- Removed fallback for `types.SimpleNamespace` in tests utils
- Use `SourceFileLoader` instead instead of `execfile_`
- Use `importlib` instead of `__import__` and eval`
- Fixed eventlet patching
- Added optional `datadog <https://www.datadoghq.com>`_ tags for statsd metrics
- Header values now are encoded using latin-1, not ascii.
- Rewritten `parse_address` util added test
- Removed redundant super() arguments
- Simplify `futures` import in gthread module
- Fixed worker_connections` setting to also affects the Gthread worker type
- Fixed setting max_requests
-  Bump minimum Eventlet and Gevent versions to 0.24 and 1.4
- Use Python default SSL cipher list by default
- handle `wsgi.input_terminated` extension
- Simplify Paste Deployment documentation
- Fix root logging: root and logger are same level.
- Fixed typo in ssl_version documentation
- Documented  systemd deployement unit examples
- Added systemd sd_notify support
- Fixed typo in gthread.py
- Added `tornado <https://www.tornadoweb.org/>`_ 5 and  6 support
- Declare our setuptools dependency
- Added support to `--bind` to open file descriptors
- Document how to serve WSGI app modules from Gunicorn
- Provide guidance on X-Forwarded-For access log in documentation
- Add support for named constants in the `--ssl-version` flag
- Clarify log format usage of header & environment in documentation
- Fixed systemd documentation to properly setup gunicorn unix socket
- Prevent removal unix socket for reuse_port
- Fix `ResourceWarning` when reading a Python config module
- Remove unnecessary call to dict keys method
- Support str and bytes for UNIX socket addresses
- fixed `InotifyReloadeder`:  handle `module.__file__` is None
- `/dev/shm` as a convenient alternative to making your own tmpfs mount in fchmod FAQ
- fix examples to work on python3
- Fix typo in `--max-requests` documentation
- Clear tornado ioloop before os.fork
- Miscellaneous fixes and improvement for linting using Pylint

Breaking Change
- Removed gaiohttp worker
- Drop support for Python 2.x
- Drop support for EOL Python 3.2 and 3.3

Revision 1.15 / (download) - annotate - [select for diffs], Mon Jul 8 10:36:27 2019 UTC (4 years, 5 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Follow some http->https redirects.

Revision 1.14 / (download) - annotate - [select for diffs], Wed Jul 4 03:43:12 2018 UTC (5 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

py-gunicorn: updated to 19.9.0

19.9.0:
* fix: address a regression that prevented syslog support from working
* fix: correctly set REMOTE_ADDR on versions of Python 3 affected by
  Python Issue 30205 <https://bugs.python.org/issue30205>_
* fix: show zero response length correctly in access log
* fix: prevent raising :exc:AttributeError when --reload is not passed
  in case of a :exc:SyntaxError raised from the WSGI application.
* The internal module gunicorn.workers.async was renamed to gunicorn.workers.base_async
  since async is now a reserved word in Python 3.7.

Revision 1.13 / (download) - annotate - [select for diffs], Sun May 6 09:10:48 2018 UTC (5 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

py-gunicorn: updated to 19.8.1

19.8.1:
fix: secure scheme headers when bound to a unix socket

Revision 1.12 / (download) - annotate - [select for diffs], Mon Apr 30 08:48:07 2018 UTC (5 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.11: +9 -19 lines
Diff to previous 1.11 (colored)

py-gunicorn: updated to 19.8.0

19.8.0:
Eventlet 0.21.0 support
Tornado 5 support
support watching additional files with --reload-extra-file
support configuring logging with a dictionary with --logging-config-dict
add support for the --config flag in the GUNICORN_CMD_ARGS environment variable
disable SO_REUSEPORT by default and add the --reuse-port setting
fix: installing inotify on MacOS no longer breaks the reloader
fix: do not throw TypeError when SO_REUSEPORT is not available
fix: properly decode HTTP paths containing certain non-ASCII characters
fix: remove whitespace when logging header values under gevent
fix: close unlinked temporary files
fix: parse --umask=0 correctly
fix: allow loading applications using relative file paths
fix: force blocking mode on the gevent sockets
fix: preserve leading / in request path
fix: forbid contradictory secure scheme headers
fix: handle malformed basic authentication headers in access log
fix: defer handling of USR1 signal to a new greenlet under gevent
fix: the threaded worker would sometimes close the wrong keep-alive connection under Python 2
fix: re-open log files on USR1 signal using handler._open to support subclasses of FileHandler
deprecation: the gaiohttp worker is deprecated, see the worker_class documentation for more information

Revision 1.11 / (download) - annotate - [select for diffs], Tue Nov 14 00:28:00 2017 UTC (6 years ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.10: +3 -1 lines
Diff to previous 1.10 (colored)

www/py-gunicorn: Set INSTALLATION_DIRS for non-static paths

List directories containing ${PKGBASE} in INSTALLATION_DIRS explicitly.

Revision 1.10 / (download) - annotate - [select for diffs], Fri Nov 3 14:39:27 2017 UTC (6 years, 1 month ago) by leot
Branch: MAIN
Changes since 1.9: +6 -3 lines
Diff to previous 1.9 (colored)

py-gunicorn: Add ALTERNATIVES and adjust PLIST for multi-packages support

- Install bin/gunicorn and bin/gunicorn_paster with the PYVERSSUFFIX appended at
  the end in order to be used by both Python 2 and a Python 3 package
- Adjust PLIST for bin/gunicorn{,_paster} and for all the files installed as
  part of DOCDIR and EXAMPLESDIR

PKGREVISION++

Revision 1.9 / (download) - annotate - [select for diffs], Fri Apr 14 13:24:30 2017 UTC (6 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.8: +2 -7 lines
Diff to previous 1.8 (colored)

19.7.1 / 2017/03/21
===================
- fix: continue if SO_REUSEPORT seems to be available but fails (:issue:`1480`)
- fix: support non-decimal values for the umask command line option (:issue:`1325`)

19.7.0 / 2017/03/01
===================
- The previously deprecated ``gunicorn_django`` command has been removed.
  Use the :ref:`gunicorn-cmd` command-line interface instead.
- The previously deprecated ``django_settings`` setting has been removed.
  Use the :ref:`raw-env` setting instead.
- The default value of :ref:`ssl-version` has been changed from
  ``ssl.PROTOCOL_TLSv1`` to ``ssl.PROTOCOL_SSLv23``.
- fix: initialize the group access list when initgroups is set (:issue:`1297`)
- add environment variables to gunicorn access log format (:issue:`1291`)
- add --paste-global-conf option (:issue:`1304`)
- fix: print access logs to STDOUT (:issue:`1184`)
- remove upper limit on max header size config (:issue:`1313`)
- fix: print original exception on AppImportError (:issue:`1334`)
- use SO_REUSEPORT if available (:issue:`1344`)
- `fix leak <https://github.com/benoitc/gunicorn/commit/b4c41481e2d5ef127199a4601417a6819053c3fd>`_ of duplicate file descriptor for bound sockets.
- add --reload-engine option, support inotify and other backends (:issue:`1368`, :issue:`1459`)
- fix: reject request with invalid HTTP versions
- add ``child_exit`` callback (:issue:`1394`)
- add support for eventlets _AlreadyHandled object (:issue:`1406`)
- format boot tracebacks properly with reloader (:issue:`1408`)
- refactor socket activation and fd inheritance for better support of SystemD (:issue:`1310`)
- fix: o fds are given by default in gunicorn (:issue:`1423`)
- add ability to pass settings to GUNICORN_CMD_ARGS environment variable which helps in container world (:issue:`1385`)
- fix: catch access denied to pid file (:issue:`1091`)
-  many additions and improvements to the documentation

Revision 1.8 / (download) - annotate - [select for diffs], Sat Oct 1 14:15:04 2016 UTC (7 years, 2 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.7: +6 -3 lines
Diff to previous 1.7 (colored)

Update to 19.6.0
Add missing DEPENDS for test

Upstream changes:
19.6.0 / 2016/05/21
Core & Logging

    improvement of the binary upgrade behaviour using USR2: remove file lockin (issue 1270)
    add the --capture-output setting to capture stdout/stderr tot the log

file (issue 1271) - Allow disabling sendfile() via the SENDFILE` environment variable (issue 1252 - fix reload under pycharm (issue 1129)
Workers

    fix: make sure to remove the signal from the worker pipe (issue 1269)
    fix: gthread worker, handle removed socket in the select loop

(issue 1258)
19.5.0 / 2016/05/10
Core

    fix: Ensure response to HEAD request wonãàÑÕ have message body
    fix: lock domain socket and remove on last arbiter exit (issue 1220)
    improvement: use EnvironmentError instead of socket.error (issue 939)
    add: new $FORWARDDED_ALLOW_IPS environment variable (issue 1205)
    fix: infinite recursion when destroying sockets (issue 1219)
    fix: close sockets on shutdown (issue 922)
    fix: clean up sys.exc_info calls to drop circular refs (issue 1228)
    fix: do post_worker_init after load_wsgi (issue 1248)

Workers

    fix access logging in gaiohttp worker (issue 1193)
    eventlet: handle QUIT in a new coroutine (issue 1217)
    gevent: remove obsolete exception clauses in run (issue 1218)
    tornado: fix extra ãà×´erverãàresponse header (issue 1246)
    fix: unblock the wait loop under python 3.5 in sync worker (issue 1256)

Logging

    fix: log message for listener reloading (issue 1181)
    Let logging module handle traceback printing (issue 1201)
    improvement: Allow configuring logger_class with statsd_host (issue 1188)
    fix: traceback formatting (issue 1235)
    fix: print error logs on stderr and access logs on stdout (issue 1184)

Documentation

    Simplify installation instructions in gunicorn.org (issue 1072)
    Fix URL and default worker type in example_config (issue 1209)
    update django doc url to 1.8 lts (issue 1213)
    fix: miscellaneous wording corrections (issue 1216)
    Add PSF License Agreement of selectors.py to NOTICE (:issue: 1226)
    document LOGGING overriding (issue 1051)
    put a note that error logs are only errors from Gunicorn (issue 1124)
    add a note about the requirements of the threads workers under python 2.x (issue 1200)
    add access_log_format to config example (issue 1251)

Tests

    Use more pytest.raises() in test_http.py

19.4.5 / 2016/01/05

    fix: NameError fileno in gunicorn.http.wsgi (issue 1178)

19.4.4 / 2016/01/04

    fix: check if a fileobject can be used with sendfile(2) (issue 1174)
    doc: be more descriptive in errorlog option (issue 1173)


19.4.3 / 2015/12/30

    fix: donãàÑÕ check if a file is writable using os.stat with SELINUX (issue 1171)

19.4.2 / 2015/12/29
Core

    improvement: handle HaltServer in manage_workers (issue 1095)
    fix: Do not rely on sendfile sending requested count (issue 1155)
    fix: claridy ãàÅÏo-sendfile default (issue 1156)
    fix: LoggingCatch sendfile failure from no file descriptor (issue 1160)

Logging

    fix: Always send access log to syslog if syslog is on
    fix: check auth before trying to own a file (issue 1157)

Documentation

    fix: Fix Slowloris broken link. (issue 1142)
    Tweak markup in faq.rst

Testing

    fix: gaiohttp test (issue 1164)

19.4.1 / 2015/11/25

    fix tornado worker (issue 1154)

    19.4.0 / 2015/11/20

Core

    fix: make sure that a user is able to access to the logs after dropping a privilege (issue 1116)
    improvement: inherit the Exception class where it needs to be (issue 997)
    fix: make sure headers are always encodedas latin1 RFC 2616 (issue 1102)
    improvement: reduce arbiter noise (issue 1078)
    fix: donãàÑÕ close the unix socket when the worker exit (issue 1088)
    improvement: Make last logged worker count an explicit instance var (issue 1078)
    improvement: prefix config file with its type (issue 836)
    improvement: pidfile handing (issue 1042)
    fix: catch OSError as well as ValueError on race condition (issue 1052)
    improve support of ipv6 by backporting urlparse.urlsplit from Python 2.7 to Python 2.6.
    fix: raise InvalidRequestLine when the line contains maliscious data (issue 1023)
    fix: fix argument to disable sendfile
    fix: add gthread to the list of supported workers (issue 1011)
    improvement: retry socket binding up to five times upon EADDRNOTAVAIL (issue 1004)
    breaking change: only honor headers that can be encoded in ascii to comply to the RFC 7230 (See issue 1151).

Logging

    add new parameters to access log (issue 1132)
    fix: make sure that files handles are correctly reopenebd on HUP (issue 627)
    include request URL in error message (issue 1071)
    get username in access logs (issue 1069)
    fix statsd logging support on Python 3 (issue 1010)

Testing

    use last version of mock.
    many fixes in Travis CI support
    miscellaneous improvements in tests

Thread worker

    fix: Fix self.nr usage in ThreadedWorker so that auto restart works as expected (issue 1031)

Gevent worker

    fix quit signal handling (issue 1128)
    add support for Python 3 (issue 1066)
    fix: make graceful shutdown thread-safe (issue 1032)

Tornado worker

    fix ssl options (issue 1146, issue 1135)
    donãàÑÕ check timeout when stopping gracefully (issue 1106)

AIOHttp worker

    add SSL support (issue 1105)

Documentation

    fix link to proc name setting (issue 1144)
    fix worker class documentation (issue 1141, issue 1104)
    clarify graceful timeout documentation (issue 1137)
    donãàÑÕ duplicate NGINX config files examples (issue 1050, issue 1048)
    add web.py framework example (issue 1117)
    update Debian/Ubuntu installations instructions (issue 1112)
    clarify pythonpath setting description (issue 1080)
    tweak some example for python3
    clarify sendfile documentation
    miscellaneous typos in source code comments (thanks!)
    clarify why REMOTE_ADD may not be the userãàÑÔ IP address (issue 1037)

Misc

    fix: reloader should survive SyntaxError (issue 994)
    fix: expose the reloader class to the worker.

Revision 1.7 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:48 2016 UTC (7 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Aug 28 15:18:24 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.5: +3 -7 lines
Diff to previous 1.5 (colored)

Upstream claims that it doesn't matter that one file does not compile.
Allow python-2.x again and adapt PLIST.

Revision 1.5 / (download) - annotate - [select for diffs], Fri Aug 28 10:37:15 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.4: +3 -1 lines
Diff to previous 1.4 (colored)

Add upstream bug report URL.

Revision 1.4 / (download) - annotate - [select for diffs], Fri Aug 28 10:34:07 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.3: +8 -1 lines
Diff to previous 1.3 (colored)

Mark as not-for-python-2.x. Add compiled files for 3.x to PLIST.
Bump PKGREVISION.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Aug 9 18:41:58 2015 UTC (8 years, 4 months ago) by gls
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Update www/py-gunicorn to 19.3.0

Upstream changes:
-----------------

19.3.0 / 2015/03/06

Core

    fix: :issue:`978` make sure a listener is inheritable
    add check_config class method to workers
    fix: :issue:`983` fix select timeout in sync worker with multiple connections
    allows workers to access to the reloader. close :issue:`984`
    raise TypeError instead of AssertionError

Logging

    make Logger.loglevel a class attribute

Documentation

    fix: :issue:`988` fix syntax errors in examples/gunicorn_rc

19.2.1 / 2015/02/4

Logging

    expose loglevel in the Logger class

AsyncIO worker (gaiohttp)

    fix :issue:`977` fix initial crash

Documentation

    document security mailing-list in the contributing page.

Revision 1.2 / (download) - annotate - [select for diffs], Wed Aug 13 20:27:09 2014 UTC (9 years, 3 months ago) by gls
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.1: +3 -3 lines
Diff to previous 1.1 (colored)

Update www/py-gunicorn to 19.1.0

pkgsrc changes:
---------------
- Cleanups

Upstream changes:
-----------------

Complete changelog in share/doc/py-gunicorn/2014-news.rst.

19.1
====

Bugfix release.

19.0
====
Gunicorn 19.0 is a major release with new features and fixes. This
version improve a lot the usage of Gunicorn with python 3 by adding two
new workers to it: `gthread` a fully threaded async worker using futures
and `gaiohttp` a worker using asyncio.

Breaking Changes
~~~~~~~~~~~~~~~~
Switch QUIT and TERM signals
++++++++++++++++++++++++++++
With this change, when gunicorn receives a QUIT all the workers are
killed immediately and exit and TERM is used for the graceful shutdown.
Note: the old behaviour was based on the NGINX but the new one is more
correct according the following doc:
https://www.gnu.org/software/libc/manual/html_node/Termination-Signals.html
also it is complying with the way the signals are sent by heroku:
https://devcenter.heroku.com/articles/python-faq#what-constraints-exist-when-developing-applications-on-heroku

Deprecations
+++++++++++++
`run_gunicorn`, `gunicorn_django` and `gunicorn_paster` are now
completely deprecated and will be removed in the next release. Use the
`gunicorn` command instead.

Revision 1.1 / (download) - annotate - [select for diffs], Thu May 8 09:05:51 2014 UTC (9 years, 7 months ago) by imil
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2

Initial import of py-gunicorn, version 18.0, into the NetBSD Packages
Collection.

Gunicorn 'Green Unicorn' is a Python WSGI HTTP Server for UNIX. It's a
pre-fork worker model ported from Ruby's Unicorn project. The Gunicorn
server is broadly compatible with various web frameworks, simply
implemented, light on server resource usage, and fairly speedy.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>