[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / py-genshi

File: [cvs.NetBSD.org] / pkgsrc / www / py-genshi / Makefile (download)

Revision 1.16, Wed Mar 10 18:11:34 2021 UTC (3 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.15: +2 -2 lines

py-genshi: updated to 0.7.5

Version 0.7.5
 * Fix handling of slices containing function call, variable name and attribute
   lookup AST nodes in Python 3.9 in template scripts (template expressions
   already correctly handled these cases). Thank you to Roger Leigh for
   finding this issue and contributing the fix for it.
 * C speedup module now available for Python >= 3.3. Support was added for
   PEP 393 (flexible string representation). Thank you to Inada Naoki for
   contributing this major enhancement.
 * Remove the custom 2to3 fixers (no longer used since the removal of 2to3
   in 0.7.4).


Version 0.7.4
 * Add support for deprecation of ast classes slice, Index and ExtSlice in
   Python 3.9. See https://bugs.python.org/issue34822 for details of the
   changes.
 * Update the project URL in setup.py to point to GitHub.
 * Remove use of 2to3 for generating Python 3 compatible code.

# $NetBSD: Makefile,v 1.16 2021/03/10 18:11:34 adam Exp $

DISTNAME=	Genshi-0.7.5
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES=	www python
MASTER_SITES=	${MASTER_SITE_PYPI:=G/Genshi/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://genshi.edgewall.org/
COMMENT=	Python toolkit for generation of output for the web
LICENSE=	modified-bsd

DEPENDS+=	${PYPKGPREFIX}-babel>=0.8:../../devel/py-babel
DEPENDS+=	${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"