The NetBSD Project

CVS log for pkgsrc/www/py-flask-sqlalchemy/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-flask-sqlalchemy

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.19: download - view: text, markup, annotated - select for diffs
Sun Feb 23 21:01:54 2025 UTC (7 weeks, 5 days ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, HEAD
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +3 -4 lines
py-flask-sqlalchemy: adapt for flit_core 3.11.

Bump PKGREVISION.

Revision 1.18: download - view: text, markup, annotated - select for diffs
Wed Mar 6 21:17:22 2024 UTC (13 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +5 -6 lines
py-flask-sqlalchemy: update to 3.1.1.

Version 3.1.1
-------------

Released 2023-09-11

-   Deprecate the ``__version__`` attribute. Use feature detection, or
    ``importlib.metadata.version("flask-sqlalchemy")``, instead. :issue:`5230`


Version 3.1.0
-------------

Released 2023-09-11

-   Drop support for Python 3.7.  :pr:`1251`
-   Add support for the SQLAlchemy 2.x API via ``model_class`` parameter. :issue:`1140`
-   Bump minimum version of SQLAlchemy to 2.0.16.
-   Remove previously deprecated code.
-   Pass extra keyword arguments from ``get_or_404`` to ``session.get``. :issue:`1149`
-   Fix bug with finding right bind key for clause statements. :issue:`1211`


Version 3.0.5
-------------

Released 2023-06-21

-   ``Pagination.next()`` enforces ``max_per_page``. :issue:`1201`
-   Improve type hint for ``get_or_404`` return value to be non-optional. :pr:`1226`


Version 3.0.4
-------------

Released 2023-06-19

-   Fix type hint for ``get_or_404`` return value. :pr:`1208`
-   Fix type hints for pyright (used by VS Code Pylance extension). :issue:`1205`


Version 3.0.3
-------------

Released 2023-01-31

-   Show helpful errors when mistakenly using multiple ``SQLAlchemy`` instances for the
    same app, or without calling ``init_app``. :pr:`1151`
-   Fix issue with getting the engine associated with a model that uses polymorphic
    table inheritance. :issue:`1155`


Version 3.0.2
-------------

Released 2022-10-14

-   Update compatibility with SQLAlchemy 2. :issue:`1122`


Version 3.0.1
-------------

Released 2022-10-11

-   Export typing information instead of using external typeshed definitions.
    :issue:`1112`
-   If default engine options are set, but ``SQLALCHEMY_DATABASE_URI`` is not set, an
    invalid default bind will not be configured. :issue:`1117`


Version 3.0.0
-------------

Released 2022-10-04

-   Drop support for Python 2, 3.4, 3.5, and 3.6.
-   Bump minimum version of Flask to 2.2.
-   Bump minimum version of SQLAlchemy to 1.4.18.
-   Remove previously deprecated code.
-   The session is scoped to the current app context instead of the thread. This
    requires that an app context is active. This ensures that the session is cleaned up
    after every request.
-   An active Flask application context is always required to access ``session`` and
    ``engine``, regardless of if an application was passed to the constructor.
    :issue:`508, 944`
-   Different bind keys use different SQLAlchemy ``MetaData`` registries, allowing
    tables in different databases to have the same name. Bind keys are stored and looked
    up on the resulting metadata rather than the model or table.
-   ``SQLALCHEMY_DATABASE_URI`` does not default to ``sqlite:///:memory:``. An error is
    raised if neither it nor ``SQLALCHEMY_BINDS`` define any engines. :pr:`731`
-   Configuring SQLite with a relative path is relative to ``app.instance_path`` instead
    of ``app.root_path``. The instance folder is created if necessary. :issue:`462`
-   Added ``get_or_404``, ``first_or_404``, ``one_or_404``, and ``paginate`` methods to
    the extension object. These use SQLAlchemy's preferred ``session.execute(select())``
    pattern instead of the legacy query interface. :issue:`1088`
-   Setup methods that create the engines and session are renamed with a leading
    underscore. They are considered internal interfaces which may change at any time.
-   All parameters to ``SQLAlchemy`` except ``app`` are keyword-only.
-   Renamed the ``bind`` parameter to ``bind_key`` and removed the ``app`` parameter
    from various ``SQLAlchemy`` methods.
-   The extension object uses ``__getattr__`` to alias names from the SQLAlchemy
    package, rather than copying them as attributes.
-   The extension object is stored directly as ``app.extensions["sqlalchemy"]``.
    :issue:`698`
-   The session class can be customized by passing the ``class_`` key in the
    ``session_options`` parameter. :issue:`327`
-   ``SignallingSession`` is renamed to ``Session``.
-   ``Session.get_bind`` more closely matches the base implementation.
-   Model classes and the ``db`` instance are available without imports in
    ``flask shell``. :issue:`1089`
-   The ``CamelCase`` to ``snake_case`` table name converter handles more patterns
    correctly. If model that was already created in the database changed, either use
    Alembic to rename the table, or set ``__tablename__`` to keep the old name.
    :issue:`406`
-   ``Model`` ``repr`` distinguishes between transient and pending instances.
    :issue:`967`
-   A custom model class can implement ``__init_subclass__`` with class parameters.
    :issue:`1002`
-   ``db.Table`` is a subclass instead of a function.
-   The ``engine_options`` parameter is applied as defaults before per-engine
    configuration.
-   ``SQLALCHEMY_BINDS`` values can either be an engine URL, or a dict of engine options
    including URL, for each bind. ``SQLALCHEMY_DATABASE_URI`` and
    ``SQLALCHEMY_ENGINE_OPTIONS`` correspond to the ``None`` key and take precedence.
    :issue:`783`
-   Engines are created when calling ``init_app`` rather than the first time they are
    accessed. :issue:`698`
-   ``db.engines`` exposes the map of bind keys to engines for the current app.
-   ``get_engine``, ``get_tables_for_bind``, and ``get_binds`` are deprecated.
-   SQLite driver-level URIs that look like ``sqlite:///file:name.db?uri=true`` are
    supported. :issue:`998, 1045`
-   SQLite engines do not use ``NullPool`` if ``pool_size`` is 0.
-   MySQL engines use the "utf8mb4" charset by default. :issue:`875`
-   MySQL engines do not set ``pool_size`` to 10.
-   MySQL engines don't set a default for ``pool_recycle`` if not using a queue pool.
    :issue:`803`
-   ``Query`` is renamed from ``BaseQuery``.
-   Added ``Query.one_or_404``.
-   The query class is applied to ``backref`` in ``relationship``. :issue:`417`
-   Creating ``Pagination`` objects manually is no longer a public API. They should be
    created with ``db.paginate`` or ``query.paginate``. :issue:`1088`
-   ``Pagination.iter_pages`` and ``Query.paginate`` parameters are keyword-only.
-   ``Pagination`` is iterable, iterating over its items. :issue:`70`
-   Pagination count query is more efficient.
-   ``Pagination.iter_pages`` is more efficient. :issue:`622`
-   ``Pagination.iter_pages`` ``right_current`` parameter is inclusive.
-   Pagination ``per_page`` cannot be 0. :issue:`1091`
-   Pagination ``max_per_page`` defaults to 100. :issue:`1091`
-   Added ``Pagination.first`` and ``last`` properties, which give the number of the
    first and last item on the page. :issue:`567`
-   ``SQLALCHEMY_RECORD_QUERIES`` is disabled by default, and is not enabled
    automatically with ``app.debug`` or ``app.testing``. :issue:`1092`
-   ``get_debug_queries`` is renamed to ``get_recorded_queries`` to better match the
    config and functionality.
-   Recorded query info is a dataclass instead of a tuple. The ``context`` attribute is
    renamed to ``location``. Finding the location uses a more inclusive check.
-   ``SQLALCHEMY_TRACK_MODIFICATIONS`` is disabled by default. :pr:`727`
-   ``SQLALCHEMY_COMMIT_ON_TEARDOWN`` is deprecated. It can cause various design issues
    that are difficult to debug. Call ``db.session.commit()`` directly instead.
    :issue:`216`

Revision 1.17: download - view: text, markup, annotated - select for diffs
Fri Apr 29 11:56:46 2022 UTC (2 years, 11 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +3 -1 lines
*: mark py-flask dependencies as not-for-python-2.x

I'll update py-flask soon; the current pkgsrc of py-flask version
is broken and all newer versions do not support python 2.x

Revision 1.16: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:55:27 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.15: download - view: text, markup, annotated - select for diffs
Wed Apr 7 13:08:46 2021 UTC (4 years ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +4 -4 lines
py-flask-sqlalchemy: Update to 2.5.1.

Version 2.5.1
-------------

Released 2021-03-18

-   Fix compatibility with Python 2.7.


Version 2.5.0
-------------

Released 2021-03-18

-   Update to support SQLAlchemy 1.4.
-   SQLAlchemy ``URL`` objects are immutable. Some internal methods have
    changed to return a new URL instead of ``None``. :issue:`885`

Revision 1.14: download - view: text, markup, annotated - select for diffs
Thu Jul 23 09:35:16 2020 UTC (4 years, 8 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
py-flask-sqlalchemy: Update to 2.4.4.

Version 2.4.4
-------------

Released 2020-07-14

-   Change base class of meta mixins to ``type``. This fixes an issue
    caused by a regression in CPython 3.8.4. :issue:`852`

Revision 1.13: download - view: text, markup, annotated - select for diffs
Fri Jun 5 11:41:32 2020 UTC (4 years, 10 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -3 lines
py-flask-sqlalchemy: Update to 2.4.3.

Version 2.4.3
-------------

Released 2020-05-26

-   Deprecate ``SQLALCHEMY_COMMIT_ON_TEARDOWN`` as it can cause various
    design issues that are difficult to debug. Call
    ``db.session.commit()`` directly instead. :issue:`216`


Version 2.4.2
-------------

Released 2020-05-25

-   Fix bad pagination when records are de-duped. :pr:`812`

Revision 1.12: download - view: text, markup, annotated - select for diffs
Fri Nov 8 13:21:52 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
py-flask-sqlalchemy: updated to 2.4.1

Version 2.4.1
- Fix ``AttributeError`` when using multiple binds with polymorphic
  models.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sun May 19 08:07:54 2019 UTC (5 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
py-flask-sqlalchemy: updated to 2.4.0

Version 2.4.0
-  Make engine configuration more flexible.
-  Address SQLAlchemy 1.3 deprecations.
-  get_or_404() and first_or_404() now accept a description
   parameter to control the 404 message.
-  Use time.perf_counter for Python 3 on Windows.
-  Drop support for Python 2.6 and 3.3.
-  Add an example of Flask's tutorial project, Flaskr, adapted for
   Flask-SQLAlchemy.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Dec 12 09:53:24 2017 UTC (7 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +4 -4 lines
py-flaks-sqlalchemy: updated to 2.3.2

Version 2.3.2
- Don't mask the parent table for single-table inheritance models.

Version 2.3.1
- If a model has a table name that matches an existing table in the metadata,
  use that table. Fixes a regression where reflected tables were not picked up
  by models.
- Raise the correct error when a model has a table name but no primary key.
- Fix repr on models that don't have an identity because they have not been
  flushed yet.
- Allow specifying a max_per_page limit for pagination, to avoid users
  specifying high values in the request args.
- For paginate with error_out=False, the minimum value for page is
  1 and per_page is 0.

Version 2.3.0
- Multiple bugs with __tablename__ generation are fixed. Names will be
  generated for models that define a primary key, but not for single-table
  inheritance subclasses. Names will not override a declared_attr.
  PrimaryKeyConstraint is detected.
- Passing an existing declarative_base() as model_class to
  SQLAlchemy.__init__ will use this as the base class instead of creating
  one. This allows customizing the metaclass used to construct the base.
- The undocumented DeclarativeMeta internals that the extension uses for
  binds and table name generation have been refactored to work as mixins.
  Documentation is added about how to create a custom metaclass that does not
  do table name generation.
- Model and metaclass code has been moved to a new models module.
  _BoundDeclarativeMeta is renamed to DefaultMeta; the old name will be
  removed in 3.0.
- Models have a default repr that shows the model name and primary key.
- Fixed a bug where using init_app would cause connectors to always use the
  current_app rather than the app they were created for. This caused issues
  when multiple apps were registered with the extension.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Sun Jul 30 22:32:26 2017 UTC (7 years, 8 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Switch github HOMEPAGEs to https.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Tue Mar 14 14:49:01 2017 UTC (8 years, 1 month ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +3 -3 lines
Update py-flask-sqlalchemy to 2.2.


Version 2.2
-----------

Released on February 27, 2017, codename Dubnium

- Minimum SQLAlchemy version is 0.8 due to use of ``sqlalchemy.inspect``.
- Added support for custom ``query_class`` and ``model_class`` as args
  to the ``SQLAlchemy`` constructor. (`#328`_)
- Allow listening to SQLAlchemy events on ``db.session``. (`#364`_)
- Allow ``__bind_key__`` on abstract models. (`#373`_)
- Allow ``SQLALCHEMY_ECHO`` to be a string. (`#409`_)
- Warn when ``SQLALCHEMY_DATABASE_URI`` is not set. (`#443`_)
- Don't let pagination generate invalid page numbers. (`#460`_)
- Drop support of Flask < 0.10. This means the db session is always tied to
  the app context and its teardown event. (`#461`_)
- Tablename generation logic no longer accesses class properties unless they
  are ``declared_attr``. (`#467`_)

.. _#328: https://github.com/mitsuhiko/flask-sqlalchemy/pull/328
.. _#364: https://github.com/mitsuhiko/flask-sqlalchemy/pull/364
.. _#373: https://github.com/mitsuhiko/flask-sqlalchemy/pull/373
.. _#409: https://github.com/mitsuhiko/flask-sqlalchemy/pull/409
.. _#443: https://github.com/mitsuhiko/flask-sqlalchemy/pull/443
.. _#460: https://github.com/mitsuhiko/flask-sqlalchemy/pull/460
.. _#461: https://github.com/mitsuhiko/flask-sqlalchemy/pull/461
.. _#467: https://github.com/mitsuhiko/flask-sqlalchemy/pull/467

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Jun 8 17:43:45 2016 UTC (8 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Switch to MASTER_SITES_PYPI.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Oct 26 18:48:55 2015 UTC (9 years, 5 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Update py-flask-sqlalchemy to 2.1.


Version 2.1
-----------

Released on October 23rd 2015, codename Caesium

- Table names are automatically generated in more cases, including
  subclassing mixins and abstract models.
- Allow using a custom MetaData object.
- Add support for binds parameter to session.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Dec 31 13:57:33 2014 UTC (10 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +1 -3 lines
Improve EGG_NAME default to work for packages with '-' in their name.
Remove now unnecessary overrides in various packages.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Oct 23 14:42:05 2014 UTC (10 years, 5 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Update py-flask-sqlalchemy to 2.0.

Version 2.0
-----------

Released on August 29th 2014, codename Bohrium

- Changed how the builtin signals are subscribed to skip non
  Flask-SQLAlchemy sessions.  This will also fix the attribute error about
  model changes not existing.
- Added a way to control how signals for model modifications are tracked.
- Made the ``SignallingSession`` a public interface and added a hook
  for customizing session creation.
- If the ``bind`` parameter is given to the signalling session it will no
  longer cause an error that a parameter is given twice.
- Added working table reflection support.
- Enabled autoflush by default.
- Consider ``SQLALCHEMY_COMMIT_ON_TEARDOWN`` harmful and remove from docs.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Aug 4 13:47:10 2013 UTC (11 years, 8 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -3 lines
Update py-flask-sqlalchemy to 1.0.

Version 1.0
-----------

(Released on July 20th 2013, no codename)

- Added Python 3.3 support.
- Dropped 2.5 compatibility.
- Various bugfixes
- Changed versioning format to do major releases for each update now.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Jan 9 19:02:44 2013 UTC (12 years, 3 months ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -1 lines
Sprinkle empty USE_LANGUAGES definitions in pure python packages
where missed at import time.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Jan 7 20:26:49 2013 UTC (12 years, 3 months ago) by kleink
Branches: MAIN
Import Flask-SQLAlchemy-0.16 as www/py-flask-sqlalchemy.

Flask-SQLAlchemy is an extension for Flask that adds support for
SQLAlchemy to your application. It requires SQLAlchemy 0.6 or
higher. It aims to simplify using SQLAlchemy with Flask by providing
useful defaults and extra helpers that make it easier to accomplish
common tasks.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>