Up to [cvs.NetBSD.org] / pkgsrc / www / py-djangorestframework
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.37 / (download) - annotate - [select for diffs], Thu Sep 28 22:26:33 2023 UTC (2 months ago) by joerg
Branch: MAIN
CVS Tags: HEAD
Changes since 1.36: +3 -1
lines
Diff to previous 1.36 (colored)
Extract using bsdtar, nbpax is broken
Revision 1.36 / (download) - annotate - [select for diffs], Sat Aug 5 06:19:18 2023 UTC (3 months, 4 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3
Changes since 1.35: +2 -3
lines
Diff to previous 1.35 (colored)
py-djangorestframework: updated to 3.14.0 Django REST framework 3.14 Django 4.1 support The latest release now fully supports Django 4.1, and drops support for Django 2.2. Our requirements are now: Python 3.6+ Django 4.1, 4.0, 3.2, 3.1, 3.0 raise_exceptions argument for is_valid is now keyword-only. Calling serializer_instance.is_valid(True) is no longer acceptable syntax. If you'd like to use the raise_exceptions argument, you must use it as a keyword argument. ManyRelatedField supports returning the default when the source attribute doesn't exist. Previously, if you used a serializer field with many=True with a dot notated source field that didn't exist, it would raise an AttributeError. Now it will return the default or be skipped depending on the other arguments. Make Open API get_reference public. Returns a reference to the serializer component. This may be useful if you override get_schema(). Change semantic of OR of two permission classes. When OR-ing two permissions, the request has to pass either class's has_permission() and has_object_permission(). Previously, both class's has_permission() was ignored when OR-ing two permissions together. Minor fixes and improvements There are a number of minor fixes and improvements in this release. See the release notes page for a complete listing.
Revision 1.35 / (download) - annotate - [select for diffs], Thu Jul 13 10:03:30 2023 UTC (4 months, 3 weeks ago) by wiz
Branch: MAIN
Changes since 1.34: +3 -2
lines
Diff to previous 1.34 (colored)
*: switch django users to py-django3
Revision 1.34 / (download) - annotate - [select for diffs], Mon Jan 24 14:32:59 2022 UTC (22 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.33: +4 -4
lines
Diff to previous 1.33 (colored)
py-djangorestframework: updated to 3.13.1 3.13.1 Revert schema naming changes with function based @api_view. 3.13.0 Django 4.0 compatability. Add max_length and min_length options to ListSerializer. Add get_request_serializer and get_response_serializer hooks to AutoSchema. Fix OpenAPI representation of null-able read only fields. Respect UNICODE_JSON setting in API schema outputs. Fix for RemoteUserAuthentication. Make Field constructors keyword-only.
Revision 1.33 / (download) - annotate - [select for diffs], Tue Jan 4 20:55:24 2022 UTC (22 months, 4 weeks ago) by wiz
Branch: MAIN
Changes since 1.32: +2 -1
lines
Diff to previous 1.32 (colored)
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
Revision 1.32 / (download) - annotate - [select for diffs], Sat Apr 3 07:33:30 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Changes since 1.31: +3 -3
lines
Diff to previous 1.31 (colored)
py-djangorestframework: updated to 3.12.4 3.12.4 Revert use of deque instead of list for tracking throttling .history. (Due to incompatibility with DjangoRedis cache backend. 3.12.3 Properly handle ATOMIC_REQUESTS when multiple database configurations are used. Bypass COUNT query when LimitOffsetPagination is configured but pagination params are not included on the request. Respect allow_null=True on DecimalField. Allow title cased "Yes"/"No" values with BooleanField. Add PageNumberPagination.get_page_number() method for overriding behavior. Fixed rendering of timedelta values in OpenAPI schemas, when present as default, min, or max fields. Render JSONFields with indentation in browsable API forms. Remove unnecessary database query in admin Token views. Raise validation errors when bools are passed to PrimaryKeyRelatedField fields, instead of casting to ints. Don't include model properties as automatically generated ordering fields with OrderingFilter. Use deque instead of list for tracking throttling .history.
Revision 1.31 / (download) - annotate - [select for diffs], Wed Jan 20 10:57:01 2021 UTC (2 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.30: +2 -2
lines
Diff to previous 1.30 (colored)
py-djangorestframework: updated to 3.12.2 3.12.2 Fix issue if rest_framework.authtoken.models is imported, but rest_framework.authtoken is not in INSTALLED_APPS. Ignore subclasses of BrowsableAPIRenderer in OpenAPI schema. Narrower exception catching in serilizer fields, to ensure that any errors in broken get_queryset() methods are not masked.
Revision 1.30 / (download) - annotate - [select for diffs], Fri Oct 2 19:27:47 2020 UTC (3 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4
Changes since 1.29: +4 -4
lines
Diff to previous 1.29 (colored)
py-djangorestframework: updated to 3.12.1 3.12.1 Add TokenProxy migration. 3.12.0 Add --file option to generateschema command. Support tags for OpenAPI schema generation. See the schema docs. Support customising the operation ID for schema generation. See the schema docs. Support OpenAPI components for schema generation. See the schema docs. The following methods on AutoSchema become public API: get_path_parameters, get_pagination_parameters, get_filter_parameters, get_request_body, get_responses, get_serializer, get_paginator, map_serializer, map_field, map_choice_field, map_field_validators, allows_filters. See the schema docs Add support for Django 3.1's database-agnositic JSONField. SearchFilter now supports nested search on JSONField and HStoreField model fields. SearchFilter now supports searching on annotate() fields. The authtoken model no longer exposes the pk in the admin URL. Add __repr__ for Request instances. UTF-8 decoding with Latin-1 fallback for basic auth credentials. CharField treats surrogate characters as a validation failure. Don't include callables as default values in schemas. Improve ListField schema output to include all available child information. Allow default=False to be included for BooleanField schema outputs. Include "type" information in ChoiceField schema outputs. Include "type": "object" on schema objects. Don't include component in schema output for DELETE requests. Fix schema types for DecimalField. Fix schema generation for ObtainAuthToken view. Support passing context=... to view .get_serializer() methods. Pass custom code to PermissionDenied if permission class has one set. Include "example" in schema pagination output. Default status code of 201 on schema output for POST requests. Use camelCase for operation IDs in schema output. Warn if duplicate operation IDs exist in schema output. Improve handling of decimal type when mapping ChoiceField to a schema output. Disable YAML aliases for OpenAPI schema outputs. Fix action URL names for APIs included under a namespaced URL. Update jQuery version from 3.4 to 3.5. Fix UniqueTogether handling when serializer fields use source=.... HTTP HEAD requests now set self.action correctly on a ViewSet instance. Return a valid OpenAPI schema for the case where no API schema paths exist. Include tests in package distribution. Allow type checkers to support annotations like ModelSerializer[Author]. Don't include invalid charset=None portion in the request Content-Type header when using APIClient. Fix \Z/\z tokens in OpenAPI regexs. Fix PrimaryKeyRelatedField and HyperlinkedRelatedField when source field is actually a property. Token.generate_key is now a class method. @action warns if method is wrapped in a decorator that does not preserve information using
Revision 1.29 / (download) - annotate - [select for diffs], Thu Aug 20 11:37:06 2020 UTC (3 years, 3 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base,
pkgsrc-2020Q3
Changes since 1.28: +2 -2
lines
Diff to previous 1.28 (colored)
Update django restframework to 3.11.1: - Make get_extra_action less permissive
Revision 1.28 / (download) - annotate - [select for diffs], Sun Dec 15 21:38:40 2019 UTC (3 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4
Changes since 1.27: +2 -2
lines
Diff to previous 1.27 (colored)
py-djangorestframework: updated to 3.11.0 Django REST framework 3.11 The 3.11 release adds support for Django 3.0. Our supported Python versions are now: 3.5, 3.6, 3.7, and 3.8. Our supported Django versions are now: 1.11, 2.0, 2.1, 2.2, and 3.0. This release will be the last to support Python 3.5 or Django 1.11. * OpenAPI Schema Generation Improvements * Validator / Default Context
Revision 1.27 / (download) - annotate - [select for diffs], Thu Nov 14 17:27:15 2019 UTC (4 years ago) by adam
Branch: MAIN
Changes since 1.26: +4 -2
lines
Diff to previous 1.26 (colored)
py-djangorestframework: updated to 3.10.3 3.10.3 Include API version in OpenAPI schema generation, defaulting to empty string. Add pagination properties to OpenAPI response schemas. Add missing "description" property to OpenAPI response schemas. Only include "required" for non-empty cases in OpenAPI schemas. Fix response schemas for "DELETE" case in OpenAPI schemas. Use an array type for list view response schemas. Use consistent lowerInitialCamelCase style in OpenAPI operation IDs. Fix minLength/maxLength/minItems/maxItems properties in OpenAPI schemas. Only call FileField.url once in serialization, for improved performance. Fix an edge case where throttling calcualtions could error after a configuration change. 3.10.2 Various OpenAPI schema fixes. Ability to specify urlconf in include_docs_urls. 3.10.1 Don't include autocomplete fields on TokenAuth admin, since it forces constraints on custom user models & admin. Require uritemplate for OpenAPI schema generation, but not coreapi. 3.10.0 Switch to OpenAPI schema generation. Drop Python 2 support. Add generateschema --generator_class CLI option Updated PyYaml dependency for OpenAPI schema generation to pyyaml>=5.1 Resolve DeprecationWarning with markdown. Use user.get_username in templates, in preference to user.username. Fix for cursor pagination issue that could occur after object deletions. Fix for nullable fields with source="*" Always apply all throttle classes during throttling checks. Updates to jQuery and Markdown dependencies. Don't strict disallow redundant SerializerMethodField field name arguments. Don't render extra actions in browable API if not authenticated. Strip null characters from search parameters.
Revision 1.26 / (download) - annotate - [select for diffs], Mon May 13 15:52:13 2019 UTC (4 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2
Changes since 1.25: +2 -2
lines
Diff to previous 1.25 (colored)
py-djangorestframework: updated to 3.9.4 3.9.4 This is a maintenance release that fixes an error handling bug under Python 2.
Revision 1.25 / (download) - annotate - [select for diffs], Tue Apr 30 07:57:19 2019 UTC (4 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.24: +2 -2
lines
Diff to previous 1.24 (colored)
py-djangorestframework: updated to 3.9.3 3.9.3 This is the last Django REST Framework release that will support Python 2. Be sure to upgrade to Python 3 before upgrading to Django REST Framework 3.10. Adjusted the compat check for django-guardian to allow the last guardian version (v1.4.9) compatible with Python 2
Revision 1.24 / (download) - annotate - [select for diffs], Mon Mar 4 08:29:25 2019 UTC (4 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Changes since 1.23: +2 -2
lines
Diff to previous 1.23 (colored)
py-djangorestframework: updated to 3.9.2 3.9.2: Routers: invalidate _urls cache on register() Deferred schema renderer creation to avoid requiring pyyaml. Added 'request_forms' block to base.html Fixed SchemaView to reset renderer on exception. Update Django Guardian dependency. Ensured support for Django 2.2. Made templates compatible with session-based CSRF. Adjusted field validators to accept non-list iterables. Added SearchFilter.get_search_fields() hook. Fix DeprecationWarning when accessing collections.abc classes via collections Allowed Q objects in limit_choices_to introspection. Added lazy evaluation to composed permissions. Add negation ~ operator to permissions composition Avoided calling distinct on annotated fields in SearchFilter. Introduced RemovedInDRFăŕ¦×arning classes to simplify deprecations.
Revision 1.23 / (download) - annotate - [select for diffs], Wed Jan 16 19:24:12 2019 UTC (4 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.22: +2 -2
lines
Diff to previous 1.22 (colored)
py-djangorestframework: updated to 3.9.1 3.9.1 Resolve XSS issue in browsable API. Upgrade Bootstrap to 3.4.0 to resolve XSS issue. Resolve issues with composable permissions. Respect limit_choices_to on foreign keys.
Revision 1.22 / (download) - annotate - [select for diffs], Tue Oct 23 07:57:05 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base,
pkgsrc-2018Q4
Changes since 1.21: +3 -3
lines
Diff to previous 1.21 (colored)
py-djangorestframework: updated to 3.9.0 3.9.0: Improvements to ViewSet extra actions Fix action support for ViewSet suffixes Allow action docs sections Deprecate the Router.register base_name argument in favor of basename. Deprecate the Router.get_default_base_name method in favor of Router.get_default_basename. Change CharField to disallow null bytes. To revert to the old behavior, subclass CharField and remove ProhibitNullCharactersValidator from the validators. python class NullableCharField(serializers.CharField): def __init__(self, *args, **kwargs): super().__init__(*args, **kwargs) self.validators = [v for v in self.validators if not isinstance(v, ProhibitNullCharactersValidator)] Add OpenAPIRenderer and generate_schema management command. Add OpenAPIRenderer by default, and add schema docs. Allow permissions to be composed Allow nullable BooleanField in Django 2.1 Add testing of Python 3.7 support Test using Django 2.1 final release. Added djangorestframework-datatables to third-party packages Change ISO 8601 date format to exclude year/month Update all pypi.python.org URLs to pypi.org Ensure that html forms (multipart form data) respect optional fields Allow hashing of ErrorDetail. Correct schema parsing for JSONField Render descriptions (from help_text) using safe Removed input value from deault_error_message Added min_value/max_value support in DurationField Fixed instance being overwritten in pk-only optimization try/except block Fixed AttributeError from items filter when value is None Fixed Javascript e.indexOf is not a function error Fix schemas for extra actions Improved get_error_detail to use error_dict/error_list Imprvied URLs in Admin renderer Add "Community" section to docs, minor cleanup Moved guardian imports out of compat Deprecate the DjangoObjectPermissionsFilter class, moved to the djangorestframework-guardian package. Drop Django 1.10 support Only catch TypeError/ValueError for object lookups Handle models without .objects manager in ModelSerializer. Improve ModelSerializer.create() error message. Fix CSRF cookie check failure when using session auth with django 1.11.6+ Updated JWT docs. Fix autoescape not getting passed to urlize_quoted_links filter
Revision 1.21 / (download) - annotate - [select for diffs], Sat Apr 7 19:55:22 2018 UTC (5 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Changes since 1.20: +2 -2
lines
Diff to previous 1.20 (colored)
py-djangorestframework: updated to 3.8.2 Version 3.8.2: Fix read_only + default unique_together validation. authtoken.views import coreapi from rest_framework.compat, not directly. Docs: Add missing argument 'detail' to Route
Revision 1.20 / (download) - annotate - [select for diffs], Thu Apr 5 08:14:18 2018 UTC (5 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.19: +2 -2
lines
Diff to previous 1.19 (colored)
py-djangorestframework: updated to 3.8.1 Version 3.8.1: Use old url_name behavior in route decorators For list_route and detail_route maintain the old behavior of url_name, basing it on the url_path instead of the function name. Version 3.8: Breaking Change: Alter read_only plus default behaviour. Correct allow_null behaviour when required=False Refactor dynamic route generation and improve viewset action introspectibility. Fix formatting of the 3.7.4 release note Docs: Update DRF Writable Nested Serializers references Docs: Fixed typo in auth URLs example. Improve composite field child errors Disable HTML inputs for dict/list fields Fix typo in HostNameVersioning doc Use rsplit to get module and classname for imports Formalize URLPatternsTestCase Add exception translation test Test staticfiles Add drf-yasg to documentation and schema 3rd party packages Remove unused compat._resolve_model() Drop compat workaround for unsupported Python 3.2 Prefer iter(dict) over iter(dict.keys()) Pass python_requires argument to setuptools Remove unused links from docs Prefer https protocol for links in docs when available Add HStoreField, postgres fields tests Always fully qualify ValidationError in docs Remove unreachable code from ManualSchema Allowed customising API documentation code samples Updated docs to use pip show Load 'static' instead of 'staticfiles' in templates Fixed a typo in fields docs Refer to "NamespaceVersioning" instead of "NamespacedVersioning" in the documentation ErrorDetail: add __eq__/__ne__ and __repr__ Replace background-attachment: fixed in docs Make 404 & 403 responses consistent with exceptions.APIException output Small fix to API documentation: schemas Fix schema generation for PrimaryKeyRelatedField Represent serializer DictField as an Object in schema Added docs example reimplementing ObtainAuthToken Add schema to the ObtainAuthToken view Fix request formdata handling Fix authtoken views imports Update pytest, isort Fixed active timezone handling for non ISO8601 datetimes. Made TemplateHTMLRenderer render IntegerField inputs when value is 0. Corrected endpoint in tutorial instructions Add Django Rest Framework Role Filters to Third party packages Use single copy of static assets. Update jQuery Changes ternary conditionals to be PEP308 compliant Added links to 'A Todo List API with React' and 'Blog API' tutorials Fix comment typo in ModelSerializer Add admin to installed apps to avoid test failures. Fixed schema for UUIDField in SimpleMetadata. Corrected docs on router include with namespaces. Test using model objects for dotted source default Allow traversing nullable related fields Added: Tutorial: Django REST with React (Django 2.0) Add LimitOffsetPagination.get_count to allow method override Don't show hidden fields in metadata Enable OrderingFilter to handle an empty tuple (or list) for the 'ordering' field. Added generic 500 and 400 JSON error handlers.
Revision 1.19 / (download) - annotate - [select for diffs], Thu Dec 21 13:42:43 2017 UTC (5 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4
Changes since 1.18: +2 -2
lines
Diff to previous 1.18 (colored)
py-djangorestframework: updated to 3.7.7 3.7.7: Fix typo to include *.mo locale files to packaging. 3.7.6: Add missing *.ico icon files to packaging. 3.7.5 Add missing *.woff2 font files to packaging. Add missing *.mo locale files to packaging.
Revision 1.18 / (download) - annotate - [select for diffs], Thu Dec 21 07:33:44 2017 UTC (5 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.17: +3 -3
lines
Diff to previous 1.17 (colored)
py-djangorestframework: updated to 3.7.4 3.7.4: Schema: Extract method for manual_fields processing Allows for easier customisation of manual_fields processing, for example to provide per-method manual fields. AutoSchema adds get_manual_fields, as the intended override point, and a utility method update_fields, to handle by-name field replacement from a list, which, in general, you are not expected to override.
Revision 1.17 / (download) - annotate - [select for diffs], Wed Nov 8 12:29:22 2017 UTC (6 years ago) by adam
Branch: MAIN
Changes since 1.16: +2 -2
lines
Diff to previous 1.16 (colored)
py-djangorestframework: updated to 3.7.3 Version 3.7.3: Fix AppRegistryNotReady error importing contrib.auth views Version 3.7.2: Fixed Django 2.1 compatibility due to removal of django.contrib.auth.login()/logout() views. Add missing import for TextLexer. Adding examples and documentation for caching Include date and date-time format for schema generation Use triple backticks for markdown code blocks Interactive docs - make bottom sidebar items sticky Clarify pagination system check Stop JSONBoundField mangling invalid JSON Have JSONField render as textarea in Browsable API Schema: Exclude OPTIONS/HEAD for ViewSet actions Fix ordering for dotted sources Fix: Fields with allow_null=True should imply a default serialization value Ensure Location header is strictly a 'str', not subclass. Add import to example in api-guide/parsers Catch OverflowError for "out of range" datetimes Add djangorestframework-rapidjson to third party packages Increase test coverage for drf_create_token command Add trove classifier for Python 3.6 support. Add pip cache support to the Travis CI configuration Rename [wheel] section to [bdist_wheel] as the former is legacy Fix invalid escape sequence deprecation warnings Add interactive docs error template Add rounding parameter to DecimalField Fix all BytesWarning caught during tests Use dict and set literals instead of calls to dict() and set() Change ImageField validation pattern, use validators from DjangoImageField Fix processing unicode symbols in query_string by Python 2
Revision 1.16 / (download) - annotate - [select for diffs], Tue Oct 17 06:30:30 2017 UTC (6 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.15: +2 -2
lines
Diff to previous 1.15 (colored)
py-djangorestframework: update to 3.7.1 Version 3.7.1 Fix Interactive documentation always uses false for boolean fields in requests Improve compatibility with Django 2.0 alpha. Improved handling of schema naming collisions Added additional docs and tests around providing a default value for dotted source fields
Revision 1.15 / (download) - annotate - [select for diffs], Sun Oct 8 09:43:29 2017 UTC (6 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.14: +2 -2
lines
Diff to previous 1.14 (colored)
py-djangorestframework: update to 3.7.0 Django REST framework 3.7 The 3.7 release focuses on improvements to schema generation and the interactive API documentation.
Revision 1.14 / (download) - annotate - [select for diffs], Fri Aug 25 06:03:10 2017 UTC (6 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Changes since 1.13: +2 -2
lines
Diff to previous 1.13 (colored)
3.6.4 Ignore any invalidly formed query parameters for OrderingFilter. Improve memory footprint when reading large JSON requests. Fix schema generation for pagination. Fix exception when HTML_CUTOFF is set to None. Fix browsable API not supporting multipart/form-data correctly. Fixed test_hyperlinked_related_lookup_url_encoded_exists. Make sure max_length is in FileField kwargs. Fix list_route & detail_route with kwargs contains curly bracket in url_path Add Django manage command to create a DRF user Token. Ensure API documentation templates do not check for user authentication Fix special case where OneToOneField is also primary key. Added aria-label and a new region for accessibility purposes in base.html Quote nested API parameters in api.js. Set ViewSet args/kwargs/request before dispatch. Added unicode support to SlugField. Fix HiddenField appears in Raw Data form initial content. Raise validation error on invalid timezone parsing. Fix SearchFilter to-many behavior/performance. Simplified chained comparisons and minor code fixes. RemoteUserAuthentication, docs, and tests. Revert "Cached the field's root and context property" Fix introspection of list field in schema. Fix interactive docs for multiple nested and extra methods. Fix/remove undefined template var "schema"
Revision 1.13 / (download) - annotate - [select for diffs], Mon May 15 09:33:21 2017 UTC (6 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2
Changes since 1.12: +2 -2
lines
Diff to previous 1.12 (colored)
Changes 3.6.3: Bug fixes.
Revision 1.12 / (download) - annotate - [select for diffs], Sun Mar 12 18:52:48 2017 UTC (6 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.11: +2 -2
lines
Diff to previous 1.11 (colored)
The 3.6 release adds two major new features to REST framework. * Built-in interactive API documentation support. * A new JavaScript client library.
Revision 1.11 / (download) - annotate - [select for diffs], Mon Feb 13 21:52:17 2017 UTC (6 years, 9 months ago) by adam
Branch: MAIN
Changes since 1.10: +2 -3
lines
Diff to previous 1.10 (colored)
Changes 3.5.4: The 3.5 release is the second in a planned series that is addressing schema generation, hypermedia support, API client libraries, and finally realtime support.
Revision 1.10 / (download) - annotate - [select for diffs], Sun Jan 1 14:44:04 2017 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
Add python-3.6 to incompatible versions.
Revision 1.9 / (download) - annotate - [select for diffs], Sat Jul 9 13:04:14 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3
Changes since 1.8: +2 -2
lines
Diff to previous 1.8 (colored)
Remove python33: adapt all packages that refer to it.
Revision 1.8 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:45 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Changes since 1.7: +2 -2
lines
Diff to previous 1.7 (colored)
Switch to MASTER_SITES_PYPI.
Revision 1.7 / (download) - annotate - [select for diffs], Sat Dec 5 21:26:05 2015 UTC (7 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.6: +2 -2
lines
Diff to previous 1.6 (colored)
Extend PYTHON_VERSIONS_INCOMPATIBLE to 35
Revision 1.6 / (download) - annotate - [select for diffs], Wed Dec 31 13:57:32 2014 UTC (8 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1
Changes since 1.5: +1 -2
lines
Diff to previous 1.5 (colored)
Improve EGG_NAME default to work for packages with '-' in their name. Remove now unnecessary overrides in various packages.
Revision 1.5 / (download) - annotate - [select for diffs], Fri May 9 07:37:25 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2
Changes since 1.4: +2 -2
lines
Diff to previous 1.4 (colored)
Mark packages that are not ready for python-3.3 also not ready for 3.4, until proven otherwise.
Revision 1.4 / (download) - annotate - [select for diffs], Sat Jan 25 10:30:28 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base,
pkgsrc-2014Q1
Changes since 1.3: +4 -3
lines
Diff to previous 1.3 (colored)
Mark packages as not ready for python-3.x where applicable; either because they themselves are not ready or because a dependency isn't. This is annotated by PYTHON_VERSIONS_INCOMPATIBLE= 33 # not yet ported as of x.y.z or PYTHON_VERSIONS_INCOMPATIBLE= 33 # py-foo, py-bar respectively, please use the same style for other packages, and check during updates. Use versioned_dependencies.mk where applicable. Use REPLACE_PYTHON instead of handcoded alternatives, where applicable. Reorder Makefile sections into standard order, where applicable. Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default with the next commit. Whitespace cleanups and other nits corrected, where necessary.
Revision 1.3 / (download) - annotate - [select for diffs], Sun Oct 28 06:31:00 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1,
pkgsrc-2012Q4-base,
pkgsrc-2012Q4
Changes since 1.2: +1 -3
lines
Diff to previous 1.2 (colored)
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Revision 1.2 / (download) - annotate - [select for diffs], Sun Apr 8 19:09:16 2012 UTC (11 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2
Changes since 1.1: +1 -3
lines
Diff to previous 1.1 (colored)
Remove python24 and all traces of it from pkgsrc. Remove devel/py-ctypes (only needed by and supporting python24). Remove PYTHON_VERSIONS_ACCEPTED and PYTHON_VERSIONS_INCOMPATIBLE lines that just mirror defaults now. Miscellaneous cleanup while editing all these files.
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Mon Sep 12 08:21:29 2011 UTC (12 years, 2 months ago) by adam
Branch: TNF
CVS Tags: pkgsrc-base,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1,
pkgsrc-2011Q4-base,
pkgsrc-2011Q4,
pkgsrc-2011Q3-base,
pkgsrc-2011Q3
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
Django REST framework is a lightweight REST framework for Django, that aims to make it easy to build well-connected, self-describing RESTful Web APIs. Features: * Automatically provides an awesome Django admin style browse-able self-documenting API. * Clean, simple, views for Resources, using Django's new class based views. * Support for ModelResources with out-of-the-box default implementations and input validation. * Pluggable parsers, renderers, authentication and permissions - Easy to customise. * Content type negotiation using HTTP Accept headers. * Optional support for forms as input validation. * Modular architecture - MixIn classes can be used without requiring the Resource or ModelResource classes.
Revision 1.1 / (download) - annotate - [select for diffs], Mon Sep 12 08:21:29 2011 UTC (12 years, 2 months ago) by adam
Branch: MAIN
Initial revision