[BACK]Return to patch-setup.py CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / py-djangocms-googlemap / patches

File: [cvs.NetBSD.org] / pkgsrc / www / py-djangocms-googlemap / patches / patch-setup.py (download)

Revision 1.1, Tue Nov 20 18:44:03 2018 UTC (8 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, HEAD

py-djangocms-googlemap: updated to 1.2.0

1.2.0:
Fixed an issue with map not always setting correct zoom level
Removed admin url data attribute from the map marker if cms isn't in edit mode
Added support for Django 1.11, 2.0 and 2.1
Removed support for Django 1.8, 1.9, 1.10
Adapted testing infrastructure (tox/travis) to incorporate django CMS 3.5 and 4.0

1.1.1:
Refactored migration 0005 to avoid using the django CMS api because it can lead to database errors when the models on file don't match the ones in the migration.
Moved Google Apps API Key to an environment variable on Divio Cloud

1.1.0:
Added support for customize marker icon
Updated translations

1.0.2:
Fixed an issue where 0005 migration mismatches lat/lng values when creating the new nested structure from older upgrades
Updated translations

1.0.1:
Prevent changes to DJANGOCMS_GOOGLEMAP_XXX settings from requiring new migrations
Changed naming of Aldryn to Divio Cloud
Adapted testing infrastructure (tox/travis) to incorporate django CMS 3.4 and dropped 3.2
Fixed zoom level not correctly being applied
Fixed latitude/longitude data attribute values being incorrectly parsed for locales not using a period as decimal separator (e.g. german)

$NetBSD: patch-setup.py,v 1.1 2018/11/20 18:44:03 adam Exp $

Do not install tests.

--- setup.py.orig	2018-11-20 18:13:56.000000000 +0000
+++ setup.py
@@ -40,7 +40,7 @@ setup(
     license='BSD',
     description='Adds Google Maps plugins to django CMS.',
     long_description=open('README.rst').read(),
-    packages=find_packages(),
+    packages=find_packages(exclude=['tests']),
     include_package_data=True,
     zip_safe=False,
     install_requires=REQUIREMENTS,