The NetBSD Project

CVS log for pkgsrc/www/py-django-taggit/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-django-taggit

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Oct 29 05:41:02 2024 UTC (4 days, 13 hours ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -7 lines
py-django-taggit: updated to 6.1.0

6.1.0 (2024-09-29)

* Add a management command (``remove_orphaned_tags``) to remove orphaned tags
* Add a fallback for when multiple tags are found in case-insensitivity mode (the earliest by PK is returned)
* Add a ``deduplicate_tags`` management command to remove duplicate tags based on case insensitivity. This feature is enabled when ``TAGGIT_CASE_INSENSITIVE`` is set to ``True`` in the settings.
* We no longer package tests, docs, or the sample taggit app into the distributed wheels. While we believe this shouldn't affect anything for users of the library, please tell us if you find yourself hitting issues (like around import errors)
* Fix missing template file for admin merge tag action

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Sep 16 19:33:01 2024 UTC (6 weeks, 4 days ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +3 -5 lines
py-django-taggit: updated to 6.0.0

6.0.0 (2024-07-27)

* By default, order tag items on instances by the primary key. This generally means that they will be ordered by "creation date" for the tag item.
  The previous behavior for this was that by default tag items were not ordered. In practice tag items often end up ordered by creation date anyways, just due to how databases work, but this was not a guarantee.
  If you wish to have the old behavior, set ``ordering=[]`` to your ``TaggableManager`` instance.
  We believe that this should not cause a noticable performance change, and the number of queries involved should not change.
* Added the ability to merge tags via the admin
* Add Django 5.0 support (no code changes were needed, but now we test this release).
* Add Python 3.12 support
* Add support for dumpdata/loaddata using natural keys

Revision 1.8: download - view: text, markup, annotated - select for diffs
Fri Feb 9 12:40:04 2024 UTC (8 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +7 -5 lines
py-django-taggit: updated to 5.0.1

5.0.1 (2023-10-26)
~~~~~~~~~~~~~~~~~~

* Fix the package metadata to properly reflect the right Django and Python version requirements
  Release 5.0.0 improperly stated its Django bounds as >=3.2, so people installing without bounds will end up on a version that won't work.

5.0.0 (2023-10-24)
~~~~~~~~~~~~~~~~~~
* **Backwards icompatible:** Rename the (``content_type``, ``object_id``) index on ``TaggedItem``.
  It is very unlikely for this to affect your code itself, and a migration will rename the index. This should not cause any downtime according to my research (Postgres does not lock the table for index renames, and Oracle holds a tiny lock to do it, and the change is only to the metadata, so is not dependent on table size).

* **Backwards incompatible:** Remove the ``.indexed_together`` and ``.unique_together`` attributes on ``TaggedItem``

  We are instead using ``constraints`` and ``indexes`` to set up these properties.
* Remove support for Django 3.2.
* Remove usage of deprecated APIs for Django 4.2
* Remove support for Python 3.7 (no code changes involved)
* Fix ``tag_kwargs`` and ``TAGGIT_CASE_INSENSITIVE=True`` discrepency.

4.0.0 (2023-05-04)
~~~~~~~~~~~~~~~~~~
* Remove Python 3.6 support (no code changes occurred, but we no longer test this release).
* Remove Django 4.0 support (no code changes occurred, but we no longer test this release).
* Add Django 4.2 support.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Apr 10 20:03:15 2023 UTC (18 months, 3 weeks ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +5 -5 lines
Update py-django-taggit to 3.1.0:

- Backwards incompatible: Tag slugification used to silently strip
  non-ASCII characters from the tag name to make the slug. This leads
  to a lot of confusion for anyone using languages with non-latin
  alphabets, as well as weird performance issues.
- Backwards incompatible: TaggableManager.set now takes a list of tags
  (instead of varargs) so that its API matches Django's
  RelatedManager.set. Example:
        previously: item.tags.set("red", "blue")
        now: item.tags.set(["red", "blue"])
- Fix issue where TagField would incorrectly report that a field has changed on empty values.
- Update Russian translation.
- Add Persian translation
- Fix issue for many languages where content types were not being properly translated.
- Provide translators additional context regarding strings in TagBase model.
- Fix compiled Ukranian translation (which would cause a failure on load for this locale).
- Update compiled Danish translation.
- Vendor in the django-taggit-serializer project (under taggit.serializers).
- Add Arabic translation.
- Add Ukranian translation.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:55:21 2022 UTC (2 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu May 27 09:51:25 2021 UTC (3 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -2 lines
py-django-taggit: mark as not compatible with Python 2.7

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue May 25 05:01:46 2021 UTC (3 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
py-django-taggit: point to py-django2 in DEPENDS

Revision 1.3: download - view: text, markup, annotated - select for diffs
Tue May 25 04:55:46 2021 UTC (3 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -8 lines
py-django-taggit: updated to 1.4.0

1.4.0

* Add Python 3.9 support.
* Remove Python 3.5 support.
* Add Django 3.2 support.
* Remove Django 1.11 and 3.0 support.
* Add Danish translation.
* Fix crashing that could occur with ``similar_objects`` in multi-inheritance contexts.
* Add support for custom fields on through table models with `through_defaults` for ``TaggedManager.add`` and ``TaggedManager.set``.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Aug 4 00:29:03 2020 UTC (4 years, 3 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +5 -1 lines
Hook up proper testing

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Aug 4 00:10:11 2020 UTC (4 years, 3 months ago) by joerg
Branches: MAIN
Add py37-django-taggit-1.3.0:

A simple, generic tagging application for Django projects.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>