The NetBSD Project

CVS log for pkgsrc/www/py-django-reversion/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-django-reversion

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.30 / (download) - annotate - [select for diffs], Thu Nov 9 06:49:49 2023 UTC (3 weeks, 3 days ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

py-django-reversion: updated to 5.0.8

5.0.8 - 2023-11-08
- Fix ``get_deleted``

5.0.7 - 2023-11-07
- Speed up ``get_deleted``

Revision 1.29 / (download) - annotate - [select for diffs], Tue Oct 10 17:05:00 2023 UTC (7 weeks, 5 days ago) by adam
Branch: MAIN
Changes since 1.28: +4 -5 lines
Diff to previous 1.28 (colored)

py-django-reversion: updated to 5.0.6

5.0.6 - 2023-09-29

- Fix handling case of missing object in admin revert (@julianklotz)


5.0.5 - 2023-09-19

- Handling case of missing object in admin revert (@etianen, @PavelPancocha)
- CI improvements (@etianen, @browniebroke)


5.0.4 - 2022-11-12

- Fix warning log formatting for failed reverts (@tony).


5.0.3 - 2022-10-02

- A revision will no longer be created if a transaction is marked as rollback, as this would otherwise cause an
  additional database error (@proofit404).
- A warning log is now emitted if a revert fails due to database integrity errors, making debugging the final
  ``RevertError`` easier.


5.0.2 - 2022-08-06

- Fixed doc builds on readthedocs (@etianen).


5.0.1 - 2022-06-18

- Fix admin detail view in multi-database configuration (@atten).


5.0.0 - 2022-02-20

- Added support for using django-reversion contexts in ``asyncio`` tasks (@bellini666).
- **Breaking:** Dropped support for Python 3.6.

Revision 1.28 / (download) - annotate - [select for diffs], Thu Jul 13 10:03:29 2023 UTC (4 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Changes since 1.27: +3 -3 lines
Diff to previous 1.27 (colored)

*: switch django users to py-django3

Revision 1.27 / (download) - annotate - [select for diffs], Tue Jan 4 20:55:21 2022 UTC (22 months, 4 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.26: +2 -1 lines
Diff to previous 1.26 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.26 / (download) - annotate - [select for diffs], Fri Feb 5 07:56:46 2021 UTC (2 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.25: +2 -2 lines
Diff to previous 1.25 (colored)

py-django-reversion: updated to 3.0.9

3.0.9:
- Significant speedup to ``Version.objects.get_deleted(...)`` database query for PostgreSQL.
- Testing against Django 3.1.
- Django 4.0 compatibility improvements.

Revision 1.25 / (download) - annotate - [select for diffs], Fri Oct 2 19:23:35 2020 UTC (3 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

py-django-reversion: updated to 3.0.8

3.0.8:
- Added ``use_natural_foreign_keys`` option to ``reversion.register()``.
- Documentation improvments and minor fixes.
- Dropped support for Django 1.11 LTS.

Revision 1.24 / (download) - annotate - [select for diffs], Wed Jun 3 15:27:44 2020 UTC (3 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.23: +5 -4 lines
Diff to previous 1.23 (colored)

py-django-reversion: updated to 3.0.7

3.0.7:
- Removing deprecated usages of `ugettest_lazy`
- Slovenian translation

3.0.6:
- Packaging improvements
- Removing deprecated usages of `force_text`
- Documentation fixes

3.0.5:
- Improved performance of `get_deleted` for large datasets
- Django 3.0 compatibility
- Drops Django < 1.11 compatibility
- Fixed errors in manageement commands when `django.contrib.admin` is not in `INSTALLED_APPS`

3.0.4:
- Remove `django.contrib.admin` dependency from django-reversion.
- README refactor
- Testing against Django 2.2

3.0.3:
- Improved performance of many reversion database queries using `EXISTS` subquery
- Added support for Django 2.1 `view` permission

3.0.2:
- Removed squashed migrations, as they subtly messed up the Django migrations framework

3.0.1:
- Added squashed migrations back in to allow older installations to upgrade.
- Fixed TypeError exception when accessing m2m_data attribute from a field that points to DjangoãàÑÔ User model

3.0.0:
- **Breaking:** ``Revision.commment`` now contains the raw JSON change message generated by django admin, rather than
  a string. Accesing ``Revision.comment`` directly is no longer recommended. Instead, use ``Revision.get_comment()``.

- **BREAKING:** django-reversion now uses ``_base_manager`` to calculate deleted models, not ``_default_manager``. This
  change will only affect models that perform default filtering in their ``_default_manager``
- Added ``request_creates_revision`` hook to ``RevisionMiddleware`` and ``views.create_revision``.
- Added ``revision_request_creates_revision`` hook to ``views.RevisionMixinView``.
- Added ``--meta`` flag to ``./manage.py createrevisions``
- Fixed bug when reverting deleted nested inlines
- Added tests for django 2.1

Revision 1.23 / (download) - annotate - [select for diffs], Sun May 31 20:45:17 2020 UTC (3 years, 6 months ago) by joerg
Branch: MAIN
Changes since 1.22: +3 -3 lines
Diff to previous 1.22 (colored)

Doesn't support django3.

Revision 1.22 / (download) - annotate - [select for diffs], Wed Apr 15 22:37:54 2020 UTC (3 years, 7 months ago) by joerg
Branch: MAIN
Changes since 1.21: +2 -1 lines
Diff to previous 1.21 (colored)

Needs py-six

Revision 1.21 / (download) - annotate - [select for diffs], Fri Feb 2 08:08:10 2018 UTC (5 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

py-django-reversion: updated to 2.0.13

2.0.13:
Improve performance of get_deleted() for Oracle
Minor tweaks

Revision 1.20 / (download) - annotate - [select for diffs], Sun Dec 10 08:56:29 2017 UTC (5 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.19: +3 -3 lines
Diff to previous 1.19 (colored)

py-django-reversion: updated to 2.0.12

2.0.12:
Fixed MySQL error in get_deleted()

2.0.11:
Dramatically improved performance of get_deleted() over large datasets
Ukranian translation
Bugfixes

Revision 1.19 / (download) - annotate - [select for diffs], Mon Aug 21 11:39:46 2017 UTC (6 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.18: +4 -4 lines
Diff to previous 1.18 (colored)

2.0.10:
- Bugfix: Handling case of `None` user in request (@pawelad).
- Documentation corrections (@danielquinn).
- Bugfix: "invalid literal for int() with base 10: 'None'" for unversioned admin inline relations.

  If, after updating, you still experience this issue, run the following in a Django shell:

  .. code::

      from reversion.models import Version
      Version.objects.filter(object_id="None").delete()

  **Important:** Ensure that none of your versioned models contain a string primary key where `"None"` is a valid value
  before running this snippet!

Revision 1.18 / (download) - annotate - [select for diffs], Tue Jun 20 07:28:39 2017 UTC (6 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

2.0.9:
Bugfix: Deleted inline admin instances no longer added to revision.
Bugfix: M2M relations correctly added to revision
Improved performance of 0003 migration
Documentation improvements
Django 1.11 support
Added atomic=True parameter to create_revision

Revision 1.17 / (download) - annotate - [select for diffs], Thu Feb 2 07:30:21 2017 UTC (6 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Changes 2.0.8:
- Setting ``revision.user`` in ``process_response`` for middleware (@etianen).
- Fixing localization of model primary keys in `recover_list.html` (@w4rri0r3k).
- Documentation tweaks

Revision 1.16 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:45 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.15 / (download) - annotate - [select for diffs], Wed Apr 20 17:33:57 2016 UTC (7 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Changes 1.10.2:
- Fixing deprecation warnings
- Minor tweaks and bug fixes

Revision 1.14 / (download) - annotate - [select for diffs], Sun Mar 6 14:19:55 2016 UTC (7 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Changes 1.10.0:
- Django 1.9 compatibility
- Added spanish (argentina) translation
- Minor bugfixes and tweaks

Revision 1.13 / (download) - annotate - [select for diffs], Fri Nov 13 19:56:16 2015 UTC (8 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.12: +3 -4 lines
Diff to previous 1.12 (colored)

Changes 1.9.3:
- Fixing regression with admin redirects following save action

Revision 1.12 / (download) - annotate - [select for diffs], Fri Jul 17 15:27:14 2015 UTC (8 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Changes 1.8.7:
- Fixing deleterevisions command on Python 3.
- Fixing Django 1.6 compatibility.
- Removing some Django 1.9 deprecation warnings.
- Minor tweaks.

Revision 1.11 / (download) - annotate - [select for diffs], Fri Apr 17 15:14:15 2015 UTC (8 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Changes 1.8.6:
- Support for MySQL utf8mb4
- Fixing some Django deprecation warnings
- Versions passed through by reversion.post_revision_commit now contain a primary key

Revision 1.10 / (download) - annotate - [select for diffs], Sun Nov 23 13:11:25 2014 UTC (9 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Changes 1.8.5:
* Added support for proxy models
* Allowing registration of models with django-reversion using custom signals
* Fixing some Django deprecation warnings

Revision 1.9 / (download) - annotate - [select for diffs], Thu Oct 9 10:09:22 2014 UTC (9 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.8: +2 -3 lines
Diff to previous 1.8 (colored)

Changes 1.8.4:
- Provisional Django 1.7 support
- Multi-db and multi-manager support to management commands
- Added index on reversion.date_created
- Minor bugfixes and documentation improvements

Revision 1.8 / (download) - annotate - [select for diffs], Sun Aug 24 07:28:18 2014 UTC (9 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Changes 1.8.2:
- reversion.register() can now be used as a class decorator
- Danish translation
- Improvements to Travis CI integration
- Simplified Chinese translation
- Minor bugfixes and documentation improvement

Revision 1.7 / (download) - annotate - [select for diffs], Mon Jun 9 10:15:44 2014 UTC (9 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Changes 1.8.1:
- Slovak translation (@jbub).
- Deleting a user no longer deletes the associated revisions (@daaray).
- Improving handling of inline models in admin integration (@blueyed).
- Improving error messages for proxy model registration (@blueyed).
- Improvements to using migrations with custom user model (@aivins).
- Removing sys.exit() in deleterevisions management command, allowing it to be used internally by Django projects (@tongwang).
- Fixing some backwards-compatible admin deprecation warnings (Thomas Schreiber).
- Fixing tests if RevisionMiddleware is used as a decorator in the parent project (@jmoldow).
- Derived models, such as those generated by deferred querysets, now work.
- Removed deprecated low-level API methods.

Revision 1.6 / (download) - annotate - [select for diffs], Sun Feb 9 08:20:00 2014 UTC (9 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Changes 1.8.0:
- Django 1.6 compatibility
- Using bulk_create to speed up revision creation.
- Including docs in source distribution
- Spanish translation
- Fixing edge-case bugs in revision middleware

Revision 1.5 / (download) - annotate - [select for diffs], Fri Aug 9 07:35:03 2013 UTC (10 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Changes 1.7.1:
* Bugfixes when using a custom User model.
* Minor bugfixes.

Revision 1.4 / (download) - annotate - [select for diffs], Wed Mar 13 07:25:42 2013 UTC (10 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Changes 1.7:
* Django 1.5 compatibility.
* Experimantal Python 3.3 compatibility!

Revision 1.3 / (download) - annotate - [select for diffs], Sun Nov 25 08:46:23 2012 UTC (11 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Changes 1.6.4:
Bug fixes.

Revision 1.2 / (download) - annotate - [select for diffs], Sun Oct 28 06:31:00 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
Changes since 1.1: +1 -3 lines
Diff to previous 1.1 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Aug 26 13:32:17 2012 UTC (11 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3

django-reversion is an extension to the Django web framework that provides
comprehensive version control facilities.

Features
* Roll back to any point in a model's history - an unlimited undo facility!
* Recover deleted models - never lose data again!
* Admin integration for maximum usability.
* Group related changes into revisions that can be rolled back in a single
  transaction.
* Automatically save a new version whenever your model changes using Django's
  flexible signalling framework.
* Automate your revision management with easy-to-use middleware.

django-reversion can be easily added to your existing Django project with
an absolute minimum of code changes.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>