Up to [cvs.NetBSD.org] / pkgsrc / www / py-django-polymorphic
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.9 / (download) - annotate - [select for diffs], Wed Aug 30 14:36:56 2023 UTC (2 months, 4 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
HEAD
Changes since 1.8: +2 -3
lines
Diff to previous 1.8 (colored)
py-django-polymorphic: updated to 3.1.0 3.1.0 Added support for Django 4.0. Fixed crash when the admin "add type" view has no choices; will show a permission denied. Fixed missing locale folder in sdist. Fixed missing QuerySet.bulk_create(.., ignore_conflicts=True) parameter support. Fixed FilteredRelation support. Fixed supporting class keyword arguments in model definitions for __init_subclass__(). Fixed including polymorphic.tests.migrations in the sdist. Fixed non-polymorphic parent handling, which has no _base_objects. Fixed missing widgets support for modelform_factory(). Fixed has_changed handling for polymorphic_ctype_id due to implicit str to int conversions. Fixed Q object handling when lists are used (e.g. in django-advanced-filters). Fixed Django Admin support when using a script-prefix.
Revision 1.8 / (download) - annotate - [select for diffs], Thu Jul 13 10:03:28 2023 UTC (4 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.7: +3 -3
lines
Diff to previous 1.7 (colored)
*: switch django users to py-django3
Revision 1.7 / (download) - annotate - [select for diffs], Tue Jan 4 20:55:20 2022 UTC (22 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.6: +2 -1
lines
Diff to previous 1.6 (colored)
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
Revision 1.6 / (download) - annotate - [select for diffs], Sat Jan 16 09:27:05 2021 UTC (2 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.5: +5 -3
lines
Diff to previous 1.5 (colored)
py-django-polymorphic: updated to 3.0.0 Changes in 3.0.0 Support for Django 3.X Dropped support for python 2.X A lot of various fixes and improvements by various authors. Thanks a lot!
Revision 1.5 / (download) - annotate - [select for diffs], Fri Jun 19 11:55:27 2020 UTC (3 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.4: +2 -2
lines
Diff to previous 1.4 (colored)
py-django-polymorphic: updated to 2.1.2 2.1.2: Fix admin 2.1.1: Fix import 2.1: Django 2.2 support
Revision 1.4 / (download) - annotate - [select for diffs], Sun Oct 7 07:13:14 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
py-django-polymorphic: updated to 2.0.3 Changes in 2.0.3: * Fixed admin crash for Django 2.1 with missing use_required_attribute.
Revision 1.3 / (download) - annotate - [select for diffs], Mon Feb 26 17:16:52 2018 UTC (5 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1
Changes since 1.2: +6 -6
lines
Diff to previous 1.2 (colored)
py-django-polymorphic: updated to 2.0.2 Changes in 2.0.2: Fixed manager inheritance behavior for Django 1.11, by automatically enabling Meta.manager_inheritance_from_future if it's not defined. This restores the manager inheritance behavior that django-polymorphic 1.3 provided for Django 1.x projects. Fixed internal base_objects usage. Changes in 2.0.1: Fixed manager inheritance detection for Django 1.11. It's recommended to use Meta.manager_inheritance_from_future so Django 1.x code also inherit the PolymorphicManager in all subclasses. Django 2.0 already does this by default. Deprecated the base_objects manager. Use objects.non_polymorphic() instead. Optimized detection for dumpdata behavior, avoiding the performance hit of __getattribute__(). Fixed test management commands Changes in 2.0: BACKWARDS INCOMPATIBILITY: Dropped Django 1.8 and 1.10 support. BACKWARDS INCOMPATIBILITY: Removed old deprecated code from 1.0, thus: Import managers from polymorphic.managers (plural), not polymorphic.manager. Register child models to the admin as well using @admin.register() or admin.site.register(), as this is no longer done automatically. Added Django 2.0 support. Added PolymorphicTypeUndefined exception for incomplete imported models. When a data migration or import creates an polymorphic model, the polymorphic_ctype_id field should be filled in manually too. The polymorphic.utils.reset_polymorphic_ctype function can be used for that. Added PolymorphicTypeInvalid exception when database was incorrectly imported. Added polymorphic.utils.get_base_polymorphic_model() to find the base model for types. Using base_model on the polymorphic admins is no longer required, as this can be autodetected. Fixed manager errors for swappable models. Fixed deleteText of |as_script_options template filter. Fixed .filter(applabel__ModelName___field=...) lookups. Improved polymorphic.utils.reset_polymorphic_ctype() to accept models in random ordering. Fix fieldsets handling in the admin (declared_fieldsets is removed since Django 1.9)
Revision 1.2 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:49 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Changes since 1.1: +2 -2
lines
Diff to previous 1.1 (colored)
Switch to MASTER_SITES_PYPI.
Revision 1.1 / (download) - annotate - [select for diffs], Wed Apr 20 20:01:14 2016 UTC (7 years, 7 months ago) by adam
Branch: MAIN
Django-polymorphic simplifies using inherited models in Django projects. When a query is made at the base model, the inherited model classes are returned.