Up to [cvs.NetBSD.org] / pkgsrc / www / py-daphne
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
py-*: remove unused tool dependency py-setuptools includes the py-wheel functionality nowadays
py-daphne: remove unused test dependency Update test status.
py-daphne: updated to 4.1.2 4.1.2 (2024-04-11) * Fixed a setuptools configuration error in 4.1.1.
py-daphne: updated to 4.1.1 4.1.1 (2024-04-10) * Fixed a twisted.plugin packaging error in 4.1.0.
py-daphne: updated to 4.1.0 4.1.0 (2024-02-10) ------------------ * Added support for Python 3.12. * Dropped support for EOL Python 3.7. * Handled root path for websocket scopes. * Validate HTTP header names as per RFC 9110.
py-daphne: updated to 4.0.0 4.0.0 (2022-10-07) ------------------ Major versioning targeting use with Channels 4.0 and beyond. Except where noted should remain usable with Channels v3 projects, but updating Channels to the latest version is recommended. * Added a ``runserver`` command to run an ASGI Django development server. Added ``"daphne"`` to the ``INSTALLED_APPS`` setting, before ``"django.contrib.staticfiles"`` to enable: INSTALLED_APPS = [ "daphne", ... ] This replaces the Channels implementation of ``runserver``, which is removed in Channels 4.0. * Made the ``DaphneProcess`` tests helper class compatible with the ``spawn`` process start method, which is used on macOS and Windows. Note that requires Channels v4 if using with ``ChannelsLiveServerTestCase``. * Dropped support for Python 3.6. * Updated dependencies to the latest versions. Previously a range of Twisted versions have been supported. Recent Twisted releases (22.2, 22.4) have issued security fixes, so those are now the minimum supported version. Given the stability of Twisted, supporting a range of versions does not represent a good use of maintainer time. Going forward the latest Twisted version will be required. * Set ``daphne`` as default ``Server`` header. This can be configured with the ``--server-name`` CLI argument. Added the new ``--no-server-name`` CLI argument to disable the ``Server`` header, which is equivalent to ``--server-name=` (an empty name). * Added ``--log-fmt`` CLI argument. * Added support for ``ASGI_THREADS`` environment variable, setting the maximum number of workers used by a ``SyncToAsync`` thread-pool executor. Set e.g. ``ASGI_THREADS=4 daphne ...`` when running to limit the number of workers. * Removed deprecated ``--ws_protocols`` CLI option.
Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/. Almost all uses, if not all of them, are wrong, according to the semantics of BUILD_DEPENDS (packages built for target available for use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for host available for use _as_ tools at build-time). No change to BUILD_DEPENDS as used correctly inside buildlink3. As proposed on tech-pkg: https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html
python: egg.mk: add USE_PKG_RESOURCES flag This flag should be set for packages that import pkg_resources and thus need setuptools after the build step. Set this flag for packages that need it and bump PKGREVISION.
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
py-daphne: updated to 3.0.2 3.0.2 (2021-04-07) ------------------ * Fixed a bug where ``send`` passed to applications wasn't a true async function but a lambda wrapper, preventing it from being used with ``asgiref.sync.async_to_sync()``.
py-daphne: updated to 3.0.1 3.0.1 (2020-11-12) * Fixed a bug where ``asyncio.CancelledError`` was not correctly handled on Python 3.8+, resulting in incorrect protocol application cleanup. 3.0.0 (2020-10-28) * Updates internals to use ASGI v3 throughout. ``asgiref.compatibility`` is used for older applications. * Consequently, the `--asgi-protocol` command-line option is removed. * HTTP request bodies are now read, and passed to the application, in chunks. * Added support for Python 3.9. * Dropped support for Python 3.5.
py-daphne: updated to 2.5.0 2.5.0: * Fixes compatability for twisted when running Python 3.8+ on Windows, by setting ``asyncio.WindowsSelectorEventLoopPolicy`` as the event loop policy in this case. * The internal ``daphne.testing.TestApplication`` now requires an addition ``lock`` argument to ``__init__()``. This is expected to be an instance of ``multiprocessing.Lock``.
py-daphne: updated to 2.4.1 2.4.1: * Avoids Twisted using the default event loop, for compatibility with Django 3.0's ``async_unsafe()`` decorator in threaded contexts, such as using the auto-reloader.
py-daphne: updated to 2.4.0 2.4.0: * Adds CI testing against and support for Python 3.8. * Adds support for ``raw_path`` in ASGI scope. * Ensures an error response is sent to the client if the application sends malformed headers. * Resolves an asyncio + multiprocessing problem when testing that would cause the test suite to fail/hang on macOS. * Requires installing Twisted's TLS extras, via ``install_requires``. * Adds missing LICENSE to distribution.
py-daphne: updated to 2.3.0 2.3.0: * Added support for ASGI v3.
Omit mentions of python 34 and 35, after those were removed. - Includes some whitespace changes, to be handled in a separate commit.
py-daphne: updated to 2.2.5 2.2.5: * WebSocket handshakes are now affected by the websocket connect timeout, so you can limit them from the command line. * Server name can now be set using --server-name
py-daphne: updated to 2.2.4 2.2.4: * No longer listens on port 8000 when a file descriptor is provided with --fixed * Fixed a memory leak with WebSockets
py-daphne: updated to 2.2.3 2.2.3: * Enforce that response headers are only bytestrings, rather than allowing unicode strings and coercing them into bytes. * New command-line options to set proxy header names: --proxy-headers-host and --proxy-headers-port.
py-daphne: updated to 2.2.2 2.2.2: * X-Forwarded-Proto support is now present and enabled if you turn on the --proxy-headers flag * ASGI applications are no longer instantiated in a thread (the ASGI spec was finalised to say all constructors must be non-blocking on the main thread) 2.2.1: * Python 3.7 compatability is flagged and ensured by using Twisted 18.7 and above as a dependency. * The send() awaitable in applications no longer blocks if the connection is closed. * Fixed a race condition where applications would be cleaned up before they had even started.
py-daphne: updated to 2.2.0 2.2.0: * HTTP timeouts have been removed by default, as they were only needed with ASGI/Channels 1. You can re-enable them with the --http-timeout argument to Daphne. * Occasional errors on application timeout for non-fully-opened sockets and for trying to read closed requests under high load are fixed. * X-Forwarded-For headers are now correctly decoded in all environments and no longer have unicode matching issues.
py-daphne: updated to 2.1.1 2.1.1: * ASGI application constructors are now run in a threadpool as they might contain blocking synchronous code.
Simplify
Needs py-test-runner.
py-daphne: updated to 2.1.0 2.1.0: * Removed subprotocol support from server, as it never really worked. Subprotocols can instead be negotiated by ASGI applications now. * Non-ASCII query strings now raise a 400 Bad Request error rather than silently breaking the logger
py-daphne: updated to 2.0.4 2.0.4: * Ping timeouts no longer reset on outgoing data, only incoming data * No more errors when connections close prematurely
py-daphne: updated to 2.0.3 2.0.3: * Unix socket listening no longer errors during startup (introduced in 2.0.2) * ASGI Applications are now not immediately killed on disconnection but instead given --application-close-timeout seconds to exit (defaults to 10) 2.0.2: * WebSockets are no longer closed after the duration of http_timeout 2.0.1: * Updated logging to correctly route exceptions through the main Daphne logger 2.0.0: * Major rewrite to the new async-based ASGI specification and to support Channels 2. Not backwards compatible.
py-daphne: updated to 1.4.2 1.4.2: * Bugfix for WebSocket protocol when X-Forwarded-For is turned on. 1.4.1: * Bugfix for a bad merge of HTTPFactory for X-Forwarded-Proto causing Daphne to not start. 1.4.0: * The X-Forwarded-Proto header can now be used to pass along protocol from a reverse proxy. * WebSocket headers are now correctly always passed as bytestrings.
Restrict Python support as py-asgiref doesn't support 2.7 and 3.4.
Switch github HOMEPAGEs to https.
Daphne is a HTTP, HTTP2 and WebSocket protocol server for ASGI, and developed to power Django Channels. It supports automatic negotiation of protocols; there's no need for URL prefixing to determine WebSocket endpoints versus HTTP endpoints.