Up to [cvs.NetBSD.org] / pkgsrc / www / py-channels
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
py-channels: updated to 4.2.0 4.2.0 (2024-11-15) Channels 4.2 introduces a couple of major but backwards-compatible changes, including most notably enhanced async suppport and fixing a long-standing bug where tests would try and close db connections and erroneously fail. There are a number of other small bugfixes.
py-*: remove unused tool dependency py-setuptools includes the py-wheel functionality nowadays
py-channels: updated to 4.1.0 Channels 4.1 is maintenance release in the 4.x series. The main change is an update in the required Python and Django version. Python 3.8, and Django 4.2 are now the minimum required versions. There are a number of other small bugfixes.
py-channels: updated to 4.0.0 4.0.0 (2022-10-15) ------------------ Channels 4 is the next major version of the Channels package. Together with the matching Daphne v4 and channels-redis v4 releases, it updates dependencies, fixes issues, and removes outdated code. It so provides the foundation for Channels development going forward. In most cases, you can update now by updating ``channels``, ``daphne``, and ``channels-redis`` as appropriate, with ``pip``, and by adding ``daphne`` at the top of your ``INSTALLED_APPS`` setting. First ``pip``:: pip install -U 'channels[daphne]' channels-redis Then in your Django settings file:: INSTALLED_APPS = [ "daphne", ... ] Again, this is a major version change. Amongst other changes, large amounts of the Django-wrapping code deprecated in Channels v3 has now been removed, in favour of Django's own ASGI handling, and the ``runserver`` command has been moved into the Daphne package.
*: switch django users to py-django3
py-channels: updated to 3.0.5 3.0.5 Bugfixes & Small Changes Removed use of providing_args keyword argument to consumer started signal, as support for this was removed in Django 4.0. Backwards Incompatible Changes Drops support for end-of-life Python 3.6 and Django 3.0 and 3.1.
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
py-channels: updated to 3.0.4 Channels 3.0.4 is a bugfix release in the 3.0 series.
py-channels: updated to 3.0.3 3.0.3 (2020-12-28) ------------------ * Fixed a bug in Channels 3.0 where the legacy ``channels.http.AsgiHandler`` would not correctly isolate per-request scopes. This is a security release for CVE-2020-35681. Please see the `Version 3.0.3 release notes <https://channels.readthedocs.io/en/latest/releases/3.0.3.html>`_ for full details. 3.0.2 (2020-11-9) ----------------- * Fixes a bug in Channels 3.0 where ``StaticFilesWrapper`` was not updated to the ASGI 3 single-callable interface. * Users of the ``runworker`` command should ensure to update ``asgiref`` to version 3.3.1 or later. 3.0.1 (2020-11-4) ----------------- * Fixes a bug in Channels 3.0 where ``SessionMiddleware`` would not correctly isolate per-instance scopes. 3.0.0 (2020-10-30) ------------------ Updated to ASGI v3, and added support for Django 3.0+. This is a major version change requiring updates to consumers and middleware. Please see the full `Version 3.0.0 release notes <https://channels.readthedocs.io/en/latest/releases/3.0.0.html>`_ for details.
py-channels: updated to 2.4.0 2.4.0: * Wraps session save calls in ``database_sync_to_async()``, for compatibility with Django 3.0's ``async_unsafe()`` checks. * Drops compatibility with all Django versions lower than 2.2.
py-channels: updated to 2.3.1 2.3.1: * Adds compatibility with Python 3.8.
py-channels: updated to 2.3.0 2.3.0: * Adjusted ``AsgiHandler`` HTTP body handling to use a spooled temporary file, rather than reading the whole request body into memory. As a result, ``AsgiRequest.__init__()`` is adjusted to expect a file-like ``stream``, rather than the whole ``body`` as bytes. Test cases instantiating requests directly will likely need to be updated to wrap the provided body in, e.g., `io.BytesIO`.
py-channels: updated to 2.2.0 2.2.0: * Updated requirements for ASGI v3 and Daphne 2.3.
Omit mentions of python 34 and 35, after those were removed. - Includes some whitespace changes, to be handled in a separate commit.
py-channels: updated to 2.1.7 2.1.7: * HTTP request body size limit is now enforced * database_sync_to_async now closes old connections before it runs code * Auth middleware closes old connections before it runs
py-channels: updated to 2.1.6 2.1.6: * HttpCommunicator now extracts query strings correctly * AsyncHttpConsumer provides channel layer attributes * Prevent late-Daphne import errors
py-channels: updated to 2.1.5 2.1.5: * Django middleware caching now works on Django 1.11 and Django 2.0. The previous release only ran on 2.1. 2.1.4: * Django middleware is now cached rather than instantiated per request resulting in a sigificant speed improvement * ChannelServerLiveTestCase now serves static files again * Improved error message resulting from bad Origin headers * runserver logging now goes through the Django logging framework * Generic consumers can now have non-default channel layers * Improved error when accessing scope['user'] before it's ready
py-channels: updated to 2.1.3 2.1.3: * An ALLOWED_ORIGINS value of "*" will now also allow requests without a Host header at all (especially important for tests) * The request.path value is now correct in cases when a server has SCRIPT_NAME set * Errors that happen inside channel listeners inside a runworker or Worker class are now raised rather than suppressed
py-channels: updated to 2.1.2 2.1.2: * AsyncHttpConsumer now has a disconnect() method you can override * Session and authentication middleware is now non-blocking. * URL routing context now includes default arguments from the URLconf. * The FORCE_SCRIPT_NAME setting is now respected in ASGI mode. * ALLOWED_HOSTS is now set correctly during LiveServerTests.
py-channels: updated to 2.1.1 2.1.1: * The scope["user"] object is no longer a lazy object, as this conflicts with any async-based consumers.
py-channels: updated to 2.1.0 2.1.0: * Async HTTP Consumers and WebSocket Consumers both gained new functionality (groups, subprotocols, and an async HTTP variant) * URLRouters now allow nesting * Async login and logout functions for sessions * Expiry and groups in the in-memory channel layer * Improved Live Server test case * More powerful OriginValidator * Other small changes and fixes in the full release notes.
py-channels: updated to 2.0.2 2.0.2: * SyncConsumer now terminates old database connections, and there is a new database_sync_to_async wrapper to allow async connections to do the same. 2.0.1: * AsyncWebsocketConsumer and AsyncJsonWebsocketConsumer classes added * OriginValidator and AllowedHostsOriginValidator ASGI middleware is now available * URLRouter now correctly resolves long lists of URLs 2.0.0: * Major backwards-incompatible rewrite to move to an asyncio base and remove the requirement to transport data over the network, as well as overhauled generic consumers, test helpers, routing and more.
Restrict Python support as py-asgiref doesn't support 2.7 and 3.4.
py-channels: update to 1.1.8 1.1.8 * Reverted recent JS fixes for subprotocols on some phones as they do not work in Chrome.
py-channels: update to 1.1.7 1.1.7: * Fixed compatability with Django 1.10 and below * JS library: Fixed error with 1006 error code
Switch github HOMEPAGEs to https.
Changes 1.1.6: The runserver server_cls override no longer fails with more modern Django versions that pass an ipv6 parameter.
Channels loads into Django as a pluggable app to bring WebSocket, long-poll HTTP, task offloading and other asynchrony support to your code, using familiar Django design patterns and a flexible underlying framework that lets you not only customize behaviours but also write support for your own protocols and needs.