The NetBSD Project

CVS log for pkgsrc/www/py-asgiref/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / py-asgiref

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.35: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:29:16 2024 UTC (3 weeks, 2 days ago) by wiz
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.34: preferred, colored
Changes since revision 1.34: +1 -2 lines
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

Revision 1.34: download - view: text, markup, annotated - select for diffs
Fri Mar 22 18:48:05 2024 UTC (8 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.33: preferred, colored
Changes since revision 1.33: +5 -7 lines
py-asgiref: updated to 3.8.1

3.8.1 (2024-03-22)
------------------

* Fixes a regression in 3.8.0 affecting nested task cancellation inside
  sync_to_async.

3.8.0 (2024-03-20)
------------------

* Adds support for Python 3.12.

* Drops support for (end-of-life) Python 3.7.

* Fixes task cancellation propagation to subtasks when using synchronous Django
  middleware.

* Allows nesting ``sync_to_async`` via ``asyncio.wait_for``.

* Corrects WSGI adapter handling of root path.

* Handles case where `"client"` is ``None`` in WsgiToAsgi adapter.

Revision 1.33: download - view: text, markup, annotated - select for diffs
Sun Jul 30 15:09:22 2023 UTC (16 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.32: preferred, colored
Changes since revision 1.32: +13 -7 lines
py-asgiref: updated to 3.7.2

3.7.2 (2023-05-27)
------------------

* The type annotations for SyncToAsync and AsyncToSync have been changed to
  more accurately reflect the kind of callables they return.

3.7.1 (2023-05-24)
------------------

* On Python 3.10 and below, the version of the "typing_extensions" package
  is now constrained to be at least version 4 (as we depend on functionality
  in that version and above)

3.7.0 (2023-05-23)
------------------

* Contextvars are now required for the implementation of `sync` as Python 3.6
  is now no longer a supported version.

* sync_to_async and async_to_sync now pass-through

* Debug and Lifespan State extensions have resulted in a typing change for some
  request and response types. This change should be backwards-compatible.

* ``asgiref`` frames will now be hidden in Django tracebacks by default.

* Raw performance and garbage collection improvements in Local, SyncToAsync,
  and AsyncToSync.

Revision 1.32: download - view: text, markup, annotated - select for diffs
Tue Jan 24 19:50:07 2023 UTC (22 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.31: preferred, colored
Changes since revision 1.31: +2 -7 lines
py-asgiref: updated to 3.6.0

3.6.0 (2022-12-20)
------------------

* Two new functions are added to the ``asgiref.sync`` module: ``iscoroutinefunction()``
  and ``markcoroutinefunction()``.

  Python 3.12 deprecates ``asyncio.iscoroutinefunction()`` as an alias for
  ``inspect.iscoroutinefunction()``, whilst also removing the ``_is_coroutine`` marker.
  The latter is replaced with the ``inspect.markcoroutinefunction`` decorator.

  The new ``asgiref.sync`` functions are compatibility shims for these
  functions that can be used until Python 3.12 is the minimum supported
  version.

  **Note** that these functions are considered **beta**, and as such, whilst
  not likely, are subject to change in a point release, until the final release
  of Python 3.12. They are included in ``asgiref`` now so that they can be
  adopted by Django 4.2, in preparation for support of Python 3.12.

* The ``loop`` argument to ``asgiref.timeout.timeout`` is deprecated. As per other
  ``asyncio`` based APIs, the running event loop is used by default. Note that
  ``asyncio`` provides timeout utilities from Python 3.11, and these should be
  preferred where available.

* Support for the ``ASGI_THREADS`` environment variable, used by
  ``SyncToAsync``, is removed. In general, a running event-loop is not
  available to `asgiref` at import time, and so the default thread pool
  executor cannot be configured. Protocol servers, or applications, should set
  the default executor as required when configuring the event loop at
  application startup.

Revision 1.31: download - view: text, markup, annotated - select for diffs
Thu May 19 13:16:03 2022 UTC (2 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.30: preferred, colored
Changes since revision 1.30: +2 -2 lines
py-asgiref: updated to 3.5.2

3.5.2 (2022-05-16)
------------------

* Allow async-callables class instances to be passed to AsyncToSync
  without warning

* Prevent giving async-callable class instances to SyncToAsync

Revision 1.30: download - view: text, markup, annotated - select for diffs
Sun May 1 20:04:45 2022 UTC (2 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.29: preferred, colored
Changes since revision 1.29: +2 -2 lines
py-asgiref: updated to 3.5.1

3.5.1 (2022-04-30)
------------------
* sync_to_async in thread-sensitive mode now works corectly when the
  outermost thread is synchronous

Revision 1.29: download - view: text, markup, annotated - select for diffs
Wed Apr 20 12:25:25 2022 UTC (2 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.28: preferred, colored
Changes since revision 1.28: +2 -3 lines
py-asgiref: updated to 3.5.0

3.5.0 (2022-01-22)
------------------

* Python 3.6 is no longer supported, and asyncio calls have been changed to
  use only the modern versions of the APIs as a result

* Several causes of RuntimeErrors in cases where an event loop was assigned
  to a thread but not running

* Speed improvements in the Local class

Revision 1.28: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:55:16 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.27: preferred, colored
Changes since revision 1.27: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.27: download - view: text, markup, annotated - select for diffs
Tue Jul 6 05:56:34 2021 UTC (3 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +2 -2 lines
py-asgiref: updated to 3.4.1

3.4.1 (2021-07-01)
------------------

* Fixed an issue with the deadlock detection where it had false positives
  during exception handling.


3.4.0 (2021-06-27)
------------------

* Calling sync_to_async directly from inside itself (which causes a deadlock
  when in the default, thread-sensitive mode) now has deadlock detection.

* asyncio usage has been updated to use the new versions of get_event_loop,
  ensure_future, wait and gather, avoiding deprecation warnings in Python 3.10.
  Python 3.6 installs continue to use the old versions; this is only for 3.7+

* sync_to_async and async_to_sync now have improved type hints that pass
  through the underlying function type correctly.

* All Websocket* types are now spelled WebSocket, to match our specs and the
  official spelling. The old names will work until release 3.5.0, but will
  raise deprecation warnings.

* The typing for WebSocketScope and HTTPScope's `extensions` key has been
  fixed.

Revision 1.26: download - view: text, markup, annotated - select for diffs
Tue Apr 6 19:42:18 2021 UTC (3 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +2 -2 lines
py-asgiref: updated to 3.3.4

3.3.4 (2021-04-06)
------------------

* The async_to_sync type error is now a warning due the high false negative
  rate when trying to detect coroutine-returning callables in Python.


3.3.3 (2021-04-06)
------------------

* The sync conversion functions now correctly detect functools.partial and other
  wrappers around async functions on earlier Python releases.

Revision 1.25: download - view: text, markup, annotated - select for diffs
Tue Apr 6 04:48:34 2021 UTC (3 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +7 -2 lines
py-asgiref: updated to 3.3.2

3.3.2 (2021-04-05)
------------------

* SyncToAsync now takes an optional "executor" argument if you want to supply
  your own executor rather than using the built-in one.

* async_to_sync and sync_to_async now check their arguments are functions of
  the correct type.

* Raising CancelledError inside a SyncToAsync function no longer stops a future
  call from functioning.

* ThreadSensitive now provides context hooks/override options so it can be
  made to be sensitive in a unit smaller than threads (e.g. per request)

Revision 1.24: download - view: text, markup, annotated - select for diffs
Tue Nov 10 11:13:46 2020 UTC (4 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +2 -2 lines
py-asgiref: update to 3.3.1

3.3.1:
Unknown changes

Revision 1.23: download - view: text, markup, annotated - select for diffs
Sat Oct 10 18:00:57 2020 UTC (4 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +2 -2 lines
py-asgiref: updated to 3.3.0

3.3.0:
* sync_to_async now defaults to thread-sensitive mode being on
* async_to_sync now works inside of forked processes
* WsgiToAsgi now correctly clamps its response body when Content-Length is set

Revision 1.22: download - view: text, markup, annotated - select for diffs
Sat Jun 20 16:26:34 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -2 lines
py-asgiref: updated to 3.2.10

3.2.10:
* Fixed bugs due to bad WeakRef handling introduced in 3.2.8

Revision 1.21: download - view: text, markup, annotated - select for diffs
Wed Jun 17 04:53:33 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -2 lines
py-asgiref: updated to 3.2.9

3.2.9:
* Fixed regression with exception handling in 3.2.8 related to the contextvars fix.

3.2.8:
* Fixed small memory leak in local.Local
* contextvars are now persisted through AsyncToSync

Revision 1.20: download - view: text, markup, annotated - select for diffs
Tue Apr 7 10:44:59 2020 UTC (4 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -2 lines
py-asgiref: updated to 3.2.7

3.2.7:
* Bug fixed in local.Local where deleted Locals would occasionally inherit
  their storage into new Locals due to memory reuse.

Revision 1.19: download - view: text, markup, annotated - select for diffs
Tue Mar 24 06:58:46 2020 UTC (4 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +8 -2 lines
py-asgiref: updated to 3.2.6

3.2.6:
* local.Local now works in all threading situations, no longer requires
  periodic garbage collection, and works with libraries that monkeypatch
  threading (like gevent)

Revision 1.18: download - view: text, markup, annotated - select for diffs
Thu Mar 12 16:15:09 2020 UTC (4 years, 8 months ago) by adam
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
py-asgiref: updated to 3.2.5

3.2.5
* __self__ is now preserved on methods by async_to_sync

3.2.4
* Pending tasks/async generators are now cancelled when async_to_sync exits
* Contextvars now propagate changes both ways through sync_to_async
* sync_to_async now preserves attributes on functions it wraps

Revision 1.17: download - view: text, markup, annotated - select for diffs
Thu Oct 31 08:25:02 2019 UTC (5 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -2 lines
py-asgiref: updated to 3.2.3

3.2.3:
* Added support and testing for Python 3.8.

Revision 1.16: download - view: text, markup, annotated - select for diffs
Fri Aug 30 10:54:10 2019 UTC (5 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
py-asgiref: updated to 3.2.2

3.2.2:
* WsgiToAsgi maps multi-part request bodies into a single WSGI input file
* WsgiToAsgi passes the `root_path` scope as SCRIPT_NAME
* WsgiToAsgi now checks the scope type to handle `lifespan` better
* WsgiToAsgi now passes the server port as a string, like WSGI
* SyncToAsync values are now identified as coroutine functions by asyncio
* SyncToAsync now handles __self__ correctly for methods

Revision 1.15: download - view: text, markup, annotated - select for diffs
Wed Aug 7 12:26:04 2019 UTC (5 years, 3 months ago) by adam
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2 lines
py-asgiref: updated to 3.2.1

3.2.1:
* sys.exc_info() is now propagated across thread boundaries

3.2.0:
* New "thread_sensitive" argument to SyncToAsync allows for pinning of code into
  the same thread as other thread_sensitive code.
* Test collection on Python 3.7 fixed

Revision 1.14: download - view: text, markup, annotated - select for diffs
Mon Jul 8 07:36:57 2019 UTC (5 years, 4 months ago) by adam
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
py-asgiref: updated to 3.1.4

3.1.4:
* Fixed an incompatibility with Python 3.5 introduced in the last release.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Jul 6 23:00:04 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -4 lines
py-asgiref: updated to 3.1.3

3.1.3:
* async_timeout has been removed as a dependency, so there are now no required
  dependencies.
* The WSGI adapter now sets REMOTE_ADDR from the ASGI client.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Fri Apr 26 13:14:20 2019 UTC (5 years, 7 months ago) by maya
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
Omit mentions of python 34 and 35, after those were removed.

- Includes some whitespace changes, to be handled in a separate commit.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Thu Apr 18 08:37:28 2019 UTC (5 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
py-asgiref: updated to 3.1.2

3.1.2:
* New thread_critical argument to Local to tell it to not inherit contexts
  across threads/tasks.
* Local now inherits across any number of sync_to_async to async_to_sync calls
  nested inside each other

3.1.1:
* Local now cleans up storage of old threads and tasks to prevent a memory leak.

3.1.0:
* Added asgiref.local module to provide threading.local drop-in replacement.

3.0.0:
* Updated to match new ASGI 3.0 spec
* Compatibility library added that allows adapting ASGI 2 apps into ASGI 3 apps
  losslessly

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu May 24 06:37:46 2018 UTC (6 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -3 lines
py-asgiref: updated to 2.3.2

2.3.2:
* Packaging fix to allow old async_timeout dependencies (2.0 as well as 3.0)

2.3.1:
* WSGI-to-ASGI adapter now works with empty bodies in responses
* Update async-timeout dependency

Revision 1.9: download - view: text, markup, annotated - select for diffs
Fri Apr 13 11:09:43 2018 UTC (6 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
py-asgiref: updated to 2.3.0

2.3.0:
* ApplicationCommunicator now has a receive_nothing() test available

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu Mar 8 08:26:21 2018 UTC (6 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
py-asgiref: updated to 2.2.0

2.2.0:
* Cancelled tasks now correctly cascade-cancel their children
* Communicator.wait() no longer re-raises CancelledError from inner coroutines

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Feb 22 08:50:47 2018 UTC (6 years, 9 months ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +3 -3 lines
py-asgiref: updated to 2.1.6

2.1.6:
* async_to_sync now works inside of threads (but is still not allowed in threads
  that have an active event loop)

Revision 1.6: download - view: text, markup, annotated - select for diffs
Fri Feb 16 14:42:55 2018 UTC (6 years, 9 months ago) by adam
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
py-asgiref: updated to 2.1.5

2.1.5:
* Fixed issues with async_to_sync not setting the event loop correctly
* Stop async_to_sync being called from threads with an active event loop

Revision 1.5: download - view: text, markup, annotated - select for diffs
Mon Feb 12 08:36:52 2018 UTC (6 years, 9 months ago) by adam
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
py-asgiref: updated to 2.1.4

2.1.4:
* Values are now correctly returned from sync_to_async and async_to_sync
* ASGI_THREADS environment variable now works correctly

2.1.3:
* Add an ApplicationCommunicator.wait() method to allow you to wait for an
  application instance to exit before seeing what it did.

2.1.2:
* Allow AsyncToSync to work if called from a non-async-wrapped sync context.

2.1.1:
* Allow AsyncToSync constructor to be called inside SyncToAsync.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Wed Jan 31 11:43:18 2018 UTC (6 years, 10 months ago) by adam
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
py-asgiref: updated to 2.1.0

2.1.0:
* Add asgiref.testing module with ApplicationCommunicator testing helper

Revision 1.3: download - view: text, markup, annotated - select for diffs
Fri Dec 8 12:07:50 2017 UTC (6 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -1 lines
Added PYTHON_VERSIONS_INCOMPATIBLE

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Nov 30 08:01:48 2017 UTC (7 years ago) by adam
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +4 -4 lines
py-asgiref: updated to 2.0.1

2.0.1:
* Bugfix release to have HTTP response content message as the correct
  "http.response.content" not the older "http.response.chunk".

2.0.0:
* Complete rewrite for new async-based ASGI mechanisms and removal of
  channel layers.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Jun 21 19:09:07 2017 UTC (7 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Contains various reference ASGI implementations, including:
* A base channel layer, asgiref.base_layer
* An in-memory channel layer, asgiref.inmemory
* WSGI-to-ASGI and ASGI-to-WSGI adapters, in asgiref.wsgi

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>