[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / p5-Catalyst-Runtime

File: [cvs.NetBSD.org] / pkgsrc / www / p5-Catalyst-Runtime / Makefile (download)

Revision 1.12, Sun Sep 13 19:59:50 2009 UTC (14 years, 7 months ago) by sno
Branch: MAIN
Changes since 1.11: +7 -6 lines

Updating www/p5-Catalyst-Runtime from 5.80007 to 5.80012

pkgsrc changes:
  - Adjusting dependencies

Upstream changes:
5.80012 2009-09-09 19:09:09

  Bug fixes:
     - Fix t/optional_http-server.t test.
     - Fix t/optional_http-server-restart.t test.
     - Fix duplicate components being loaded at setup time, each component is
       now loaded at most once + tests.
     - Fix backward compatibility - hash key configured actions are stored in
       is returned to 'actions'.
     - Fix get_action_methods returning duplicate methods when a method is both
       decorated with method attributes and set as an action in config.

  Refactoring / cleanups:
     - Reduce minimum supported perl version from 5.8.6 to 5.8.4 as there are
       many people still running/testing this version with no known issues.

  Tests:
     - Make the optional_http_server.t test an author only test which must be
       run by authors to stop it being broken again.
     - Fix recursion warnings in the test suites.

5.80011 2009-08-23 13:48:15

  Bug fixes:
      - Remove leftovers of the restarter engine. The removed code caused test
        failures, which weren't apparent for anyone still having an old version
        installed in @INC.

5.80010 2009-08-21 23:32:15

  Bug fixes:
      - Fix and add tests for a regression introduced by 5.80008.
        Catalyst::Engine is now able to send out data from filehandles larger
        than the default chunksize of 64k again.

5.80009 2009-08-21 22:21:08

  Bug fixes:
      - Fix and add tests for generating inner packages inside the COMPONENT
        method, and those packages being correctly registered as components.
        This fixes Catalyst::Model::DBIC among others.

5.80008 2009-08-21 17:47:30

  Bug fixes:
       - Fix replace_constructor warning to actually work if you make your
         application class immutable without that option.
       - Depend on Module::Pluggable 3.9 to prevent a bug wherein components
         in inner packages might not be registered. This especially affected
         tests.
       - Catalyst::Engine::FastCGI - relax the check for versions of Microsoft
         IIS. Provides compatibility with Windows 2008 R2 as well as
         (hopefully) future versions.
       - In tests which depend on the values of environment variables,
         localise the environment, then delete only relevant environment
         variables (RT#48555)
       - Fix issue with Engine::HTTP not sending headers properly in some cases
         (RT#48623)
       - Make Catalyst::Engine write at least once when finalizing the response
         body from a filehandle, even if the write is empty. This avoids fail
         when trying to send out an empty response body from a filehandle.
       - Catalyst::Engine::HTTP - Accept a fully qualified absolute URI in the
         Request-URI of the Request-Line

  Refactoring / cleanups:
       - Deleted the Restarter engine and its Watcher code. Use the
         new Catalyst::Restarter in a recent Catalyst::Devel instead.
       - New unit test for Catalyst::Action 'unit_core_action.t'
       - Bump minimum supported perl version from 5.8.1 to 5.8.6 as there are
         known issues with 5.8.3.
       - Debug output uses dynamic column sizing to create more readable output
         when using a larger $ENV{COLUMNS} setting. (groditi)

  New features:
       - Added private_path method for Catalyst::Action
       - Allow uri_for($controller_instance) which will produce a URI
         for the controller namespace
       - Break setup_components into two more parts: locate_components and
         expand_component_module (rjbs)
       - Allow Components to return anon classed from their COMPONENT method
         correctly, and have action registration work on Controllers returned
         as such by adding a catalyst_component_name accessor for all components
         which returns the component instance's name to be used when building
         actions etc.
       - Adding X-Forwarded-Port to allow the frontend proxy to dictate the
         frontend port (jshirley)
       - Added Catalyst::Stats->created accessor for the time at the start of
         the request.

  Documentation:
       - Fix POD to refer to ->config(key => $val), rather than
         ->config->{key} = $val, as the latter form is deprecated.
       - Clearer docs for the 'uri_for' method.
       - Fix POD refering to CGI::Cookie. We're using CGI::Simple::Cookie.
         (Forrest Cahoon)

# $NetBSD: Makefile,v 1.12 2009/09/13 19:59:50 sno Exp $

DISTNAME=	Catalyst-Runtime-5.80012
PKGNAME=	p5-${DISTNAME}
CATEGORIES=	www perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Catalyst/}

MAINTAINER=	rhaen@NetBSD.org
HOMEPAGE=	http://www.catalystframework.org/
COMMENT=	The Elegant MVC Web Application Framework
LICENSE=	${PERL5_LICENSE}

CONFLICTS+=	p5-Catalyst-[0-9]*

DEPENDS+=	p5-B-Hooks-EndOfScope>=0.08:../../devel/p5-B-Hooks-EndOfScope
DEPENDS+=	p5-CGI-Simple>=0:../../www/p5-CGI-Simple
DEPENDS+=	p5-Class-C3-Adopt-NEXT>=0.07:../../devel/p5-Class-C3-Adopt-NEXT
DEPENDS+=	p5-Class-MOP>=0.83:../../devel/p5-Class-MOP
DEPENDS+=	p5-Data-Dump>=0:../../devel/p5-Data-Dump
DEPENDS+=	p5-File-Modified>=0:../../devel/p5-File-Modified
DEPENDS+=	p5-HTML-Parser>=0:../../www/p5-HTML-Parser
DEPENDS+=	p5-HTTP-Body>=1.04:../../www/p5-HTTP-Body
DEPENDS+=	p5-HTTP-Request-AsCGI>=0.8:../../www/p5-HTTP-Request-AsCGI
DEPENDS+=	p5-List-MoreUtils-[0-9]*:../../devel/p5-List-MoreUtils
DEPENDS+=	p5-MRO-Compat-[0-9]*:../../devel/p5-MRO-Compat
DEPENDS+=	p5-Module-Pluggable>=3.9:../../devel/p5-Module-Pluggable
DEPENDS+=	p5-Moose>=0.78:../../devel/p5-Moose
DEPENDS+=	p5-MooseX-Emulate-Class-Accessor-Fast>=0.00801:../../devel/p5-MooseX-Emulate-Class-Accessor-Fast
DEPENDS+=	p5-MooseX-MethodAttributes>=0.15:../../devel/p5-MooseX-MethodAttributes
DEPENDS+=	p5-Path-Class>=0.09:../../devel/p5-Path-Class
DEPENDS+=	{perl>=5.10,p5-Scalar-List-Utils>=0}:../../devel/p5-Scalar-List-Utils
DEPENDS+=	p5-String-RewritePrefix>=0.004:../../textproc/p5-String-RewritePrefix
DEPENDS+=	p5-Sub-Exporter-[0-9]*:../../devel/p5-Sub-Exporter
DEPENDS+=	p5-Task-Weaken-[0-9]*:../../devel/p5-Task-Weaken
DEPENDS+=	p5-Text-SimpleTable>=0.03:../../textproc/p5-Text-SimpleTable
DEPENDS+=	{perl>=5.10,p5-Time-HiRes>=0}:../../time/p5-Time-HiRes
DEPENDS+=	p5-Tree-Simple>=1.15:../../devel/p5-Tree-Simple
DEPENDS+=	p5-Tree-Simple-VisitorFactory>=0:../../devel/p5-Tree-Simple-VisitorFactory
DEPENDS+=	p5-URI>=1.35:../../www/p5-URI
DEPENDS+=	p5-libwww>=5.805:../../www/p5-libwww
DEPENDS+=	p5-namespace-autoclean-[0-9]*:../../devel/p5-namespace-autoclean
DEPENDS+=	p5-namespace-clean-[0-9]*:../../devel/p5-namespace-clean

# Recommends:
DEPENDS+=	p5-B-Hooks-OP-Check-StashChange-[0-9]*:../../devel/p5-B-Hooks-OP-Check-StashChange

BUILD_DEPENDS+=	p5-Class-Data-Inheritable-[0-9]*:../../devel/p5-Class-Data-Inheritable
BUILD_DEPENDS+=	p5-Test-Exception-[0-9]*:../../devel/p5-Test-Exception
#BUILD_DEPENDS+=	p5-Test-MockObject>=1.07:../../devel/p5-Test-MockObject
BUILD_DEPENDS+=	p5-Test-Simple>=0.88:../../devel/p5-Test-Simple

MAKE_ENV+=	PERL_EXTUTILS_AUTOINSTALL=--skipdeps
PERL5_PACKLIST= auto/Catalyst/Runtime/.packlist
#PERL5_MODULE_TYPE=	Module::Install::Bundled
MAKE_PARAMS+=	--skipdeps
PKG_DESTDIR_SUPPORT=	user-destdir

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"