The NetBSD Project

CVS log for pkgsrc/www/p5-Catalyst-Plugin-Session/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / p5-Catalyst-Plugin-Session

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.16 / (download) - annotate - [select for diffs], Fri Jan 4 06:26:51 2019 UTC (6 weeks, 2 days ago) by wen
Branch: MAIN
CVS Tags: HEAD
Changes since 1.15: +5 -5 lines
Diff to previous 1.15 (colored)

Update to 0.41

Upstream changes:
0.41 2018-12-05
      - Don't let an evil session ID supplier have an easy XSS vector (Michael McClimon++)

Revision 1.15 / (download) - annotate - [select for diffs], Sat Jan 16 23:34:29 2016 UTC (3 years, 1 month ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-
Changes since 1.14: +5 -5 lines
Diff to previous 1.14 (colored)

Update to 0.40
--------------
0.40 2015-01-26
  - Add a flag so that a storage can finalize during finalize_header rather
    than finalize_body.  This is to enable storages that need to write to the
    HTTP header (such as the cookie based store).

Revision 1.14 / (download) - annotate - [select for diffs], Wed Nov 4 02:47:05 2015 UTC (3 years, 3 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.13: +2 -1 lines
Diff to previous 1.13 (colored)

Add SHA512 digests for distfiles for www category

Problems found locating distfiles:
	Package haskell-cgi: missing distfile haskell-cgi-20001206.tar.gz
	Package nginx: missing distfile array-var-nginx-module-0.04.tar.gz
	Package nginx: missing distfile encrypted-session-nginx-module-0.04.tar.gz
	Package nginx: missing distfile headers-more-nginx-module-0.261.tar.gz
	Package nginx: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package nginx-devel: missing distfile echo-nginx-module-0.58.tar.gz
	Package nginx-devel: missing distfile form-input-nginx-module-0.11.tar.gz
	Package nginx-devel: missing distfile lua-nginx-module-0.9.16.tar.gz
	Package nginx-devel: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx-devel: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package php-owncloud: missing distfile owncloud-8.2.0.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.13 / (download) - annotate - [select for diffs], Thu Feb 6 10:42:40 2014 UTC (5 years ago) by abs
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.12: +4 -4 lines
Diff to previous 1.12 (colored)

Updated www/p5-Catalyst-Plugin-Session to 0.39

Revision history for Perl extension Catalyst::Plugin::Session

0.39 2013-10-16
      - Fixed a bug when "expiry_threshold" is non-zero, where changes to the
      session were not saved.

0.38 2013-09-18
      - New feature: "expiry_threshold" which allows you more control over when
      this plugin checks and updates the expiration date for the session.
      This is useful when you have high traffic and need to reduce the number
      of session expiration hits (like if you are using a database for sessions
      and your db is getting pounded).

Revision 1.12 / (download) - annotate - [select for diffs], Fri Aug 23 14:55:40 2013 UTC (5 years, 5 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.11: +4 -4 lines
Diff to previous 1.11 (colored)

Update to 0.37

Upstream changes:
0.37 2013-02-25
      - Fix t/live_verify_address.t to skip of Catalyst::Plugin::Authentication
        is not installed, fixing RT#81506.

0.36 2012-10-19
       - Re-pack with new Module::Install which doesn't get
         MYMETA.yaml wrong.
       - Remove use of Plack::Middleware::ForceEnv from the tests
          as it was not used / needed

0.35 2012-04-24
        - Implement a 'change_session_expires' method (gshank)

        - Fixed bug from last version where session does not persist
          across a redirect

0.34 2012-03-30
        - Fixed up t/live_verify_address.t per https://rt.cpan.org/Ticket/Display.html?id=71142
        - Merged in dpetrov's 0.32 changes (extend_session_expire)

0.33 2012-03-08
        - Note that flash is deprecated / not recommended due to it's
          inherent races. Point out Catalyst::Plugin::StatusMessage instead

Revision 1.11 / (download) - annotate - [select for diffs], Tue Jan 31 14:22:59 2012 UTC (7 years ago) by rhaen
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.10: +4 -4 lines
Diff to previous 1.10 (colored)

Updated to 0.32

Changelog:
0.32 2011-06-08
        - Fix handling with enables verify_address and add related test

0.31 2010-10-08
        - Fix session being loaded by call to dump_these in debug mode
          (RT#58856)

Revision 1.10 / (download) - annotate - [select for diffs], Sun Jul 25 18:22:53 2010 UTC (8 years, 6 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.9: +4 -4 lines
Diff to previous 1.9 (colored)

Updating www/p5-Catalyst-Plugin-Session from 0.29 to 0.30

Upstream changes:
0.30 2010-06-24
        - Fix Makefile.PL's is_upgrading_needed() routine (RT #58771)

Revision 1.9 / (download) - annotate - [select for diffs], Sat Nov 21 14:22:50 2009 UTC (9 years, 2 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.8: +4 -4 lines
Diff to previous 1.8 (colored)

Updating www/p5-Catalyst-Plugin-Session from 0.27 to 0.29

Upstream changes:
0.29 2009-11-04
        - Fix session being deleted when you have a new session after session
          expiry when calling session_is_valid method. Tests for this.
        - Allow ->session to be used as a setter method so that you can say
          ->session( key => $value );

0.28 2009-10-29
        - Fix session fixation test with LWP 5.833 by calling $cookie_jar->set_cookie
          rather than manually stuffing the cookie in the request.

Revision 1.8 / (download) - annotate - [select for diffs], Sat Oct 24 14:45:49 2009 UTC (9 years, 3 months ago) by sno
Branch: MAIN
Changes since 1.7: +4 -4 lines
Diff to previous 1.7 (colored)

Updating www/p5-Catalyst-Plugin-Session from 0.26nb1 to 0.27

Upstream changes:
0.27 2009-10-08
        - Release 0.26_01 as stable without further changes.

0.26_01 2009-10-06
        - Move actions out of the root application class in tests as this
          is deprecated.
        - Change configuration key to 'Plugin::Session' by default. The
          old 'session' key is still supported, but will issue a warning
          in a future release.

Revision 1.7 / (download) - annotate - [select for diffs], Thu Aug 20 18:04:16 2009 UTC (9 years, 6 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.6: +4 -4 lines
Diff to previous 1.6 (colored)

Update package www/p5-Catalyst-Plugin-Session from 0.25 to 0.26

pkgsrc changes:
  - Adjusting dependencies according to META.yml

Upstream changes:
0.26 2009-08-19
        - Remove Test::MockObject from the test suite as prone to failing on
          some platforms and perl versions due to it's UNIVERSAL:: package
          dependencies.

Revision 1.6 / (download) - annotate - [select for diffs], Wed Aug 19 18:27:40 2009 UTC (9 years, 6 months ago) by sno
Branch: MAIN
Changes since 1.5: +4 -4 lines
Diff to previous 1.5 (colored)

Updating package www/p5-Catalyst-Plugin-Session from 0.24 to 0.25

pkgsrc changes:
  - Adjusting license (now we have ${PERL5_LICENSE}

Upstream changes:
0.25 2009-0708
        - Add the a change_session_id method which can be called after
          authentication to change the user's session cookie whilst preserving
          their session data. This can be used to provide protection from
          Session Fixation attacks. (kmx)

Revision 1.5 / (download) - annotate - [select for diffs], Tue Jul 7 21:38:45 2009 UTC (9 years, 7 months ago) by sno
Branch: MAIN
Changes since 1.4: +4 -4 lines
Diff to previous 1.4 (colored)

Updating package Catalyst::Plugin::Session from 0.22 to 0.24 and adjusting
meta-data (dependencies, master site).

Upstream changes:
0.24 2009-06-23
        - Be more paranoid about getting values of $c->req to avoid issues
          with old Test::WWW::Mechanize::Catalyst.
        - Check we have a modern version of TWMC before doing the tests which
          need it.

0.23 2009-06-16
        - Add the verify_user_agent config parameter (kmx)
        - Add a test case to prove that logging in with a session cookie still
          causes a new cookie to be issued for you, proving that the code is
          not vulnerable to a session fixation attack. (t0m)

Revision 1.4 / (download) - annotate - [select for diffs], Sun May 17 19:26:00 2009 UTC (9 years, 9 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.3: +4 -4 lines
Diff to previous 1.3 (colored)

PkgSrc changes:
  - Updating package for p5 module Catalyst::Plugin::Session from 0.21 to
    0.22

Upstream changes:
0.22 2009-05-13
        - INSANE HACK to ensure B::Hooks::EndOfScope inlines us a new method right now
          in Catalyst::Plugin::Session::Test::Store for Catalyst 5.80004 compatibility.

          This change does not in any way affect normal users - it is just due to the
          fairly crazy way that Catalyst::Plugin::Session::Test::Store works, and that
          module is _only_ used for unit testing session store plugins pre-installation.

          Session::Test::Store should be replaced with a more sane solution, and other
          CPAN modules using it moved away from using it, but this change keeps stops
          new Catalyst breaking other distributions right now.

Revision 1.3 / (download) - annotate - [select for diffs], Fri May 1 13:30:35 2009 UTC (9 years, 9 months ago) by sno
Branch: MAIN
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (colored)

PkgSrc changes:
  - Updating package for p5 module of Catalyst::Plugin::Session from 0.20
    to 0.21
  - Setting license to gnu-gpl-v2
  - Adjusting depends

Upstream changes:
0.21 2009-04-30
        - Hide the internal packages in Catalyst::Plugin::Session::Test::Store from PAUSE.
        - Convert from CAF to Moose with Moosex::Emulate::Class::Accessor::Fast

Revision 1.2 / (download) - annotate - [select for diffs], Sun Feb 22 17:27:46 2009 UTC (9 years, 11 months ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Update from version 1.19nb1 to 1.20.

Pkgsrc changes:
 o Adjust dependencies to account for new requirements
 o Move some dependencies into BUILD_DEPENDS, since they're
   only required for "make test".

Upstream changes:

0.20 2009-02-05
        - No code changes since 0.19_01 dev release.
        - Add IDEAS.txt which is an irc log of discussion about the
          next-generation session plugin from discussion on #catalyst-dev
        - Remove TODO file, which is no longer relevant.

0.19_01 2009-01-09
        - Switch from using NEXT to Class::C3 for method re-dispatch.
        - Use shipit to package the dist.
        - Switch to Module::install.
        - Flash data is now stored inside the session (key "__flash") to avoid
          duplicate entry errors caused by simultaneous select/insert/delete of
          flash rows when using DBI as a Store. (Sergio Salvi)
        - Fix session finalization order that caused HTTP responses to be sent
          before the session is actually finalized and stored in its Store.
          (Sergio Salvi)

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Tue Jul 15 09:18:32 2008 UTC (10 years, 7 months ago) by abs
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Added www/p5-Catalyst-Plugin-Session version 0.19

The Session plugin is the base of two related parts of functionality
required for session management in web applications.

The first part, the State, is getting the browser to repeat back a
session key, so that the web application can identify the client and
logically string several requests together into a session.

The second part, the Store, deals with the actual storage of information
about the client. This data is stored so that the it may be revived for
every request made by the same client.

This plugin links the two pieces together.

WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session/

Revision 1.1 / (download) - annotate - [select for diffs], Tue Jul 15 09:18:32 2008 UTC (10 years, 7 months ago) by abs
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>