The NetBSD Project

CVS log for pkgsrc/www/p5-Catalyst-Plugin-Authentication/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / p5-Catalyst-Plugin-Authentication

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.35 / (download) - annotate - [select for diffs], Thu Jul 6 09:42:28 2023 UTC (7 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

*: recursive bump for perl 5.38

Revision 1.34 / (download) - annotate - [select for diffs], Tue Jun 6 12:42:42 2023 UTC (8 months, 2 weeks ago) by riastradh
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.33: +7 -7 lines
Diff to previous 1.33 (colored)

Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/.

Almost all uses, if not all of them, are wrong, according to the
semantics of BUILD_DEPENDS (packages built for target available for
use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for
host available for use _as_ tools at build-time).

No change to BUILD_DEPENDS as used correctly inside buildlink3.

As proposed on tech-pkg:
https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html

Revision 1.33 / (download) - annotate - [select for diffs], Tue Jun 28 11:37:15 2022 UTC (19 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

*: recursive bump for perl 5.36

Revision 1.32 / (download) - annotate - [select for diffs], Mon May 24 19:55:25 2021 UTC (2 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

*: recursive bump for perl 5.34

Revision 1.31 / (download) - annotate - [select for diffs], Mon Aug 31 18:12:44 2020 UTC (3 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

*: bump PKGREVISION for perl-5.32.

Revision 1.30 / (download) - annotate - [select for diffs], Mon Nov 4 22:10:01 2019 UTC (4 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.29: +9 -9 lines
Diff to previous 1.29 (colored)

www: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

Manually excluded phraseanet since pkglint got the indentation wrong.

Revision 1.29 / (download) - annotate - [select for diffs], Sun Aug 11 13:24:31 2019 UTC (4 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

Bump PKGREVISIONs for perl 5.30.0

Revision 1.28 / (download) - annotate - [select for diffs], Sun Jun 30 20:17:25 2019 UTC (4 years, 7 months ago) by nia
Branch: MAIN
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.

Revision 1.27 / (download) - annotate - [select for diffs], Wed Aug 22 09:47:33 2018 UTC (5 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

Recursive bump for perl5-5.28.0

Revision 1.26 / (download) - annotate - [select for diffs], Wed Jun 28 08:16:58 2017 UTC (6 years, 7 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.25: +3 -1 lines
Diff to previous 1.25 (colored)

Requires PERL_USE_UNSAFE_INC hack.

Revision 1.25 / (download) - annotate - [select for diffs], Mon Jun 5 14:25:13 2017 UTC (6 years, 8 months ago) by ryoon
Branch: MAIN
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

Recursive revbump from lang/perl5 5.26.0

Revision 1.24 / (download) - annotate - [select for diffs], Wed Jun 8 19:24:59 2016 UTC (7 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

Bump PKGREVISION for perl-5.24.

Revision 1.23 / (download) - annotate - [select for diffs], Tue May 3 10:54:58 2016 UTC (7 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

Reset maintainer (observer now).

Revision 1.22 / (download) - annotate - [select for diffs], Sun Jul 12 18:56:34 2015 UTC (8 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg

Revision 1.21 / (download) - annotate - [select for diffs], Fri Jun 12 10:51:56 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.20 / (download) - annotate - [select for diffs], Thu May 29 23:38:02 2014 UTC (9 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.19: +2 -1 lines
Diff to previous 1.19 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.19 / (download) - annotate - [select for diffs], Fri Aug 23 13:51:51 2013 UTC (10 years, 6 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.18: +3 -4 lines
Diff to previous 1.18 (colored)

Update to 1.0023

Upstream changes:
0.10023 11 Jan 2013
   - Add Howto on using the auth from the proxy server with
     ::Credential::Remote (Robert Rothenberg)

Revision 1.18 / (download) - annotate - [select for diffs], Fri May 31 12:42:38 2013 UTC (10 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.17 / (download) - annotate - [select for diffs], Sun Jan 27 07:57:23 2013 UTC (11 years ago) by rhaen
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.16: +2 -3 lines
Diff to previous 1.16 (colored)

- Updated to 0.10022

ChangeLog:
0.10022 08 Jan 2013
    - Fix NoPasswd store (skaufman)

0.10021 30 June 2012
    - Change all classes to Moose and MooseX::Emulate::Class::Accessor::Fast,
      fixing undeclared dependency on Class::Accessor::Fast.
    - Change Catalyst::Authentication::Realm to use String::RewritePrefix
      rather than doing namespace mangling manually.
    - Fix whitespace and tabs, add Test::EOL and Test::NoTabs
    - Document optional methods in stores needed for auto_create_user
      and auto_update_user in realms.
    - Clarify support channels
    - Note primary maintainer in docs.
    - Add x_authority metadata.
    - Get the NAME right by making it 1 line, due to crappy parsing
      in EU::MM (RT#77028)

0.10020 05 May 2012
     - Allow user_class to be configured for Catalyst::Authentication::Store::Minimal
       (Jochen Lutz <jlu@akk.org>)

0.10019 14 April 2012
     - Upgrade code to use Moose compatibility layer (jnap)
     - Added some rules to .gitignore for people using macs (jnap)
     - Updated copyright info
     - Catalyst::Plugin::Authentication::Credential::NoPassword added
       (Okko)
     - Convert repository to git (fREW Schmidt)

Revision 1.16 / (download) - annotate - [select for diffs], Sun Oct 28 06:30:32 2012 UTC (11 years, 3 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.15: +1 -2 lines
Diff to previous 1.15 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.15 / (download) - annotate - [select for diffs], Wed Oct 3 21:58:39 2012 UTC (11 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.14: +2 -1 lines
Diff to previous 1.14 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.14 / (download) - annotate - [select for diffs], Tue Aug 23 10:15:52 2011 UTC (12 years, 6 months ago) by abs
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.13: +10 -12 lines
Diff to previous 1.13 (colored)

Updated www/p5-Catalyst-Plugin-Authentication to 0.100180

0.10018 29 Jul 2011
     - Fix failing tests with the new PSGI Catalyst dev release

0.10017 24 Jan 2010
     - Fix failing tests with the new PSGI Catalyst dev release

Revision 1.13 / (download) - annotate - [select for diffs], Sun Aug 14 16:05:48 2011 UTC (12 years, 6 months ago) by obache
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Revision bump after updating perl5 to 5.14.1.

Revision 1.12 / (download) - annotate - [select for diffs], Sat Aug 21 16:36:41 2010 UTC (13 years, 6 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.10.1 -> 5.12.1.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=..."), minus the packages updated after
the perl package update.

sno@ was right after all, obache@ kindly asked and he@ led the
way. Thanks!

Revision 1.11 / (download) - annotate - [select for diffs], Tue Jan 26 09:41:47 2010 UTC (14 years ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.10: +4 -3 lines
Diff to previous 1.10 (colored)

Updating www/p5-Catalyst-Plugin-Authentication from 0.10015nb1 to 0.10016

pkgsrc changes:
  - Adjusting dependencies

Upstream changes:
0.10016 22 Jan 2010
     - Move root actions out of applcation class in tests to remove
       warnings in the latest Catalyst.
     - Add AUTOLOAD method to the default user class so that methods are
       delegated down onto the underlieing user object retrieved from
       the store (if present)
     - Fix typos in documentation (RT#49476)
     - Fix compatibilty with Catalyst 5.70 (RT#50466)
     - Various documentation improvements
     - Fix Realm::Processive's authinfo_mungle option (RT#47106)

Revision 1.10 / (download) - annotate - [select for diffs], Thu Sep 24 06:50:19 2009 UTC (14 years, 5 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.9: +2 -1 lines
Diff to previous 1.9 (colored)

Bumping revision of packages which depend direct or indirect on
devel/p5-Class-MOP. A late detected incompible change forced it.

Revision 1.9 / (download) - annotate - [select for diffs], Sun Sep 13 20:20:37 2009 UTC (14 years, 5 months ago) by sno
Branch: MAIN
Changes since 1.8: +7 -4 lines
Diff to previous 1.8 (colored)

Updating www/p5-Catalyst-Plugin-Authentication from 0.10013 to 0.10015

pkgsrc changes:
  - Updating dependencies
  - use bundled Module::Install (AuthorTests)

Upstream changes:
0.10015 Tue Sep 1 01:40:36 BST 2009
     - Remove (undeclared) dependency on Class::Data::Inhertiable (RT#49086)
     - Remove dependency on Test::MockObject
     - Fix repository metadata in META.yml / Makefile.PL
     - Make POD tests author side only.

0.10014 Tue Aug 25 15:42:57 BST 2009
      - Don't always supply an "id" column in the authinfo passed to the store
        class in ::Credential::Remote. This means that it works better with
        the DBIC store. (t0m)

      - Make auth_realms method ensure authentication is initialized
        before calling methods which get created during auth initialization.
        Fixes back compat cases where auth store is in the plugin list
        before the authentication plugin. (t0m)

Revision 1.8 / (download) - annotate - [select for diffs], Tue Jul 7 21:43:25 2009 UTC (14 years, 7 months ago) by sno
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Updating package for p5 module Catalyst::Plugin::Authentication from
0.10012 to 0.10013

Upstream changes:
0.10013 Fri Jun 19 16:08:00 BST 2009
      - Add a username_field config item to ::Credential::Remote
        (Nigel Metheringham)
      - Die with a useful error message if we are about to try to restore
        a user from a realm which does not exist. (t0m)

Revision 1.7 / (download) - annotate - [select for diffs], Mon Jun 15 22:38:45 2009 UTC (14 years, 8 months ago) by sno
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.6: +6 -5 lines
Diff to previous 1.6 (colored)

pkgsrc changes:
  - Updating package for p5 module Catalyst::Plugin::Authentication
    from 0.10011 to 0.10012
  - Adjusting license according to META.yaml
  - Use Module::Install as module type

Upstream changes:
0.10012 Sat Jun  6 10:58:43 BST 2009
      - Add Catalyst::Authentication::Credential::Remote which authenticates you
        directly from environment variables passed by your web server. This
        allows the use of SSL client certificates, NTLM, or just basic/digest
        auth done at the web server level to be used to authenticate users
        to your Catalyst application (kmx)
        - Tests for this
      - Change ->config invocations to be best practices (t0m)
      - Note about session auto-vification even when use_session is set
        to false (robert).
      - Note about how a realms key used to be needed to unconfuse people
        running an old version, but browsing the docs on search.cpan (ruoso)

Revision 1.6 / (download) - annotate - [select for diffs], Fri May 1 13:34:27 2009 UTC (14 years, 9 months ago) by sno
Branch: MAIN
Changes since 1.5: +10 -4 lines
Diff to previous 1.5 (colored)

PkgSrc changes:
  - Updating package for p5 module of Catalyst::Plugin::Authentication
    from 0.10009_1 to 0.10011
  - Setting license to gnu-gpl-v2
  - Adjusting dependencies

Upstream changes:
0.10011 Sun Mar  8 23:32:12 GMT 2009
      - Update t/live_app_session.t to skip unless you have a newer, more
        reliable version of TWMC (RT#43817)
      - Change check for isa Catalyst::Plugin::Session to just check the
        existance of a session method. (Edmund von der Burg)

0.10010
      - Change from NEXT to MRO::Compat
      - Chop a number off the versions to get back to the correct 0.10000
        version scheme.

0.100092_01
      - Add hook for failing user restore.
        - Add test for this.
      - Fix bug in Credential::Password with password_type: clear.
        - Add test for this.
      - Add mock object tests for Credential::Password with password_type:
        clear.

0.100092
      - Release new version, no changes since dev release.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Dec 11 16:03:38 2008 UTC (15 years, 2 months ago) by rhaen
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

updated to 0.100091
Changelog:
0.10009 2008-11-27
        - Including progressive realm for multiple authentication attempts
          in a single request.

0.10008 2008-10-23
		- Updating config to allow for inclusion of realm ref's in the main
		  config hash rather than in a subref called 'realms'

Revision 1.4 / (download) - annotate - [select for diffs], Mon Nov 10 22:37:46 2008 UTC (15 years, 3 months ago) by rhaen
Branch: MAIN
Changes since 1.3: +3 -6 lines
Diff to previous 1.3 (colored)

- updated to 0.10008
- took maintainership

Changelog:
0.10007 2008-10-23
		- Updating config to allow for inclusion of realm ref's in the main
		  config hash rather than in a subref called 'realms'

0.10007 2008-08-17
	- Update tests prereqs to include Test::Exception (RT #36339)
        - Some documentation fixes (including RT #36062)
        - Compatibility fix where the use of new style config and old
          style Authentication::Store::Minimal would cause a crash
          (Reported & fixed by Jos Boumans C<kane@cpan.org>)
        - Documentation update on Password - to indicate proper field naming
        - Decouple Authentication system from session.  The realm class
          now allows complete control over how a user is persisted across
          requests.
        - pod fixes (RT #36062, RT #36063)

Revision 1.3 / (download) - annotate - [select for diffs], Sun Oct 19 19:19:06 2008 UTC (15 years, 4 months ago) by he
Branch: MAIN
Changes since 1.2: +2 -1 lines
Diff to previous 1.2 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.8.8 -> 5.10.0.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=...").

Revision 1.2 / (download) - annotate - [select for diffs], Thu Sep 11 11:19:36 2008 UTC (15 years, 5 months ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +3 -2 lines
Diff to previous 1.1 (colored)

Update from version 0.10006 to 0.10007.

Upstream changes:

0.10007 2008-08-17
	- Update tests prereqs to include Test::Exception (RT #36339)
        - Some documentation fixes (including RT #36062)
        - Compatibility fix where the use of new style config and old
          style Authentication::Store::Minimal would cause a crash
          (Reported & fixed by Jos Boumans C<kane@cpan.org>)
        - Documentation update on Password - to indicate proper field naming
        - Decouple Authentication system from session.  The realm class
          now allows complete control over how a user is persisted across
          requests.
        - pod fixes (RT #36062, RT #36063)

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Tue Jul 15 09:17:09 2008 UTC (15 years, 7 months ago) by abs
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Added www/p5-Catalyst-Plugin-Authentication version 0.10006

The authentication plugin provides generic user support. It is the basis
for both authentication (checking the user is who they claim to be), and
authorization (allowing the user to do what the system authorises them
to do).

WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication/

Revision 1.1 / (download) - annotate - [select for diffs], Tue Jul 15 09:17:09 2008 UTC (15 years, 7 months ago) by abs
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>