[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / p5-Catalyst-Devel

File: [cvs.NetBSD.org] / pkgsrc / www / p5-Catalyst-Devel / Makefile (download)

Revision 1.6, Tue May 19 22:25:55 2009 UTC (14 years, 11 months ago) by sno
Branch: MAIN
Changes since 1.5: +7 -5 lines

pkgsrc changes:
  - Updating package for p5 module Catalyst::Devel from 1.12 to 1.15
  - Adjusting dependencies according to META.yml

Upstream changes:
1.15    2009-05-13 20:02
        - Remove -p option for pid file, and restore it to the port number,
          as it should be -port|-p (t0m)
        - Document -pidfile in myapp_server.pl POD (t0m)

1.14_02 2009-05-11 04:29
        - Small changes to work with File::ChangeNotify 0.03.

1.14_01 2009-05-11 03:45
        - This release moves the restarter functionality into a new
          module Catalyst::Restarter, that is not a Catalyst Engine
          subclass.

          The new restarter is simpler and more reliable, because it
          does not try to test if a changed piece of code can be
          compiled. It simply restarts the server whenever it detects
          changes. This also makes it much faster.

          However, this does mean that the server can simply die when
          a changed file cannot compile. This is different than the
          old behavior, where the server remained running without
          incorporating the change.

          Finally, the new restarter relies on File::ChangeNotify,
          which is designed to accomodate per-OS methods of detecting
          changed files. As of this writing, it currently ships with a
          file watcher that uses inotify on Linux systems, and a
          default fallback class that does everything in pure Perl.

1.13    2009-05-11 02:50
        - add [-pidfile|-p] option for myapp_server.pl (caelum)
        - Bump dependency on Config::General (caelum)
        - On perls with c3 method dispatch, make sure Class::C3 is recent
          enough to not produce warnings if it is already installed (caelum)
        - add resources to META.yml (caelum)

# $NetBSD: Makefile,v 1.6 2009/05/19 22:25:55 sno Exp $

DISTNAME=	Catalyst-Devel-1.15
PKGNAME=	p5-${DISTNAME}
CATEGORIES=	www perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Catalyst/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://search.cpan.org/dist/Catalyst-Devel/
COMMENT=	Development tool kit for Catalyst
LICENSE=	gnu-gpl-v2 # OR artistic

DEPENDS+=	p5-Catalyst-Action-RenderView>=0.04:../../www/p5-Catalyst-Action-RenderView
DEPENDS+=	p5-Catalyst-Manual>=5.70:../../www/p5-Catalyst-Manual
DEPENDS+=	p5-Catalyst-Plugin-ConfigLoader-[0-9]*:../../www/p5-Catalyst-Plugin-ConfigLoader
#DEPENDS+=	p5-Catalyst-Plugin-StackTrace-[0-9]*:../../www/p5-Catalyst-Plugin-StackTrace
DEPENDS+=	p5-Catalyst-Plugin-Static-Simple>=0.16:../../www/p5-Catalyst-Plugin-Static-Simple
DEPENDS+=	p5-Catalyst-Runtime>=5.70:../../www/p5-Catalyst-Runtime
DEPENDS+=	p5-Class-Accessor-[0-9]*:../../devel/p5-Class-Accessor
DEPENDS+=	p5-Config-General>=2.42:../../devel/p5-Config-General
DEPENDS+=	p5-File-ChangeNotify>=0.03:../../devel/p5-File-ChangeNotify
DEPENDS+=	p5-File-Copy-Recursive>=0:../../sysutils/p5-File-Copy-Recursive
DEPENDS+=	p5-Module-Install>=0.64:../../devel/p5-Module-Install
DEPENDS+=	p5-Path-Class>=0.09:../../devel/p5-Path-Class
DEPENDS+=       p5-Template-Toolkit>=2.14:../../www/p5-Template-Toolkit
DEPENDS+=	p5-parent-[0-9]*:../../devel/p5-parent

USE_LANGUAGES=	# empty
PERL5_PACKLIST=	auto/Catalyst/Devel/.packlist

PKG_DESTDIR_SUPPORT=	user-destdir

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"