[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / p5-CGI

File: [cvs.NetBSD.org] / pkgsrc / www / p5-CGI / Makefile (download)

Revision 1.38, Wed Jul 12 17:03:43 2006 UTC (17 years, 8 months ago) by heinz
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.37: +2 -2 lines

Updated to version 3.20.

Pkgsrc changes:
  - none

Relevant changes since version 3.11:
====================================
  Version 3.20
  1. Patch from David Wheeler for CGI::Cookie->bake(). Uses mod_perl
     headers_out->add() rather than headers_out->set().
  2. Fixed problem identified by Andrei Voronkov in which start_form()
     output was screwed up when initial argument begins with a dash and
     subsequent arguments do not.
  3. Quashed uninitialized variable warnings coming from script_name(),
     url() and other functions that require access to the PATH_INFO
     environment variable.

  Version 3.19
  1. Added patch from Stephen Frost that allows one to suppress use of the
     temp file that is created during uploads.
  2. Fixed problem noted by Martin Foster in which regular expression
     meta-character terms in the path information were not quoted, causing
     URL parsing to fail on URLs that contained metacharacters (such as +).
  3. More fixes to the url() method.
  4. Removed "hack to fix broken PATH_INFO in MSII".

  Version 3.18
  1.  Doc typo fixes.
  2.  Patch from Steve Peters to default the document type to match the charset.
  3.  Fixed param() so that param(-name=>'foo',-values=>[]) sets the
      parameter to empty list.

  Version 3.17 Fri Feb 24 14:01:27 EST 2006
   1. Added patch from Mike Hanafey which caused 0 arguments to
      CGI::Cookie->new() to be treated as empty.
   2. Patch to CGI::Carp from Peter Whaite to fix the unfixable problem of
      CGI::Carp not behaving correctly in an eval() context.
   3. CGI::Fast->new() calls CGI->_reset_globals to avoid contamination of
      one session with another's variables.
   4. Fixed upload failure on files that contain semicolons in their names.

  Version 3.16 Wed Feb  8 13:29:11 EST 2006
   1. header() -charset option now works even when the MIME type is not "text".
   2. Fixed documentation for cookie() function and fastCGI.
   3. Upload filehandles now only closed automatically on Windows systems.
   4. Apache::Cookie compatibility fix from David Wheeler
   5. CGI::Carp->fatalsToBrowser() does not work correctly with
	mod_perl 2. No workaround is known.
   6. Fixed text status code associated with 302 redirects. Should be "Found"
	but was "Moved".
   7. Fixed charset in start_html() and header() to be in synch.

  Version 3.14 Tue Dec  6 17:12:03 EST 2005
   1. Fixed broken scrolling_list() select attribute.

  Version 3.14 Tue Dec  6 17:12:03 EST 2005
   1. Fixed broken scrolling_list() select attribute.

  Version 3.13
    1. Removed extraneous empty "?" from end of self_url().

  Version 3.12
    1. Fixed virtual_port so that it works properly with https protocol.
    2. Fixed documentation for upload_hook().
    3. Added POSTDATA documentation.
    4. Made upload_hook() work in function-oriented mode.
    5. Fixed POST_MAX behavior so that it doesn't cause client to hang.
    6. Disabled automatic tab indexes and added new -tabindex pragma to
	turn automatic indexes back on.
    7. The url() and self_url() methods now work better in the context of Apache
       mod_rewrite. Be advised that path_info() may give you confusing results
       when mod_rewrite is active because Apache calculates the path info
       *after* rewriting. This is mostly worked around in url() and self_url(),
       but you may notice some anomalies.
    8. Removed empty (and non-validating) <div> from code emitted by end_form().
    9. Fixed CGI::Carp to work correctly with Mod_perl 1.29 in an Apache 2
       environment.
   10. Setting $CGI::TMPDIRECTORY should now be effective.
none

# $NetBSD: Makefile,v 1.38 2006/07/12 17:03:43 heinz Exp $
#

VERS=			3.20
DISTNAME=       	CGI.pm-${VERS}
PKGNAME=        	p5-CGI-${VERS}
SVR4_PKGNAME=		p5cgi
CATEGORIES=		www perl5
MASTER_SITES+=		${MASTER_SITE_PERL_CPAN:=CGI/}

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://stein.cshl.org/WWW/software/CGI/
COMMENT=		Perl5 module for writing forms-based CGI programs

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_LANGUAGES=		# empty
PERL5_PACKLIST=		auto/CGI/.packlist
HTMLDIR=		${PREFIX}/share/doc/html/p5-CGI

post-build:
	cd ${WRKSRC}/examples;						\
	for file in *.cgi *.pl; do					\
		${SED}	-e "s|^#!/.*|#!${PERL5}|g"			\
			$${file} > $${file}.tmp;			\
		${MV} -f $${file}.tmp $${file};				\
	done;								\
	${CHMOD} +x *.cgi;						\
	${PERL5} make_links.pl

post-install:
	${INSTALL_DATA_DIR} ${HTMLDIR}
	${INSTALL_DATA_DIR} ${HTMLDIR}/examples
	cd ${WRKSRC}; ${INSTALL_DATA} *.html ${HTMLDIR}
	cd ${WRKSRC}/examples;						\
	${INSTALL_DATA} *.gif *.html *.txt *.xbm ${HTMLDIR}/examples;	\
	${INSTALL_SCRIPT} *.cgi ${HTMLDIR}/examples

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"