[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / p5-Apache-Reload

File: [cvs.NetBSD.org] / pkgsrc / www / p5-Apache-Reload / Attic / Makefile (download)

Revision 1.2, Mon Dec 20 11:31:12 2004 UTC (19 years, 4 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.1: +2 -1 lines

since perl is now built with threads on most platforms, the perl archlib
module directory has changed (eg. "darwin-2level" vs.
"darwin-thread-multi-2level").

binary packages of perl modules need to be distinguishable between
being built against threaded perl and unthreaded perl, so bump the
PKGREVISION of all perl module packages and introduce
BUILDLINK_RECOMMENDED for perl as perl>=5.8.5nb5 so the correct
dependencies are registered and the binary packages are distinct.

addresses PR pkg/28619 from H. Todd Fujinaka.

# $NetBSD: Makefile,v 1.2 2004/12/20 11:31:12 grant Exp $
#

DISTNAME=		Apache-Reload-0.07
PKGNAME=		p5-${DISTNAME}
SVR4_PKGNAME=		p5arl
PKGREVISION=		1
CATEGORIES=		www perl5
MASTER_SITES=		${MASTER_SITE_PERL_CPAN:=Apache/}

MAINTAINER=		hiramatu@boreas.dti.ne.jp
COMMENT=		Perl5 module to reload changed modules

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_BUILDLINK3=		YES
PERL5_PACKLIST=		${PERL5_SITEARCH}/auto/Apache/Reload/.packlist

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"