[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / opera

Annotation of pkgsrc/www/opera/Makefile, Revision 1.38.2.1

1.38.2.1! snj         1: # $NetBSD: Makefile,v 1.40 2005/08/05 22:04:04 jdolecek Exp $
1.1       tron        2:
1.32      tron        3: DISTNAME=      opera-${OPERA_PKG_VERSION:S/u/pl/}
                      4: PKGREVISION=   # empty
1.1       tron        5: CATEGORIES=    www
1.32      tron        6: MASTER_SITES=  http://www.panix.com/opera/files/${OPERA_DIR}/ \
                      7:                ftp://ftp.hu-berlin.de/pub/www/opera/${OPERA_DIR}/ \
                      8:                http://ftp.sunet.se/pub/www/clients/Opera/${OPERA_DIR}/ \
                      9:                ftp://ftp.task.gda.pl/pub/opera/${OPERA_DIR}/ \
                     10:                ftp://ftp.tuwien.ac.at/infosys/browsers/opera/${OPERA_DIR}/ \
1.38.2.1! snj        11:                ftp://opera.nsc.no/pub/nsc.no/mirrors/operasoftware/${OPERA_DIR}/ \
1.32      tron       12:                ftp://ftp.opera.com/pub/opera/${OPERA_DIR}/
                     13: DISTFILES=     opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPERA_LANG}${EXTRACT_SUFX}
1.1       tron       14:
1.32      tron       15: MAINTAINER=    tech-pkg@NetBSD.org
1.1       tron       16: HOMEPAGE=      http://www.opera.com/
1.10      wiz        17: COMMENT=       Small, fast and customizable WWW client
1.1       tron       18:
1.32      tron       19: ONLY_FOR_PLATFORM=     NetBSD-*-i386 SunOS-*-sparc FreeBSD-*-i386
1.1       tron       20:
                     21: LICENSE=       opera-license
                     22:
1.32      tron       23: #PKG_INSTALLATION_TYPES=       overwrite pkgviews
                     24:
                     25: NO_CONFIGURE=           YES
                     26: NO_TOOLS=               YES
                     27: USE_LANGUAGES=          # empty
                     28:
1.25      bouyer     29: .include "../../mk/bsd.prefs.mk"
                     30:
1.32      tron       31: OPERA_LANG=            en
1.38.2.1! snj        32: OPERA_VER_DATE=                20050727
        !            33: OPERA_PKG_VERSION=     8.02
        !            34: OPERA_PKG_VERSION_DIR= 802
1.32      tron       35:
                     36: _OPERA_OPSYS?=         ${OPSYS}
                     37: _OPERA_MACHINE_ARCH?=  ${MACHINE_ARCH}
                     38:
                     39: .if (${_OPERA_OPSYS} == NetBSD)
                     40: DEPENDS+=      suse_x11>=7.3:../../emulators/${SUSE_DIR_PREFIX}_x11
                     41:
1.18      wiz        42: # we need the DIST_SUBDIR=. because of the inclusion of suse's Makefile.common
1.14      tron       43: DIST_SUBDIR=   .
1.13      tron       44: EXTRACT_ONLY=  # empty
                     45: PLIST_SRC=     ${WRKDIR}/PLIST_DYNAMIC
1.1       tron       46:
1.32      tron       47: EXTRACT_SUFX=          .rpm
                     48: OPERA_ARCH=            .i386
1.34      tron       49: OPERA_DIR=             linux/${OPERA_PKG_VERSION_DIR}/final/${OPERA_LANG}/${OPERA_ARCH:S/.//}/static
1.32      tron       50: OPERA_DIST_VERSION=    ${OPERA_PKG_VERSION:C/beta.*//:C/u.*//}-${OPERA_VER_DATE}.1-static-qt
                     51:
                     52: RPMFILES=      ${DISTFILES}
                     53: RPM2PKGSTRIP=  0
                     54:
                     55: .elif (${_OPERA_OPSYS} == FreeBSD)
                     56: EXTRACT_SUFX=          .tar.bz2
                     57: OPERA_ARCH=            .i386.freebsd
1.38.2.1! snj        58: OPERA_DIR=             unix/freebsd/${OPERA_PKG_VERSION_DIR}/final/${OPERA_LANG}/shared/gcc-2.95
1.32      tron       59: OPERA_DIST_VERSION=    ${OPERA_PKG_VERSION:C/u.*//}-${OPERA_VER_DATE}.1-static-qt
                     60:
                     61: WRKSRC=                        ${WRKDIR}/opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPERA_LANG}
                     62:
                     63: OWN_DIRS=              ${PREFIX}/share/opera/plugins
                     64:
                     65: .elif (${_OPERA_OPSYS} == SunOS) && (${_OPERA_MACHINE_ARCH} == sparc)
                     66: EXTRACT_SUFX=          .tar.bz2
                     67: OPERA_ARCH=            -sol8-sparc-local
1.34      tron       68: OPERA_DIR=             unix/solaris/${OPERA_PKG_VERSION_DIR}/final/${OPERA_LANG}/static
1.32      tron       69: OPERA_DIST_VERSION=    ${OPERA_PKG_VERSION:C/u.*//}-${OPERA_VER_DATE}.1-static-qt
                     70:
                     71: WRKSRC=                        ${WRKDIR}/opera-${OPERA_DIST_VERSION}${OPERA_ARCH}-${OPERA_LANG}
                     72:
                     73: BUILD_DEFS+=           INSTALL_ETC_OPERARC
                     74: INSTALL_ETC_OPERARC?=  no
                     75: OWN_DIRS=              ${PREFIX}/lib/opera/plugins
                     76:
                     77: .  if !empty(INSTALL_ETC_OPERARC:M[yY][eE][sS])
                     78: CONF_FILES+=           ${PREFIX}/share/opera/config/opera6rc \
                     79:                        /etc/opera6rc
                     80: CONF_FILES+=           ${PREFIX}/share/opera/config/opera6rc.fixed \
                     81:                        /etc/opera6rc.fixed
                     82: .  endif
1.25      bouyer     83:
1.32      tron       84: PLIST_SUBST+=          OPERA_VER_DATE=${OPERA_VER_DATE}
                     85: PLIST_SUBST+=          OPERA_PKG_VERSION=${OPERA_PKG_VERSION:C/u.*//}
1.16      tron       86:
1.32      tron       87: .endif
1.16      tron       88:
1.32      tron       89: .if (((${_OPERA_OPSYS} == SunOS) && (${_OPERA_MACHINE_ARCH} == sparc)) || (${_OPERA_OPSYS} == FreeBSD))
                     90: NO_BUILD=               YES
                     91: USE_PKGINSTALL=                YES
                     92:
1.33      tron       93: SUBST_CLASSES+=                opera
1.36      jlam       94: SUBST_STAGE.opera=     post-build
                     95: SUBST_FILES.opera=     man/opera.1
1.33      tron       96: SUBST_SED.opera=       -e 's,/usr/,${PREFIX}/,g'
1.25      bouyer     97:
1.32      tron       98: .endif
1.25      bouyer     99:
1.37      jlam      100: INSTALLATION_DIRS=     bin man/man1
                    101:
1.25      bouyer    102: do-build:
1.32      tron      103: .if (${_OPERA_OPSYS} == NetBSD)
                    104:        @ ${SED} -e 's#@EMULDIR@#${EMULDIR}#g' ${FILESDIR}/opera.sh > \
                    105:                ${WRKDIR}/opera
1.25      bouyer    106:
1.32      tron      107: post-install: post-install-manpage
                    108:        ${INSTALL_SCRIPT} ${WRKDIR}/opera ${PREFIX}/bin
                    109:
                    110: .include "../../emulators/suse_linux/Makefile.application"
                    111:
1.35      jlam      112: .if defined(MANCOMPRESSED) && !empty(MANCOMPRESSED:M[yY][eE][sS])
                    113: PKGSRC_USE_TOOLS+=     gzip
                    114: .endif
                    115:
1.32      tron      116: post-install-manpage:
1.35      jlam      117:   # The SuSE common makefile defines "MANCOMPRESSED=yes".
                    118: .  if defined(MANCOMPRESSED) && !empty(MANCOMPRESSED:M[yY][eE][sS])
1.32      tron      119:        ${GZIP_CMD} ${EMULDIR}/usr/share/man/man1/opera.1
                    120:        ${LN} -fs ../../${EMULSUBDIR}/usr/share/man/man1/opera.1.gz \
                    121:                ${PREFIX}/man/man1
                    122: .  else
                    123:        ${LN} -fs ../../${EMULSUBDIR}/usr/share/man/man1/opera \
                    124:                ${PREFIX}/man/man1
                    125: .  endif
                    126: .endif
                    127:
                    128: .if (((${_OPERA_OPSYS} == SunOS) && (${_OPERA_MACHINE_ARCH} == sparc)) || (${_OPERA_OPSYS} == FreeBSD))
1.25      bouyer    129: do-install:
1.32      tron      130:        @cd ${WRKSRC} && ${ECHO} "n" | ./install.sh --prefix=${PREFIX}
                    131:        @${ECHO} "=> You can ignore any previous lines about opera6rc"
                    132:        @${ECHO}
1.1       tron      133:
1.32      tron      134: post-install:
                    135:        @${INSTALL_MAN} ${WRKSRC}/man/opera.1 ${PREFIX}/man/man1
1.29      jschauma  136: .endif
                    137:
1.32      tron      138: # regenerate distinfo for all ports supported by this package
                    139: opera-distinfo:
1.38.2.1! snj       140:        ( echo '$$NetBSD: Makefile,v 1.40 2005/08/05 22:04:04 jdolecek Exp $$'; echo ''; \
1.32      tron      141:        _OPERA_OPSYS=NetBSD ${MAKE} distinfo 1>&2; \
                    142:                ${GREP} opera distinfo; \
                    143:        _OPERA_OPSYS=FreeBSD ${MAKE} distinfo 1>&2; \
                    144:                ${GREP} opera distinfo; \
                    145:        _OPERA_OPSYS=SunOS _OPERA_MACHINE_ARCH=sparc make distinfo 1>&2; \
                    146:                ${GREP} opera distinfo; \
                    147:        ) > distinfo.new
                    148:        ${MV} -f distinfo.new distinfo
                    149:
1.28      dmcmahil  150: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>