File:  [cvs.NetBSD.org] / pkgsrc / www / ocaml-curl / Makefile
Revision 1.3: download - view: text, annotated - select for diffs
Sun Oct 28 06:30:24 2012 UTC (12 years, 5 months ago) by asau
Branches: MAIN
CVS tags: HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.3 2012/10/28 06:30:24 asau Exp $
#

DISTNAME=		ocurl-0.5.3
PKGNAME=		ocaml-curl-0.5.3
EXTRACT_SUFX=		.tgz
PKGREVISION=		1
CATEGORIES=		www net devel
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=ocurl/}

MAINTAINER=		rich.neswold@gmail.com
HOMEPAGE=		http://sourceforge.net/projects/ocurl/
COMMENT=		OCaml bindings to the CURL library
LICENSE=		mit

MAKE_JOBS_SAFE=         no

DEPENDS+=               ocaml-findlib-[0-9]*:../../devel/ocaml-findlib

USE_TOOLS=		gmake
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--with-findlib

.include "../../mk/bsd.prefs.mk"

PLIST_VARS+=	opt
.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
    (${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "x86_64")
PLIST.opt=	yes
.endif

WRKSRC=			${WRKDIR}/ocurl
USE_LANGUAGES=		c

INSTALLATION_DIRS+=     lib/ocaml/site-lib

.include "../../lang/ocaml/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>