[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / navigator

Annotation of pkgsrc/www/navigator/Makefile.common, Revision 1.54

1.54    ! wiz         1: # $NetBSD: Makefile.common,v 1.53 2002/11/25 17:22:05 wiz Exp $
1.1       abs         2: #
                      3: # Common include file for communicator and navigator packages
                      4:
                      5: .include "../../mk/bsd.prefs.mk"
1.9       tron        6:
1.1       abs         7: # Note - the version will be overridden for certain architectures which
                      8: #       do not have the latest version available (eg: SunOS sparc)
1.50      abs         9: NS_VERS=       4.8
                     10: PKGNAME=       ${BINNAME}-4.80
1.12      tron       11: NS_ENCRYPTION= us
1.11      abs        12: LDAP_VERS=     40
1.19      abs        13:
1.50      abs        14: MASTER_SITES=  ftp://ftp.netscape.com/pub/communicator/${SUB}/ \
                     15:                ftp://ftp.de.netscape.com/pub/communicator/${SUB}/ \
1.19      abs        16:                ftp://ftp-uk.netscape.com/pub/communicator/${SUB}/ \
                     17:                ftp://sunsite.utk.edu/pub/netscape/communicator/${SUB}/ \
                     18:                ftp://ftp.informatik.rwth-aachen.de/pub/mirror/ftp.netscape.com/pub/communicator/${SUB}/
1.1       abs        19: #
                     20: # Based on OPSYS and MACHINE_ARCH, define:
1.11      abs        21: #      PLIST_ARCH      ARCH specific PLIST contents
1.1       abs        22: #      DISTUNAME       Used to determine DISTNAME (tarfile on ftp server)
                     23: #      DIST_DIR_NAME   Directory on ftp site from which to download
                     24: #      WRKNAME         Used to determine WRKSRC (directoryname in tarfile)
                     25: #      VENDOR_NAME     Only used in '128-bit key version' information message
                     26: #
                     27: .if ${OPSYS} == "SunOS" && ${MACHINE_ARCH} == "sparc"
1.10      abs        28: PLIST_ARCH=    solaris-sparc
1.41      tron       29: .if (${OS_VERSION} == 5.5.1) || (${OS_VERSION} == 5.6) || \
                     30:     (${OS_VERSION} == 5.7)
1.50      abs        31: NS_VERS=       4.79
                     32: PKGNAME=       ${BINNAME}-${NS_VERS}
1.1       abs        33: DISTUNAME=     sparc-sun-solaris2.5.1
1.44      abs        34: DIST_DIR_NAME= supported/sunos551
1.1       abs        35: WRKNAME=       sparc-sun-solaris2.5.1
                     36: VENDOR_NAME=   Solaris 2.5.1
1.41      tron       37: .else
                     38: DISTUNAME=     sparc-sun-solaris2.8
                     39: DIST_DIR_NAME= supported/sunos58
                     40: WRKNAME=       sparc-sun-solaris2.8
                     41: VENDOR_NAME=   Solaris 2.8
                     42: .endif
1.38      wiz        43: .if !defined(NS_NO_FLASH)
1.30      jlam       44: DEPENDS+=      ns-flash>4.0:../../graphics/ns-flash
1.38      wiz        45: .endif
1.1       abs        46: #
                     47: .elif (${MACHINE_ARCH} == "alpha")
                     48: .if !exists(/emul/osf1/sbin/loader)
1.18      hubertf    49: IGNORE=        "${PKGNAME} requires Digital UNIX libraries - see compat_osf1(8)"
1.1       abs        50: .endif
1.44      abs        51: NS_VERS=       4.78
1.50      abs        52: PKGNAME=       ${BINNAME}-${NS_VERS}
1.10      abs        53: PLIST_ARCH=    osf-alpha
1.1       abs        54: DISTUNAME=     alpha-dec-osf4.0
                     55: DIST_DIR_NAME= supported/dec_unix40
                     56: WRKNAME=       alpha-dec-osf4.0
                     57: VENDOR_NAME=   Tru64 UNIX
                     58: #
1.10      abs        59: .elif (${MACHINE_ARCH} == "i386" && defined(NS_USE_BSDI))
1.24      tron       60: NS_VERS=       4.75
1.50      abs        61: PKGNAME=       ${BINNAME}-${NS_VERS}
1.10      abs        62: PLIST_ARCH=    bsdi-i386
                     63: DISTUNAME=     x86-bsdi-bsd2
                     64: DIST_DIR_NAME= unsupported/bsdi21
                     65: WRKNAME=       x86-bsdi-bsd2
                     66: VENDOR_NAME=   BSD/OS 2.1
                     67: #
1.1       abs        68: .elif (${MACHINE_ARCH} == "i386")
1.10      abs        69: PLIST_ARCH=    linux-i386
1.45      tron       70: DEPENDS+=      suse_compat>=6.4:../../emulators/${SUSE_DIR_PREFIX}_compat
                     71: DEPENDS+=      suse_x11>=6.4:../../emulators/${SUSE_DIR_PREFIX}_x11
1.7       sakamoto   72: DISTUNAME=     x86-unknown-linux2.2
1.14      tron       73: DIST_DIR_NAME= supported/linux22
1.7       sakamoto   74: WRKNAME=       x86-unknown-linux2.2
                     75: VENDOR_NAME=   Linux 2.2
1.38      wiz        76: .if !defined(NS_NO_FLASH)
1.30      jlam       77: DEPENDS+=      ns-flash>4.0:../../graphics/ns-flash
1.38      wiz        78: .endif
1.1       abs        79: #
1.49      dmcmahil   80: .elif (((${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "sparc64")) && defined(NS_USE_SUNOS))
1.1       abs        81: .if !exists(/emul/sunos/usr/lib/ld.so)
1.18      hubertf    82: IGNORE=        "${PKGNAME} requires SunOS libraries - see compat_sunos(8)"
1.1       abs        83: .endif
                     84: NS_VERS=       4.61
1.50      abs        85: PKGNAME=       ${BINNAME}-${NS_VERS}
1.12      tron       86: NS_ENCRYPTION= export
1.11      abs        87: LDAP_VERS=     30
1.10      abs        88: PLIST_ARCH=    sunos-sparc
1.1       abs        89: DISTUNAME=     sparc-sun-sunos4.1.3_U1
                     90: DIST_DIR_NAME= unsupported/sunos413
                     91: WRKNAME=       ${DISTUNAME}
                     92: VENDOR_NAME=   SunOS 4.1.3
1.19      abs        93: MASTER_SITES=  ftp://archive.netscape.com/archive/communicator/${SUB}/
1.49      dmcmahil   94: #
                     95: .elif (${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "sparc64")
                     96: PLIST_ARCH=    solaris-sparc
                     97: .if !exists(/emul/svr4/usr/lib/ld.so)
                     98: IGNORE=        "${PKGNAME} requires Solaris libraries - see compat_svr4(8)"
                     99: .endif
1.51      jdc       100: NS_VERS=       4.79
                    101: PKGNAME=       ${BINNAME}-${NS_VERS}
1.49      dmcmahil  102: DISTUNAME=      sparc-sun-solaris2.5.1
                    103: DIST_DIR_NAME=  supported/sunos551
                    104: WRKNAME=        sparc-sun-solaris2.5.1
                    105: VENDOR_NAME=    Solaris 2.5.1
1.31      kei       106: #
                    107: .elif (${MACHINE_ARCH} == "powerpc")
                    108: .if (${BINNAME} == "navigator")
                    109: IGNORE=                "There is no navigator-only package for PowerPC"
                    110: IGNORE+=       "platform.  Please cd to ../communicator and"
                    111: IGNORE+=       "install communicator package instead."
                    112: .endif
1.37      wiz       113: DEPENDS+=      linuxppc_lib>=2000.4.2:../../emulators/linuxppc_lib
1.31      kei       114: NS_VERS=       4.73
1.50      abs       115: PKGNAME=       ${BINNAME}-${NS_VERS}
1.31      kei       116: DISTNAME=      netscape-4.7-3.ppc
                    117: WRKSRC=                ${WRKDIR}
1.54    ! wiz       118: # was: ftp://ftp.linuxppc.org/linuxppc-halloween/software/ \
1.53      wiz       119: MASTER_SITES=  ftp://ftp.riken.go.jp/pub/Linux/linuxppc/linuxppc-halloween/software/ \
                    120:                ftp://gd.tuwien.ac.at/linux/linuxppc/linuxppc-halloween/software/
1.31      kei       121: EXTRACT_SUFX=  .rpm
                    122: HOMEPAGE=      http://linuxppc.org/software/index/linuxppc_stable/software/netscape-4.7-3.ppc.html
1.32      hubertf   123: BUILD_DEPENDS= rpm2pkg-1.2:../../pkgtools/rpm2pkg
1.31      kei       124: DESCR_SRC=     ${WRKDIR}/DESCR.linux-powerpc
                    125: PLIST_SRC=     ${WRKDIR}/PLIST_DYNAMIC
                    126: SORT=          sort
                    127: RPM2PKG=       rpm2pkg
1.33      kei       128: RPM2PKGARGS=   ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX}
1.36      wiz       129: VENDOR_NAME=   # empty.  what should be here?
1.43      abs       130: .else
                    131: PLIST_ARCH=
1.1       abs       132: .endif
                    133: #
                    134:
1.34      tron      135: MAINTAINER=    tron@netbsd.org
1.31      kei       136: HOMEPAGE?=     http://home.netscape.com/browsers/index.html
1.5       abs       137: RESTRICTED=    "No re-distribution without agreement from Netscape"
1.17      hubertf   138: NO_SRC_ON_CDROM=       ${RESTRICTED}
                    139: NO_BIN_ON_CDROM=       ${RESTRICTED}
                    140: NO_SRC_ON_FTP=         ${RESTRICTED}
                    141: NO_BIN_ON_FTP=         ${RESTRICTED}
1.1       abs       142:
1.42      abs       143: ONLY_FOR_PLATFORM= *-*-alpha *-*-i386 *-*-powerpc *-*-sparc *-*-sparc64
1.20      abs       144: CATEGORIES=    www
1.29      abs       145: NS_NAME=       ${BINNAME}-${NS_VERS}
1.34      tron      146: PKGNAME?=      ${BINNAME}-${NS_VERS}
1.31      kei       147: DISTNAME?=     ${BINNAME}-v${NS_VERS_SHORT}-${NS_ENCRYPTION}.${DISTUNAME}
1.20      abs       148:
                    149: .if (${BINNAME} != "netscape")
                    150:
1.50      abs       151: NO_BUILD=      YES
                    152:
1.31      kei       153: .if (${MACHINE_ARCH} == "powerpc")
                    154:
                    155: do-extract:
                    156:        ${MKDIR} ${WRKSRC}
                    157:
                    158: do-install:
                    159:        ${CP} ${PKGDIR}/DESCR.linux-powerpc ${WRKDIR}
                    160:        ${RM} -f ${PLIST_SRC}
1.33      kei       161:        ${RPM2PKG} -d ${PREFIX} -f ${PLIST_SRC} -s 1 ${RPM2PKGARGS}
                    162:
                    163:        ${SED} -e 's#@BINNAME@#${BINNAME}#g' \
                    164:               -e 's#@PREFIX@#${PREFIX}#g' \
                    165:            <${FILESDIR}/${BINNAME}.sh.linux-powerpc >${WRKDIR}/${BINNAME}.sh
                    166:        ${INSTALL_SCRIPT} ${WRKDIR}/${BINNAME}.sh ${PREFIX}/bin/${NS_NAME}
                    167:        ${RM} -f ${PREFIX}/bin/${BINNAME}
                    168:        ${LN} -sf ${NS_NAME} ${PREFIX}/bin/${BINNAME}
                    169:        ${ECHO} bin/${BINNAME} >> ${PLIST_SRC}
                    170:        ${ECHO} bin/${NS_NAME} >> ${PLIST_SRC}
1.31      kei       171:        ${SORT} -r ${PLIST_SRC} > ${PLIST_SRC}.sorted
                    172:        ${MV} ${PLIST_SRC}.sorted ${PLIST_SRC}
                    173:
                    174: .else
                    175:
1.20      abs       176: NS_VERS_SHORT= ${NS_VERS:S/.//}
                    177: SUB=           english/${NS_VERS}/unix/${DIST_DIR_NAME}/${DIST_SDIR_NAME}
                    178:
1.1       abs       179: BUILD_DEFS+=   NS_ENCRYPTION
                    180: DIST_SUBDIR=   netscape
                    181:
                    182: WRKSRC=         ${WRKDIR}/${BINNAME}-v${NS_VERS_SHORT}.${WRKNAME}
1.29      abs       183: MOZILLA_HOME=  ${PREFIX}/lib/netscape/${NS_NAME}
1.1       abs       184: NS_PLUGINS_DIR=        ${PREFIX}/lib/netscape/plugins
                    185:
                    186: PLIST_SRC=     ${PKGDIR}/PLIST.pre \
1.10      abs       187:                ${PKGDIR}/PLIST.${PLIST_ARCH} \
1.1       abs       188:                ${PKGDIR}/PLIST.post
1.10      abs       189: PLIST_SUBST+=  NS_VERS=${NS_VERS} LDAP_VERS=${LDAP_VERS} BINNAME=${BINNAME}
1.1       abs       190:
                    191: do-install:
1.27      hubertf   192:        ${INSTALL_DATA_DIR} ${MOZILLA_HOME}/java/classes
1.1       abs       193:        ${INSTALL_SCRIPT} ${WRKSRC}/vreg ${MOZILLA_HOME}
                    194: .for file in ifc11.jar iiop10.jar jae40.jar java40.jar jio40.jar jsd10.jar \
1.7       sakamoto  195:     ldap${LDAP_VERS}.jar resource.jar scd10.jar
1.1       abs       196:        ${INSTALL_DATA} ${WRKSRC}/${file} ${MOZILLA_HOME}/java/classes
                    197: .endfor
1.52      wiz       198:        cd ${MOZILLA_HOME} ; ${DECOMPRESS_CMD} \
                    199:                ${WRKSRC}/nethelp-v${NS_VERS_SHORT}.nif | ${PAX} -r
                    200:        cd ${MOZILLA_HOME} ; ${DECOMPRESS_CMD} \
                    201:                ${WRKSRC}/netscape-v${NS_VERS_SHORT}.nif | ${PAX} -cr \
                    202:                '*libflashplayer.so' '*ShockwaveFlash.class' '*dynMotif*' \
                    203:                || ${TRUE}
1.1       abs       204: .if (${BINNAME} == "communicator")
                    205:        cd ${MOZILLA_HOME} ; ${GTAR} xpzf ${WRKSRC}/spellchk-v${NS_VERS_SHORT}.nif
                    206: .endif
                    207:
                    208:        ${SED} -e 's#@@MOZILLA_HOME@@#${MOZILLA_HOME}#g' \
                    209:               -e 's#@@NS_PLUGINS_DIR@@#${NS_PLUGINS_DIR}#g' \
                    210:            <${FILESDIR}/${BINNAME}.sh >${WRKDIR}/${BINNAME}.sh
1.29      abs       211:        ${INSTALL_SCRIPT} ${WRKDIR}/${BINNAME}.sh ${PREFIX}/bin/${NS_NAME}
1.1       abs       212:        ${RM} -f ${PREFIX}/bin/${BINNAME}
1.29      abs       213:        ${LN} -sf ${NS_NAME} ${PREFIX}/bin/${BINNAME}
1.1       abs       214:
1.42      abs       215: .if ${PLIST_ARCH} == "sunos-sparc"
1.1       abs       216:        # Bizarre magic to handle the NIS and DNS versions. Make DNS default.
                    217:        @${SED} -e 's#MOZILLA_HOME/netscape#MOZILLA_HOME/netscape_nis#g' \
                    218:            <${WRKDIR}/${BINNAME}.sh >${WRKDIR}/${BINNAME}_nis.sh
                    219:        ${INSTALL_SCRIPT} ${WRKDIR}/${BINNAME}_nis.sh \
1.29      abs       220:            ${PREFIX}/bin/${NS_NAME}_nis
1.1       abs       221: .if (${BINNAME} == "communicator")
1.29      abs       222:        ${LN} -sf ${NS_NAME}_nis ${PREFIX}/bin/netscape_nis
1.1       abs       223: .endif
                    224:        ${MV} ${MOZILLA_HOME}/netscape ${MOZILLA_HOME}/netscape_nis
                    225:        ${MV} ${MOZILLA_HOME}/netscape_dns ${MOZILLA_HOME}/netscape
                    226: .endif
                    227:        ${INSTALL_DATA_DIR} ${NS_PLUGINS_DIR}
                    228:
                    229:        ${CHOWN} -R 0:0 ${MOZILLA_HOME}
                    230:        ${CHMOD} -R go-w ${MOZILLA_HOME}
1.31      kei       231: .endif
1.1       abs       232:
1.20      abs       233: .endif
1.46      tron      234:
1.47      tron      235: .if (${BINNAME} != "netscape")
1.50      abs       236: USE_BUILDLINK2=        # defined
1.46      tron      237: .include "../../emulators/suse_linux/Makefile.application"
1.47      tron      238: .endif

CVSweb <webmaster@jp.NetBSD.org>