[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / links

File: [cvs.NetBSD.org] / pkgsrc / www / links / Makefile.common (download)

Revision 1.62, Mon Jul 20 23:03:24 2015 UTC (8 years, 9 months ago) by dholland
Branch: MAIN
Changes since 1.61: +4 -6 lines

Update www/links{,gui} to links-{,gui-}2.10.
From Leo Taccari in PR 50072.

pkgsrc changes:
o Convert all the old links-xz and links-zlib options to lzma and zlib2.
o Do not include the bzip2, xz and zlib buildlink3.mk files: they are
  handled in www/links/options.mk.
o Add "svg" option for links-gui (disabled by default) to reflect
  upstream change.

Changes:
o Fix "Counld not assing boundary" bug when posting a form
  The bug was found by Greg Cook
o SVG support using the rsvg library
o Attach to existing links instance instead of creating a new instance
o Detect image type based on the first few bytes rather than on
  content-type
o New glyphs taken from Volker's git
o Fixed a bug on Windows where dns lookup got stuck if we closed the
  primary instance (which resulted in fork) while the lookup was in
  progress
o Use OpenMP in the image scaler
o Fixed a bug where the output of font sharpening depended on data read
  from uninitialized memory
o Preallocate downloaded files on Linux
o Support libevent and libev
o Enable SSL SNI, some servers need it
o Test for RAND_* functions in configure because libressl doesn't have
  them
o Support keepalive on https connections

# $NetBSD: Makefile.common,v 1.62 2015/07/20 23:03:24 dholland Exp $
#
# used by www/links/Makefile
# used by www/links-gui/Makefile

DISTNAME=	links-2.10
CATEGORIES=	www
MASTER_SITES=	http://links.twibright.com/download/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://links.twibright.com/
LICENSE=	gnu-gpl-v2 # including special OpenSSL paragraph

GNU_CONFIGURE=		YES

PLIST_SRC=		${.CURDIR}/../../www/links/PLIST
PATCHDIR=		${.CURDIR}/../../www/links/patches
DISTINFO_FILE=		${.CURDIR}/../../www/links/distinfo

INSTALLATION_DIRS=	share/doc/links

.include "options.mk"

post-install:
	${INSTALL_DATA} ${WRKSRC}/KEYS ${DESTDIR}${PREFIX}/share/doc/links

.include "../../devel/libevent/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"