[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / libwww

File: [cvs.NetBSD.org] / pkgsrc / www / libwww / Makefile (download)

Revision 1.14, Sun Oct 15 12:56:25 2000 UTC (23 years, 5 months ago) by fredb
Branch: MAIN
Changes since 1.13: +6 -4 lines

Remove hidden dependency on "automake", and remove dependency on
"autoconf", too, while we're at it.

# $NetBSD: Makefile,v 1.14 2000/10/15 12:56:25 fredb Exp $
# FreeBSD Id: Makefile,v 1.10 1998/06/14 23:34:59 jseger Exp
#

DISTNAME=		w3c-${PKGNAME}
PKGNAME=		libwww-5.3.1
CATEGORIES=		www devel
MASTER_SITES=		http://www.w3.org/Library/Distribution/ \
			ftp://ftp.uni-hannover.de/pub/mirror/info-systems/WWW/libwww/

MAINTAINER=		tv@netbsd.org
HOMEPAGE=		http://www.w3.org/Library/

USE_GMAKE=		yes
USE_LIBTOOL=		yes
USE_SSL=		yes

GNU_CONFIGURE=		yes
CONFIGURE_ARGS=		--with-zlib --with-regex --without-x
CONFIGURE_ARGS+=	--with-ssl

DOCDIR=			${PREFIX}/share/doc/libwww
LTCONFIG_OVERRIDE=	${WRKSRC}/config/ltconfig

pre-configure:
	cd ${WRKSRC}; \
	    for foo in configure.in aclocal.m4 `find . -name Makefile.in` \
		    configure stamp-h.in; do \
		${TOUCH} $$foo; \
	    done

.include "../../mk/bsd.prefs.mk"

# Include SOCKS firewall support
.if defined(USE_SOCKS) && (${USE_SOCKS} == 4 || ${USE_SOCKS} == 5)
.if ${USE_SOCKS} == 4
CONFIGURE_ARGS+= 	--with-socks --with-socks4 --without-socks5
DEPENDS+=		socks4-2.2:../../net/socks4
.else
CONFIGURE_ARGS+= 	--with-socks --without-socks4 --with-socks5
DEPENDS+=		socks5-1.0.2:../../net/socks5
.endif
.endif

.include "../../mk/bsd.pkg.mk"