[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / ikiwiki

File: [cvs.NetBSD.org] / pkgsrc / www / ikiwiki / Makefile (download)

Revision 1.149, Sat Jun 24 13:10:44 2017 UTC (6 years, 9 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.148: +2 -2 lines

Update to 3.20170622. From the changelog:

* t/git-cgi.t: Wait 1 second before doing a revert that should work.
  This hopefully fixes a race condition in which the test failed
  around 6% of the time. (Closes: 862494)
* Guard against set-but-empty REMOTE_USER CGI variable on
  misconfigured nginx servers, and in general treat sessions with
  a set-but-empty name as if they were not signed in.
* When the CGI fails, print the error to stderr, not "Died"
* mdwn: Don't mangle <style> into <elyts> under some circumstances
* mdwn: Enable footnotes by default when using the default Discount
  implementation. A new mdwn_footnotes option can be used to disable
  footnotes in MultiMarkdown and Discount.
* mdwn: Don't enable alphabetically labelled ordered lists by
  default when using the default Discount implementation. A new
  mdwn_alpha_list option can be used to restore the old
  interpretation.
* osm: Convert savestate hook into a changes hook. savestate is not
  the right place to write wiki content, and in particular this
  breaks websetup if osm's dependencies are not installed, even
  if the osm plugin is not actually enabled. (Closes: #719913)
* toc: if the heading is of the form <h1 id="...">, use that for
  the link in the table of contents (but continue to generate
  <a name="index42"></a> in case someone was relying on it)
* color: Do not leak markup into contexts that take only the plain
  text, such as toc
* meta: Document [[!meta name="foo" content="bar"]]

# $NetBSD: Makefile,v 1.149 2017/06/24 13:10:44 schmonz Exp $
#

DISTNAME=		ikiwiki_3.20170622
PKGNAME=		${DISTNAME:S/_/-/}
CATEGORIES=		www textproc
MASTER_SITES=		${MASTER_SITE_DEBIAN:=pool/main/i/ikiwiki/}
EXTRACT_SUFX=		.tar.xz

MAINTAINER=		schmonz@NetBSD.org
HOMEPAGE=		https://ikiwiki.info/
COMMENT=		Flexible static site generator with dynamic features
LICENSE=		gnu-gpl-v2

# ./pm_filter /usr/pkg 3.20141016 /usr/pkg/lib/perl5/vendor_perl/5.20.0 < ikiwiki.in > ikiwiki.out
# sh: ./pm_filter: not found
MAKE_JOBS_SAFE=		no

DEPENDS+=		p5-Text-Markdown-Discount-[0-9]*:../../textproc/p5-Text-Markdown-Discount
DEPENDS+=		p5-URI>=1.36:../../www/p5-URI
DEPENDS+=		p5-HTML-Parser-[0-9]*:../../www/p5-HTML-Parser
DEPENDS+=		p5-HTML-Template-[0-9]*:../../www/p5-HTML-Template
DEPENDS+=		p5-HTML-Tree-[0-9]*:../../www/p5-HTML-Tree
DEPENDS+=		p5-Mail-Sendmail-[0-9]*:../../mail/p5-Mail-Sendmail
DEPENDS+=		p5-Time-Duration-[0-9]*:../../time/p5-Time-Duration
DEPENDS+=		p5-TimeDate-[0-9]*:../../time/p5-TimeDate
DEPENDS+=		p5-HTML-Scrubber>=0.08:../../www/p5-HTML-Scrubber
DEPENDS+=		p5-JSON-[0-9]*:../../converters/p5-JSON
DEPENDS+=		p5-RPC-XML-[0-9]*:../../net/p5-RPC-XML
DEPENDS+=		p5-XML-Atom-[0-9]*:../../textproc/p5-XML-Atom
DEPENDS+=		p5-XML-Feed-[0-9]*:../../textproc/p5-XML-Feed
DEPENDS+=		p5-XML-Simple-[0-9]*:../../textproc/p5-XML-Simple
DEPENDS+=		p5-XML-RSS-[0-9]*:../../textproc/p5-XML-RSS
DEPENDS+=		p5-File-MimeInfo-[0-9]*:../../devel/p5-File-MimeInfo
DEPENDS+=		p5-gettext-[0-9]*:../../devel/p5-gettext
DEPENDS+=		p5-YAML-LibYAML-[0-9]*:../../textproc/p5-YAML-LibYAML

WRKSRC=			${WRKDIR}/${PKGNAME_NOREV}
PERL5_PACKLIST=		auto/IkiWiki/.packlist
USE_LANGUAGES=		c
USE_TOOLS+=		gmake msgfmt perl:run xgettext

REPLACE_PYTHON+=	plugins/proxy.py plugins/pythondemo plugins/rst

BUILD_TARGET=		extra_build all

MAKE_FLAGS+=		W3M_CGI_BIN=${PREFIX:Q}/libexec/w3m/cgi-bin
MAKE_FLAGS+=		SYSCONFDIR=${PKG_SYSCONFDIR:Q}
MAKE_FLAGS+=		MANDIR=${PREFIX:Q}/${PKGMANDIR:Q}

INSTALL_MAKE_FLAGS+=	SYSCONFDIR=${EGDIR:Q}

PKG_SYSCONFSUBDIR=	${PKGBASE}
EGDIR=			${PREFIX}/share/examples/${PKGBASE}
.for f in auto.setup auto-blog.setup wikilist
CONF_FILES+=		${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
.endfor

#SPECIAL_PERMS+=		${PREFIX}/bin/ikiwiki-update-wikilist ...

TEST_TARGET=		test

maintainer-find-default-perl-shebangs-not-substed:
	cd ${WRKSRC} && \
	find . -type f -print | \
	perl -ne 'open(F, "<$$_"); $$l=<F>; print if $$l =~ m|^#!/usr/bin/perl|'

.include "options.mk"

pre-configure:
	find ${WRKSRC} -type f -name '*.orig' -print | xargs rm -f

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "SunOS"
TOOLS_PLATFORM.find=	# empty, to force GNU find from pkgsrc findutils
.endif

.include "../../lang/perl5/module.mk"
.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"